IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

C# Discussion :

Request for the permission of type 'System.Security.Permissions.SecurityPermission, [. . .]' failed [Débutant]


Sujet :

C#

  1. #1
    r0d
    r0d est déconnecté
    Expert éminent

    Homme Profil pro
    Développeur de jeux vidéo
    Inscrit en
    août 2004
    Messages
    4 261
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ain (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur de jeux vidéo

    Informations forums :
    Inscription : août 2004
    Messages : 4 261
    Points : 6 603
    Points
    6 603
    Billets dans le blog
    2
    Par défaut Request for the permission of type 'System.Security.Permissions.SecurityPermission, [. . .]' failed
    Bonjour,

    j'ai récupéré un projet écrit en C#, mais il ne compile pas sur ma machine. Depuis ce matin, j'épluche le web à la recherche d'une solution mais je suis bloqué.
    Voici le message d'erreur complet:
    Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.'

    Ca ne concerne donc pas une ligne de code, mais des questions de sécurité du framework ou je ne sais quoi (je connais très très mal l'environnement .NET).

    Dans mes recherches, une réponse qui revient souvent consiste à modifier la politique de sécurité (security policy) et mettre la LocalIntranet zone en "fully trust". Le problème c'est que ne parviens pas à trouver cette option. Je soupçonne que cette option n'existe pas sur mon O.S. (Windows Server 2012 R2). Par exemple, aucun fichier du nom de 'mscorcfg' n'existe sur ma machine, quelle que soit l'extension.

    Une chose qui me met la puce à l'oreille, c'est que ce projet est configuré de façon à utiliser le framework .NET 2.0. Mais sur ma machine, quand je vais dans 'panneau de configuration -> programs and features', je constate que les frameworks 4.5 et 4.5.1 sont installés, mais pas le 2.0. Je croyais que chaque version d'un framework incluait les versions précédentes. Me trompe-je?

    Donc voilà, si quelqu'un a une idée de ce qui se passe, toute remarque est la bienvenue.

    Important note: je ne peux pas 'upgrader' ce projet vers un framework plus récent, question de contrainte qui vient de très haut. Comprenez que moi je ne demande que ça, mais ils détiennent ma femme et mes enfants, je ne peux pas rigoler avec ça...
    Tester c'est douter, corriger c'est abdiquer.

  2. #2
    Membre régulier
    Inscrit en
    novembre 2006
    Messages
    40
    Détails du profil
    Informations forums :
    Inscription : novembre 2006
    Messages : 40
    Points : 117
    Points
    117
    Par défaut
    Citation Envoyé par r0d Voir le message
    Dans mes recherches, une réponse qui revient souvent consiste à modifier la politique de sécurité (security policy) et mettre la LocalIntranet zone en "fully trust". Le problème c'est que ne parviens pas à trouver cette option. Je soupçonne que cette option n'existe pas sur mon O.S. (Windows Server 2012 R2). Par exemple, aucun fichier du nom de 'mscorcfg' n'existe sur ma machine, quelle que soit l'extension.
    Dans Internet explorer :
    Roue crantée : Option Internet -> Securité

    Citation Envoyé par r0d Voir le message
    Important note: je ne peux pas 'upgrader' ce projet vers un framework plus récent, question de contrainte qui vient de très haut. Comprenez que moi je ne demande que ça, mais ils détiennent ma femme et mes enfants, je ne peux pas rigoler avec ça...
    Aie aie aie !

  3. #3
    r0d
    r0d est déconnecté
    Expert éminent

    Homme Profil pro
    Développeur de jeux vidéo
    Inscrit en
    août 2004
    Messages
    4 261
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ain (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur de jeux vidéo

    Informations forums :
    Inscription : août 2004
    Messages : 4 261
    Points : 6 603
    Points
    6 603
    Billets dans le blog
    2
    Par défaut
    Hello,
    merci de t'intéresser à mon problème

    Alors, je suis allé dans les options de sécurité de IE, et j'ai tout désactivé. C'est à dire que dans Internet et dans Local intranet, j'ai décoché "Enable Protected Mode". C'est ce que tu voulais dire?
    Parce que ça change rien au niveau de la compilation de mon projet
    Tester c'est douter, corriger c'est abdiquer.

  4. #4
    Membre actif
    Homme Profil pro
    Analyste Programmeur
    Inscrit en
    septembre 2008
    Messages
    176
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Analyste Programmeur
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : septembre 2008
    Messages : 176
    Points : 297
    Points
    297
    Par défaut
    Bonjour,

    j'ai regardé sur un serveur 2012 auquel j'ai accès et je peux te confirmer que le framework 2.0 n'est pas installé par défaut.
    Tu peux vérifier les frameworks installés comme ceci : http://msdn.microsoft.com/fr-fr/libr...v=vs.110).aspx

    A partir de là, si le framework n'y est pas, un peu normal que tu ne puisse pas compiler.

    Je croyais que chaque version d'un framework incluait les versions précédentes.
    Rumeur à laquelle j'ai longtemps cru également.

    Bonne continuation.
    L’aléatoire n’existe pas en informatique, c’est juste un moyen de dire que l’on a pas encore compris.

  5. #5
    r0d
    r0d est déconnecté
    Expert éminent

    Homme Profil pro
    Développeur de jeux vidéo
    Inscrit en
    août 2004
    Messages
    4 261
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ain (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur de jeux vidéo

    Informations forums :
    Inscription : août 2004
    Messages : 4 261
    Points : 6 603
    Points
    6 603
    Billets dans le blog
    2
    Par défaut
    Bon, le problème est résolu, mais je n'ai pas la moindre idée du 'pourquoi'.
    J'ai installé le framework 2.0, mais ça n'a rien changé. Au grès de mes tentatives, j'ai dû, à un moment donné, récupérer les sources (qui sont sur un dépôt svn à la base) sur le C: (sur cette machine, je ne met normalement que les programmes sur le C). Et là, tout a compilé direct... comprend pô
    Tester c'est douter, corriger c'est abdiquer.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 9
    Dernier message: 01/10/2013, 12h32
  2. Réponses: 0
    Dernier message: 22/04/2009, 13h07
  3. Réponses: 4
    Dernier message: 14/09/2007, 09h18
  4. Réponses: 0
    Dernier message: 21/08/2007, 22h08
  5. [VB.NET] System.Security.Permission ....
    Par ludovic85 dans le forum Windows Forms
    Réponses: 8
    Dernier message: 17/10/2006, 12h24

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo