IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Interfaces Graphiques Perl Discussion :

[Tk] Tag delete ne peut plus être recréé


Sujet :

Interfaces Graphiques Perl

  1. #1
    Membre chevronné Avatar de dmganges
    Homme Profil pro
    Retraité. Ne recherche pas un emploi.
    Inscrit en
    septembre 2011
    Messages
    1 376
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 69
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Retraité. Ne recherche pas un emploi.
    Secteur : Service public

    Informations forums :
    Inscription : septembre 2011
    Messages : 1 376
    Points : 2 023
    Points
    2 023
    Par défaut [Tk] Tag delete ne peut plus être recréé
    Bonsoir,
    Désolé me revoilà avec mes tags !

    Je delete sans pb des tags créés avec :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    # Clear Tags Input
    my $bulb = $Wm->Photo( -file => $Image ); 
    my $bouton_clearTagInput = $cadre_gestion->Button(
    	-image    => $bulb,
    	-command  => sub {
    		if ($TexteInput) {
    			$widget_input->tagDelete( 'g14' );
    			$LabMessage = "Surbrillances dans Input effacées !";
    		}
    	},
    );
    La création se fait ainsi :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    sub Regex {
    	if ( !$Regex ) {
    		$LabRegex   = "Regex vide !";
    		$LabMessage = "Regex vide !";
    		print "\a\a";
    		return;
    	}
    	$TexteInput = $widget_input->get( '1.0', 'end' );
    	my $Pattern = $Regex;
    	$Pattern =~ s/ /\\ /go;
    	$LabRegex = $Pattern;
    	my $i = 0;
    	my @Array = ($TexteInput =~ m/(\b.{0,40}$Pattern.{0,40}\b)/gx);
    	my $Nb = @Array;
    	if ($Nb == 1){
    		my @NewArray = split /$Pattern/, $TexteInput;
    		my @ChainePref = ( $Array[0] =~ m/($Pattern)/gx);
    		$widget_output->insert( 'end', $NewArray[0] );
    		$widget_output->see( 'end' );
    		$widget_output->update;
    		$widget_output->tagAdd( 'MARK', 'end -1 chars' );
    		my @Mark = $widget_output->tagRanges( 'MARK' );
    		my ($SelA, $SelB) = split /\./, $Mark[0];
    		$SelB = $SelB + length($ChainePref[0]);
    		my $SelLast = $SelA.".".$SelB;
    		
    		print "MARK=$Mark[0] SELLAST=$SelLast\n";
    		
    		$widget_input->see( $Mark[0] );
    		$widget_output->insert( 'end', $ChainePref[0], "g14");
    		
    		$widget_input->tagAdd( 'g14', $Mark[0], $SelLast);
    		$widget_input->update;
    		
    		$widget_output->insert( 'end', $NewArray[1] );
    		$LabRegex = $Pattern;
    	} else {
    		foreach my $Ligne ( @Array ) {
    			$widget_output->insert( 'end', ++$i .": ".$Ligne."\n" );
    		}
    	}
    }
    Après avoir fait un delete des tags, si je relance la fonction sub Regex() les tags ne sont pas recréés
    Je fais une trace qui me précise bien que je suis au même endroit.

    Si je recharge le widget_input et que je relance sub Regex() même pb, pas de tag !

    Y aurait-il une manip particulière à faire ?

    MERCI d'avance !

  2. #2
    Membre chevronné Avatar de dmganges
    Homme Profil pro
    Retraité. Ne recherche pas un emploi.
    Inscrit en
    septembre 2011
    Messages
    1 376
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 69
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations professionnelles :
    Activité : Retraité. Ne recherche pas un emploi.
    Secteur : Service public

    Informations forums :
    Inscription : septembre 2011
    Messages : 1 376
    Points : 2 023
    Points
    2 023
    Par défaut
    C'est OK :
    Après un :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    $widget_input->tagDelete( 'g14' );
    Il faut reconfigurer le widget :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    configurer_tags($widget_input);
    Ce qui donne :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    # Clear Tags Input
    $Bulb = $Wm->Photo( -file => $Bulb );
    my $bouton_clearTagInput = $cadre_gestion->Button(
    	-image    => $Bulb,
    	#-text    => "SurB",
    	-command  => sub {
    		if ($TexteInput) {
    			confirmation($Wm, "Faut-il effacer le surlignement dans Input ?") if ( $config{GLOBAL}{confirm} eq 'OUI');
    			if ($Reponse eq "OUI") {
    				$widget_input->tagDelete( 'g14' );
    				$LabMessage = "Surbrillances dans Input effacées !";
    			} else {
    				$LabMessage = "Surbrillances dans Input conservées !";
    			}
    		}
    		configurer_tags($widget_input);
    	},
    );

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [Toutes versions] Combobox qui ne peut plus être utilisé
    Par SylvainM dans le forum Macros et VBA Excel
    Réponses: 2
    Dernier message: 15/12/2014, 17h06
  2. Réponses: 2
    Dernier message: 26/10/2010, 16h07
  3. Réponses: 10
    Dernier message: 05/05/2010, 09h16
  4. Réponses: 8
    Dernier message: 20/07/2006, 12h30
  5. Réponses: 6
    Dernier message: 03/09/2003, 10h29

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo