Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Discussion :

2 carte reseau & 1 serveur web


Sujet :

Architecture

  1. #1
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mars 2012
    Messages
    9
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Yonne (Bourgogne)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Industrie

    Informations forums :
    Inscription : mars 2012
    Messages : 9
    Points : 8
    Points
    8
    Par défaut 2 carte reseau & 1 serveur web
    Bonjour les amis
    j'ai un PC qui tourne sous Windows 7 avec 2 cartes réseaux ethernet, mon souci c'est: est il possible d'avoir un seul serveur web (apache) accessible par les 2 adresse réseaux??
    Cordialement

  2. #2
    Expert éminent sénior
    Avatar de JML19
    Homme Profil pro
    Retraité : Electrotechnicien Electronicien Informaticien de la SNCF
    Inscrit en
    décembre 2010
    Messages
    13 315
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Corrèze (Limousin)

    Informations professionnelles :
    Activité : Retraité : Electrotechnicien Electronicien Informaticien de la SNCF
    Secteur : Transports

    Informations forums :
    Inscription : décembre 2010
    Messages : 13 315
    Points : 20 559
    Points
    20 559
    Billets dans le blog
    10
    Par défaut
    Bonjour

    Oui si tes deux cartes réseaux accède au réseau où se trouve ton serveur.
    Vous pouvez utiliser les FAQ (ICI) ou les Tutoriels (ICI) et aussi accéder au blog (ICI)

  3. #3
    Rédacteur

    Avatar de ram-0000
    Homme Profil pro
    Consultant en sécurité
    Inscrit en
    mai 2007
    Messages
    11 519
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 56
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Consultant en sécurité
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : mai 2007
    Messages : 11 519
    Points : 50 345
    Points
    50 345
    Par défaut
    Oui, quel est ton probleme ?
    Raymond
    Vous souhaitez participer à la rubrique Réseaux ? Contactez-moi

    Cafuro Cafuro est un outil SNMP dont le but est d'aider les administrateurs système et réseau à configurer leurs équipements SNMP réseau.
    e-verbe Un logiciel de conjugaison des verbes de la langue française.

    Ma page personnelle sur DVP
    .

  4. #4
    Membre actif
    Homme Profil pro
    Ingénieur systèmes et réseaux
    Inscrit en
    avril 2014
    Messages
    139
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur systèmes et réseaux

    Informations forums :
    Inscription : avril 2014
    Messages : 139
    Points : 271
    Points
    271
    Par défaut
    Il me semble que Windows "simple" (pas la licence serveur) à du mal avec plusieurs cartes sur le même réseau. En tout cas c'était le cas sur xp il y a encore quelques années. Maintenant sur 7 ou 8 je ne sais pas . Dans mon souvenir, il me semble que Windows n'utilise qu'une seule des 2 cartes, et la deuxième prend le relais sur la première si il y a un problème. Il y aussi des différences de priorités entre carte pour le wifi et carte pour ethernet. (Ethernet est prioritaire sur le wifi donc le wifi n'est pas utilisé).
    C'est pour faire une sorte de load balancing ?

  5. #5
    Futur Membre du Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mars 2012
    Messages
    9
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Yonne (Bourgogne)

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Industrie

    Informations forums :
    Inscription : mars 2012
    Messages : 9
    Points : 8
    Points
    8
    Par défaut
    Bonjour
    j'ai installé les 2 carte avec 2 adresses (192.168.20.111 et 169.254.2.89) et j'ai pu accéder au serveur par les 2 adresse. dans les pages de mon site web je dois tracer des courbe en realtime en récupérant des données d'un service web qui tourne sur le port 8181 et pour que les utilisateurs des 2 réseaux peuvent accéder aux données du service web j'ai pensé pour contourner le problème des adresse ip à utiliser le nom de la machine (mamachine:8181) et ca marché très bien, mais quand j'ai essayé d’accéder au site web par une autre machine (192.168.10.92) en tapant au navigateur l'adresse 192.168.20.111 je vois dans le navigateur le nom de ma machine (mamachine/index.php) sans pouvoir afficher la page, j'ai résolu le problème par l'ajout du nom de la machine dans le fichier hosts de windows: 192.168.20.111 mamachine
    le problème est que j'ai essayé la même procédure dans une autre machine (192.168.10.123) j'ai pas pu visualiser les pages en tapant le nom de la machine.
    Merci pour votre aide

  6. #6
    Expert éminent sénior
    Avatar de JML19
    Homme Profil pro
    Retraité : Electrotechnicien Electronicien Informaticien de la SNCF
    Inscrit en
    décembre 2010
    Messages
    13 315
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Corrèze (Limousin)

    Informations professionnelles :
    Activité : Retraité : Electrotechnicien Electronicien Informaticien de la SNCF
    Secteur : Transports

    Informations forums :
    Inscription : décembre 2010
    Messages : 13 315
    Points : 20 559
    Points
    20 559
    Billets dans le blog
    10
    Par défaut
    Bonjour

    Cette machine accède avec l'IP ? Si oui le fichier hosts doit jouer le même rôle!

    As-tu mis #PRE pour mettre en cache dans le fichiers hosts à la fin des lignes ?
    Vous pouvez utiliser les FAQ (ICI) ou les Tutoriels (ICI) et aussi accéder au blog (ICI)

Discussions similaires

  1. Réponses: 2
    Dernier message: 19/03/2014, 20h29
  2. Config carte reseau ethernet 10/100
    Par toto_titi dans le forum Réseau
    Réponses: 9
    Dernier message: 08/02/2012, 17h57
  3. serveur web invisible dans le reseau
    Par aminlove88 dans le forum Apache
    Réponses: 1
    Dernier message: 12/02/2009, 17h59
  4. Exploitation de base sur un serveur Web
    Par Oz-WereWolf dans le forum Installation
    Réponses: 10
    Dernier message: 07/03/2004, 22h52

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo