Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Publications Discussion :

Utiliser oBasic dans le Tableur (Calc)


Sujet :

Publications

  1. #1
    Rédacteur

    Utiliser oBasic dans le Tableur (Calc)
    Bonjour,

    Voici un tuto sur comment débuter avec oBasic dans le Tableur. Ce tutoriel ne sera qu'un élément de base pour la programmation, il ne contiendra pas toutes les commandes possibles, mais l'essentiel pour commencer à travailler avec Tableur (Calc).
    Le tuto se trouve ici.

    @+.
    N'oubliez pas le Tag afin de faciliter la recherche, et en votant cela permet de mieux la cibler.

    Je ne réponds pas aux messages privés s'ils sont liés à une question technique

  2. #2
    Community Manager

    ,
    Les tutoriels sur oBasic n'étant pas nombreux, celui-ci vient au bon moment.
    Merci beaucoup.
    Vous avez envie de contribuer au sein du Club Developpez.com ? Contactez-nous maintenant !
    Vous êtes passionné, vous souhaitez partager vos connaissances en informatique, vous souhaitez faire partie de la rédaction.
    Il suffit de vous porter volontaire et de nous faire part de vos envies de contributions :
    Rédaction d'articles/cours/tutoriels, Traduction, Contribution dans la FAQ, Rédaction de news, interviews et témoignages, Organisation de défis, de débats et de sondages, Relecture technique, Modération, Correction orthographique, etc.
    Vous avez d'autres propositions de contributions à nous faire ? Vous souhaitez en savoir davantage ? N'hésitez pas à nous approcher.

  3. #3
    Membre averti
    Simple et Précis.

    Merci pour ce tuto !

  4. #4

  5. #5
    Nouveau Candidat au Club
    Citation Envoyé par zoom61 Voir le message
    Bonjour,

    Voici un tuto sur comment débuter avec oBasic dans le Tableur. Ce tutoriel ne sera qu'un élément de base pour la programmation, il ne contiendra pas toutes les commandes possibles, mais l'essentiel pour commencer à travailler avec Tableur (Calc).
    Le tuto se trouve ici.

    @+.
    Merci pour ce tuto, mais quelques correctifs sur le tuto :
    § V-A-3 - La cellule active --> mettre : Dim maCellule as object
    ...
    maCellule = maFeuille.getCellRangeByName("A2")
    ...
    maCellule.FormulaLocal="=somme(A1:100)"
    § V-C-1 - Une Valeur --> Appeler la fonction Sub LireValeur()

  6. #6
    Rédacteur

    Citation Envoyé par jeep56 Voir le message
    Merci pour ce tuto, mais quelques correctifs sur le tuto :
    § V-A-3 - La cellule active --> mettre : Dim maCellule as object
    ...
    maCellule.FormulaLocal="=somme(A1:100)"
    § V-C-1 - Une Valeur --> Appeler la fonction Sub LireValeur()
    Corrections faites.

    Citation Envoyé par jeep56 Voir le message
    maCellule = maFeuille.getCellRangeByName("A2")
    Là, j'ai pas compris
    N'oubliez pas le Tag afin de faciliter la recherche, et en votant cela permet de mieux la cibler.

    Je ne réponds pas aux messages privés s'ils sont liés à une question technique

  7. #7
    Candidat au Club
    Très bon tuto
    Bonjour,

    C'est un très bon tuto pour débuter en macro sous libre office
    Je programme habituellement sous VBA Excel. Et ce n'est pas évident de passer de l'un à l'autre.


    § V-B-3 - Une formule

    Une petite erreur de frappe : maCellule.Formula = "=SUM(A1:A100") ne semble donc pas corrigé.

    De plus "=SUM(A1:A100)" génère une erreur de référence circulaire si la cellule de référence est "A1" comme dans le tuto

    Et "=SOMME(A1:A100)" en FomulaLocal ne fonctionne pas chez moi, il l'écrit comme un string. Une idée ?

    A+

  8. #8
    Rédacteur

    Citation Envoyé par Yopsom Voir le message
    C'est un très bon tuto pour débuter en macro sous libre office
    Je programme habituellement sous VBA Excel. Et ce n'est pas évident de passer de l'un à l'autre.
    Merci

    Citation Envoyé par Yopsom Voir le message
    Une petite erreur de frappe : maCellule.Formula = "=SUM(A1:A100") ne semble donc pas corrigé.

    De plus "=SUM(A1:A100)" génère une erreur de référence circulaire si la cellule de référence est "A1" comme dans le tuto
    C'est corrigé

    Citation Envoyé par Yopsom Voir le message
    Et "=SOMME(A1:A100)" en FomulaLocal ne fonctionne pas chez moi, il l'écrit comme un string. Une idée ?
    Le langage par défaut est bien le français !

    Cdlt.
    N'oubliez pas le Tag afin de faciliter la recherche, et en votant cela permet de mieux la cibler.

    Je ne réponds pas aux messages privés s'ils sont liés à une question technique

  9. #9
    Membre du Club
    Bonjour,

    Je m'y perds dans obasic par rapport à VBA, mais ce tuto sur les macro m'éclaire grandement.

    Cependant, quelle est dans le catalogue la différence entre la partie "Standard" et "VBAProject" svp ? les sous menus sont les mêmes .

    Dans lequel des 2 pourrais-je récupérer ma macro ?
    SVP

    merci

  10. #10
    Rédacteur

    Citation Envoyé par Mod77 Voir le message
    Cependant, quelle est dans le catalogue la différence entre la partie "Standard" et "VBAProject" svp ? les sous menus sont les mêmes .
    Standard : c'est quand la macro a été créée avec LibreOffice (ou Apache OpenOffice).
    VBAProject : c'est quand le fichier est issu de Microsoft Office (un fichier qui a été converti).
    N'oubliez pas le Tag afin de faciliter la recherche, et en votant cela permet de mieux la cibler.

    Je ne réponds pas aux messages privés s'ils sont liés à une question technique

  11. #11
    Membre du Club
    Citation Envoyé par zoom61 Voir le message
    Standard : c'est quand la macro a été créée avec LibreOffice (ou Apache OpenOffice).
    VBAProject : c'est quand le fichier est issu de Microsoft Office (un fichier qui a été converti).
    ok, merci! même si c'est tard

  12. #12
    Futur Membre du Club
    Bravo
    Votre tuto m'a bien aidé pour démarrer. J'ai beaucoup progressé depuis et il me semble aujourd'hui tellement simple... mais à l'époque quelle joie de trouver cet excellent tuto. Merci.

###raw>template_hook.ano_emploi###