1. #1
    Membre habitué
    Inscrit en
    août 2005
    Messages
    91
    Détails du profil
    Informations forums :
    Inscription : août 2005
    Messages : 91
    Points : 180
    Points
    180

    Par défaut Windev : Convertir un document (doc, docx, rtf) vers le format PDF avec les fonctions OLE d'Open Office

    Bonjour,

    Voici une petite procédure permettant de transformer tout type de document reconnu par Open Office (ou Libre Office) (doc, docx, rtf etc...) en document PDF :

    L'appel se fait de cette façon :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
     
    QUAND EXCEPTION DANS
    	DocumentVersPDF("c:\documentWord.doc","c:\documentWord.pdf")
    	Info("Document sauvegardé !")
    FAIRE
    	Erreur(ExceptionInfo(errComplet))
    FIN
    La procédure DocumentVersPDF :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
     
    PROCEDURE DocumentVersPDF(LOCAL _sDocCheminComplet est une chaîne,_sDocPDFCheminComplet est une chaîne="")
     
    LOCAL
    	oServiceManager est un objet OLE dynamique
    	oDesktop est un objet OLE dynamique
    	oDocument est un objet OLE dynamique
    	sMess est une chaîne
     
    SI PAS fFichierExiste(_sDocCheminComplet) ALORS
    	sMess = "Le document source n'existe pas."
    	ExceptionDéclenche(1,sMess)
    FIN
     
    QUAND EXCEPTION DANS
    	// Création d'un service OpenOffice si nécessaire
    	oServiceManager = allouer un objet OLE ("com.sun.star.ServiceManager")
    	oDesktop = oServiceManager>>createInstance("com.sun.star.frame.Desktop")
    FAIRE
    	sMess = "OpenOffice n'est pas installé sur votre poste."
    	ExceptionDéclenche(1,sMess)
    FIN
     
    tParams est un tableau de 0 objet Automation dynamique //Tableau de paramètres
     
    //Masqué
    CreateProperty(oServiceManager,tParams,"Hidden",Vrai)
    //Lecture seule
    //CreateProperty(oServiceManager,tParams,"ReadOnly",faux)
     
    //Formatage du chemin du fichier
    LOCAL
    	sDocCheminCompletTmp est une chaîne
     
    sDocCheminCompletTmp = "file:///"+Remplace(_sDocCheminComplet,"\","/")
    //Ouverture du fichier dans OpenOffice Writer
    oDocument = oDesktop>>LoadComponentFromURL(sDocCheminCompletTmp,"_blank",0,tParams)
    SI oDocument = Null ALORS
    	ExceptionDéclenche(1,"Impossible de charger le document source.")
    FIN
     
    TableauSupprimeTout(tParams)
    //CreateProperty(oServiceManager,tParams,"Magnification",2)
    //CreateProperty(oServiceManager,tParams,"EncryptFile",vrai)
    //CreateProperty(oServiceManager,tParams,"DocumentOpenPassword","Password")
    //CreateProperty(oServiceManager,tParams,"HideViewerWindowControls",vrai)
     
    oExportObject est un objet OLE dynamique
    oExportObject = oServiceManager>>Bridge_GetValueObject()
    oExportObject>>Set("[]com.sun.star.beans.PropertyValue",tParams);
     
    tFilterParams est un tableau de 0 objet Automation dynamique
    CreateProperty(oServiceManager,tFilterParams,"FilterName","writer_pdf_Export")
    CreateProperty(oServiceManager,tFilterParams,"FilterData",oExportObject)
     
    SI _sDocPDFCheminComplet = "" ALORS
    	_sDocPDFCheminComplet = fExtraitChemin(_sDocCheminComplet,fDisque+fRépertoire+fFichier)+".pdf"
    FIN
     
    LOCAL
    	sDocPDFCheminCompletTmp est une chaîne
     
    sDocPDFCheminCompletTmp = "file:///"+Remplace(_sDocPDFCheminComplet,"\","/")
     
    oDocument>>StoreToURL(sDocPDFCheminCompletTmp,tFilterParams);
     
    oDocument>>Close(Vrai);
     
    CAS EXCEPTION:
    	sMess = "Erreur lors de la sauvegarde du document : "+RC
    	sMess += "'"+_sDocCheminComplet+"'"+RC
    	sMess += "vers le document : "+RC
    	sMess += "'"+_sDocPDFCheminComplet+"'."+RC
    	ExceptionPropage(sMess+RC+RC+ExceptionInfo(errComplet))
    La procédure CreateProperty :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
     
    PROCEDURE CreateProperty(oServiceManager,__tArgs,_sName est une chaîne,_vValue)
     
    TableauAjoute(__tArgs)
    iNbOccurences est un entier = __tArgs..Occurrence
     
    __tArgs[iNbOccurences] = oServiceManager>>Bridge_GetStruct("com.sun.star.beans.PropertyValue") 
    __tArgs[iNbOccurences]>>Name = _sName
    __tArgs[iNbOccurences]>>Value = _vValue
    Bonne prog

  2. #2
    Community Manager

    Avatar de Lana.Bauer
    Femme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    novembre 2012
    Messages
    5 383
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : Allemagne

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux

    Informations forums :
    Inscription : novembre 2012
    Messages : 5 383
    Points : 12 089
    Points
    12 089

    Par défaut

    Bonjour,

    Pourriez-vous ajouter cette procédure comme Q/R dans la FAQ.

    Merci

  3. #3
    Membre éprouvé
    Homme Profil pro
    Responsable des études
    Inscrit en
    février 2010
    Messages
    505
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Responsable des études
    Secteur : High Tech - Électronique et micro-électronique

    Informations forums :
    Inscription : février 2010
    Messages : 505
    Points : 992
    Points
    992

    Par défaut

    Citation Envoyé par bastiencb Voir le message
    Bonjour,

    Voici une petite procédure permettant de transformer tout type de document reconnu par Open Office (ou Libre Office) (doc, docx, rtf etc...) en document PDF :

    L'appel se fait de cette façon :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
     
    QUAND EXCEPTION DANS
    	DocumentVersPDF("c:\documentWord.doc","c:\documentWord.pdf")
    	Info("Document sauvegardé !")
    FAIRE
    	Erreur(ExceptionInfo(errComplet))
    FIN
    La procédure DocumentVersPDF :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
     
    PROCEDURE DocumentVersPDF(LOCAL _sDocCheminComplet est une chaîne,_sDocPDFCheminComplet est une chaîne="")
     
    LOCAL
    	oServiceManager est un objet OLE dynamique
    	oDesktop est un objet OLE dynamique
    	oDocument est un objet OLE dynamique
    	sMess est une chaîne
     
    SI PAS fFichierExiste(_sDocCheminComplet) ALORS
    	sMess = "Le document source n'existe pas."
    	ExceptionDéclenche(1,sMess)
    FIN
     
    QUAND EXCEPTION DANS
    	// Création d'un service OpenOffice si nécessaire
    	oServiceManager = allouer un objet OLE ("com.sun.star.ServiceManager")
    	oDesktop = oServiceManager>>createInstance("com.sun.star.frame.Desktop")
    FAIRE
    	sMess = "OpenOffice n'est pas installé sur votre poste."
    	ExceptionDéclenche(1,sMess)
    FIN
     
    tParams est un tableau de 0 objet Automation dynamique //Tableau de paramètres
     
    //Masqué
    CreateProperty(oServiceManager,tParams,"Hidden",Vrai)
    //Lecture seule
    //CreateProperty(oServiceManager,tParams,"ReadOnly",faux)
     
    //Formatage du chemin du fichier
    LOCAL
    	sDocCheminCompletTmp est une chaîne
     
    sDocCheminCompletTmp = "file:///"+Remplace(_sDocCheminComplet,"\","/")
    //Ouverture du fichier dans OpenOffice Writer
    oDocument = oDesktop>>LoadComponentFromURL(sDocCheminCompletTmp,"_blank",0,tParams)
    SI oDocument = Null ALORS
    	ExceptionDéclenche(1,"Impossible de charger le document source.")
    FIN
     
    TableauSupprimeTout(tParams)
    //CreateProperty(oServiceManager,tParams,"Magnification",2)
    //CreateProperty(oServiceManager,tParams,"EncryptFile",vrai)
    //CreateProperty(oServiceManager,tParams,"DocumentOpenPassword","Password")
    //CreateProperty(oServiceManager,tParams,"HideViewerWindowControls",vrai)
     
    oExportObject est un objet OLE dynamique
    oExportObject = oServiceManager>>Bridge_GetValueObject()
    oExportObject>>Set("[]com.sun.star.beans.PropertyValue",tParams);
     
    tFilterParams est un tableau de 0 objet Automation dynamique
    CreateProperty(oServiceManager,tFilterParams,"FilterName","writer_pdf_Export")
    CreateProperty(oServiceManager,tFilterParams,"FilterData",oExportObject)
     
    SI _sDocPDFCheminComplet = "" ALORS
    	_sDocPDFCheminComplet = fExtraitChemin(_sDocCheminComplet,fDisque+fRépertoire+fFichier)+".pdf"
    FIN
     
    LOCAL
    	sDocPDFCheminCompletTmp est une chaîne
     
    sDocPDFCheminCompletTmp = "file:///"+Remplace(_sDocPDFCheminComplet,"\","/")
     
    oDocument>>StoreToURL(sDocPDFCheminCompletTmp,tFilterParams);
     
    oDocument>>Close(Vrai);
     
    CAS EXCEPTION:
    	sMess = "Erreur lors de la sauvegarde du document : "+RC
    	sMess += "'"+_sDocCheminComplet+"'"+RC
    	sMess += "vers le document : "+RC
    	sMess += "'"+_sDocPDFCheminComplet+"'."+RC
    	ExceptionPropage(sMess+RC+RC+ExceptionInfo(errComplet))
    La procédure CreateProperty :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
     
    PROCEDURE CreateProperty(oServiceManager,__tArgs,_sName est une chaîne,_vValue)
     
    TableauAjoute(__tArgs)
    iNbOccurences est un entier = __tArgs..Occurrence
     
    __tArgs[iNbOccurences] = oServiceManager>>Bridge_GetStruct("com.sun.star.beans.PropertyValue") 
    __tArgs[iNbOccurences]>>Name = _sName
    __tArgs[iNbOccurences]>>Value = _vValue
    Bonne prog

    Génial !! Merci pour le partage !

  4. #4
    Futur Membre du Club
    Profil pro
    Inscrit en
    janvier 2010
    Messages
    13
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : janvier 2010
    Messages : 13
    Points : 9
    Points
    9

    Par défaut

    Bonjour bastiencb

    Merci pour cette procédure, ça marche en effet du tonnerre !

    Est-ce qu'il y a une possibilité dans les propriétés de StoreToURL de dire "tu m'exportes la page 5 à 7 en pdf" ?

    Je ne trouve pas.

    Merci àtoi.

Discussions similaires

  1. Réponses: 0
    Dernier message: 26/02/2015, 16h01
  2. Ouvrir Document .doc/.docx DANS la Form
    Par mindhavok dans le forum VB.NET
    Réponses: 2
    Dernier message: 25/11/2011, 09h25
  3. Lire un document doc ou rtf dans Joomla
    Par jacma dans le forum Joomla
    Réponses: 2
    Dernier message: 11/01/2011, 14h16
  4. convertir des documents doc en pdf
    Par choupeo dans le forum Documents
    Réponses: 2
    Dernier message: 07/12/2007, 08h36

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo