IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Développement de jobs Discussion :

Version Java d'un composant


Sujet :

Développement de jobs

  1. #1
    Membre expert
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    juin 2007
    Messages
    2 938
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : juin 2007
    Messages : 2 938
    Points : 3 925
    Points
    3 925
    Par défaut Version Java d'un composant
    Bonjour tous,

    J'utilise la version Talend 5.4.1.
    Dans un de mes Jobs j'ai utilisé le composant TFileInputDelimited pour lire un fichier CSV. Mais quand j'exporte mon job pour en faire un batch et que je déploie sur un serveur unix, j'ai cette erreur d'incompatibilité de version Java :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    Exception in thread "main" java.lang.UnsupportedClassVersionError: (com/talend/csv/CSVReader) bad major version at offset=6
            at java.lang.ClassLoader.defineClassImpl(Native Method)
            at java.lang.ClassLoader.defineClass(ClassLoader.java:267)
            at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:151)
            at java.net.URLClassLoader.defineClass(URLClassLoader.java:601)
            at java.net.URLClassLoader.access$400(URLClassLoader.java:125)
            at java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:1056)
            at java.security.AccessController.doPrivileged(AccessController.java:274)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:493)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:650)
            at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:349)
    Pourtant je suis bien en Java compliance 1.5 sous Talend (mais dans l’interpréteur de commande Talend je suis en 1.6 pour que l'éxécution marche).
    Quelqu'un peut il me dire si ce composant dans la version TOS 5.4.1 ne peut être générée qu'en 1.6?
    Vous avez peut être hâte de réussir et il n'y a rien de mal à cela...
    mais la patience est aussi une vertu; l'échec vous l'enseignera certainement..."

  2. #2
    Membre émérite
    Avatar de haskouse
    Homme Profil pro
    Salesforce
    Inscrit en
    août 2009
    Messages
    923
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : Maroc

    Informations professionnelles :
    Activité : Salesforce
    Secteur : Conseil

    Informations forums :
    Inscription : août 2009
    Messages : 923
    Points : 2 684
    Points
    2 684
    Par défaut
    La version avec laquelle ton job Talend a été compilé ne correspond pas à la version avec laquelle tu veux l’exécuter sur ton serveur Linux.
    Bref pour que ça marche, recompile ton projet Talend avec la même version que le java de ton serveur Linux, ou bien installe la même version de java que celle de ton Talend sur ton serveur Linux.
    "Le savant qui enseigne le bien aux gens et ne le met pas en pratique, est semblable à la torche qui éclaire en se brûlant." Mohammed le Messager d’Allah (que la paix et le salut d'Allah soient sur lui)

    Tutoriels Talend
    Mes articles publiés
    Mon CV en-ligne

  3. #3
    Membre expert
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    juin 2007
    Messages
    2 938
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : juin 2007
    Messages : 2 938
    Points : 3 925
    Points
    3 925
    Par défaut
    Citation Envoyé par haskouse Voir le message
    La version avec laquelle ton job Talend a été compilé ne correspond pas à la version avec laquelle tu veux l’exécuter sur ton serveur Linux.
    Bref pour que ça marche, recompile ton projet Talend avec la même version que le java de ton serveur Linux, ou bien installe la même version de java que celle de ton Talend sur ton serveur Linux.
    Merci pour la réponse.
    Vu que je n'ai pas la main sur le serveur cible, on ne va donc pas retenir la solution de changer la version serveur cible.
    Et recompiler le projet sur le serveur cible aussi n'est pas propre je trouve.
    Alors je reformule ma question comment forcer Talend à recompiler tout le projet en 1.5 compatible? Pour rappel la compilation sous talend (en cliquant sur le bouton "code" se passe bien) mais à l’exécution sous le contrôle de talend ca plante déjà. Il m'oblige via Fênetre==>Préférence==>Talend==>Interpréteur Java à mettre du Java 1.6 pour que ça marche. D'où mon plantage sur le serveur cible.
    Vous avez peut être hâte de réussir et il n'y a rien de mal à cela...
    mais la patience est aussi une vertu; l'échec vous l'enseignera certainement..."

  4. #4
    Membre émérite
    Avatar de haskouse
    Homme Profil pro
    Salesforce
    Inscrit en
    août 2009
    Messages
    923
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : Maroc

    Informations professionnelles :
    Activité : Salesforce
    Secteur : Conseil

    Informations forums :
    Inscription : août 2009
    Messages : 923
    Points : 2 684
    Points
    2 684
    Par défaut
    Modifies les préférences de Talend pour le faire pointer sur la m^me version de JAVA que celle que tu as sur le serveur Linux.

    Nom : 1.jpg
Affichages : 582
Taille : 65,2 Ko
    Nom : 2.jpg
Affichages : 551
Taille : 61,8 Ko
    "Le savant qui enseigne le bien aux gens et ne le met pas en pratique, est semblable à la torche qui éclaire en se brûlant." Mohammed le Messager d’Allah (que la paix et le salut d'Allah soient sur lui)

    Tutoriels Talend
    Mes articles publiés
    Mon CV en-ligne

  5. #5
    Membre expert
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    juin 2007
    Messages
    2 938
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : juin 2007
    Messages : 2 938
    Points : 3 925
    Points
    3 925
    Par défaut
    Merci,
    mais j'avais déjà effectué ces manipulations, c'est un peu les bases de l'environnement Eclipse .
    J'ai mis 2 captures en PJ, dans la capture Nom : versionJava1.png
Affichages : 581
Taille : 71,8 Ko je suis bien en 1.5, aucun problème ici.
    Nom : versionJavaCompTalend.png
Affichages : 537
Taille : 64,5 Ko
    Mais Talend pour exécuter mon Job sous son contrôle m'impose de laisse la version de l'interpreteur de commande à 1.6 sinon il me crashe l'erreur de version si je passe à 1.5. J'espère me faire comprendre cette fois ci avec la dernière capture.
    Vous avez peut être hâte de réussir et il n'y a rien de mal à cela...
    mais la patience est aussi une vertu; l'échec vous l'enseignera certainement..."

  6. #6
    Membre émérite
    Avatar de haskouse
    Homme Profil pro
    Salesforce
    Inscrit en
    août 2009
    Messages
    923
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : Maroc

    Informations professionnelles :
    Activité : Salesforce
    Secteur : Conseil

    Informations forums :
    Inscription : août 2009
    Messages : 923
    Points : 2 684
    Points
    2 684
    Par défaut
    Quelle est la version utilisée dans le serveur en utilisant la commande "java -version" ?
    "Le savant qui enseigne le bien aux gens et ne le met pas en pratique, est semblable à la torche qui éclaire en se brûlant." Mohammed le Messager d’Allah (que la paix et le salut d'Allah soient sur lui)

    Tutoriels Talend
    Mes articles publiés
    Mon CV en-ligne

  7. #7
    Membre expert
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    juin 2007
    Messages
    2 938
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : juin 2007
    Messages : 2 938
    Points : 3 925
    Points
    3 925
    Par défaut
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    java version "1.5.0"
    Java(TM) 2 Runtime Environment, Standard Edition (build pap32dev-20111020 (SR13 ))
    IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 AIX ppc-32 j9vmap3223-20111019 (JIT enabled)
    J9VM - 20111017_92807_bHdSMr
    JIT  - 20110916_20782_r8
    GC   - 20110524_AA)
    JCL  - 20111019
    Vous avez peut être hâte de réussir et il n'y a rien de mal à cela...
    mais la patience est aussi une vertu; l'échec vous l'enseignera certainement..."

  8. #8
    Membre émérite
    Avatar de haskouse
    Homme Profil pro
    Salesforce
    Inscrit en
    août 2009
    Messages
    923
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : Maroc

    Informations professionnelles :
    Activité : Salesforce
    Secteur : Conseil

    Informations forums :
    Inscription : août 2009
    Messages : 923
    Points : 2 684
    Points
    2 684
    Par défaut
    Est ce que tu as déjà essayé de modifier le chemin de l’interpréteur JAVA dans Talend en pointant sur la version 1.5 ?
    "Le savant qui enseigne le bien aux gens et ne le met pas en pratique, est semblable à la torche qui éclaire en se brûlant." Mohammed le Messager d’Allah (que la paix et le salut d'Allah soient sur lui)

    Tutoriels Talend
    Mes articles publiés
    Mon CV en-ligne

  9. #9
    Membre expert
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    juin 2007
    Messages
    2 938
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : juin 2007
    Messages : 2 938
    Points : 3 925
    Points
    3 925
    Par défaut
    Citation Envoyé par haskouse Voir le message
    Est ce que tu as déjà essayé de modifier le chemin de l’interpréteur JAVA dans Talend en pointant sur la version 1.5 ?
    Oui Je l'avais déjà mentionné dans cette phrase :
    Mais Talend pour exécuter mon Job sous son contrôle m'impose de laisse la version de l'interpreteur de commande à 1.6 sinon il me crashe l'erreur de version si je passe à 1.5
    .
    Quelqu'un peut il me confirmer que pour une version donnée de Talend et un certain composant, une version minimum de la JDK est imposée? car c'est ce que je soupconne.
    J'ai quand même contourné le souci par une solution que je ne trouve pas du tout propre...
    Vous avez peut être hâte de réussir et il n'y a rien de mal à cela...
    mais la patience est aussi une vertu; l'échec vous l'enseignera certainement..."

  10. #10
    Membre émérite
    Avatar de haskouse
    Homme Profil pro
    Salesforce
    Inscrit en
    août 2009
    Messages
    923
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : Maroc

    Informations professionnelles :
    Activité : Salesforce
    Secteur : Conseil

    Informations forums :
    Inscription : août 2009
    Messages : 923
    Points : 2 684
    Points
    2 684
    Par défaut
    Désolé je n'avais pas compris.
    Sinon si tu utilises une version 5 et plus de Talend, je pense qu'il te faut un java 6 et plus.
    "Le savant qui enseigne le bien aux gens et ne le met pas en pratique, est semblable à la torche qui éclaire en se brûlant." Mohammed le Messager d’Allah (que la paix et le salut d'Allah soient sur lui)

    Tutoriels Talend
    Mes articles publiés
    Mon CV en-ligne

  11. #11
    Membre expert
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    juin 2007
    Messages
    2 938
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : juin 2007
    Messages : 2 938
    Points : 3 925
    Points
    3 925
    Par défaut
    Citation Envoyé par haskouse Voir le message
    Désolé je n'avais pas compris.
    Sinon si tu utilises une version 5 et plus de Talend, je pense qu'il te faut un java 6 et plus.
    En effet j'en suis arrivé à la même conclusion.
    Vous avez peut être hâte de réussir et il n'y a rien de mal à cela...
    mais la patience est aussi une vertu; l'échec vous l'enseignera certainement..."

Discussions similaires

  1. Application J2EE + version Java
    Par djuddju dans le forum Java EE
    Réponses: 2
    Dernier message: 09/04/2006, 10h15
  2. [ Variable environnement ] Version java
    Par lhpp dans le forum Général Java
    Réponses: 13
    Dernier message: 08/04/2006, 12h01
  3. [ Batch ] - Installeur suivant version java.
    Par lhpp dans le forum Autres Logiciels
    Réponses: 5
    Dernier message: 06/04/2006, 22h08
  4. [applet] gestion des versions Java
    Par bigVinz dans le forum Applets
    Réponses: 1
    Dernier message: 09/12/2005, 16h06

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo