+ Répondre à la discussion Actualité déjà publiée
Page 1 sur 2 12 DernièreDernière
  1. #1
    Rédacteur/Modérateur
    Avatar de regis1512
    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    mai 2008
    Messages
    1 263
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Haute Vienne (Limousin)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2008
    Messages : 1 263
    Points : 7 616
    Points
    7 616

    Par défaut [Article] Installation du gestionnaire de projets Redmine sous Windows

    Bonjour à tous,

    J'ai écrit un article intitulé "Installation du gestionnaire de projets Redmine sous Windows".

    Cet article présente l'installation pas à pas du logiciel de gestion de projets Redmine.

    Redmine est un logiciel de gestion de projets de type application Web. Un logiciel de gestion de projets permet de gérer le cycle de vie d'une application. Parmi les fonctionnalités courantes dans ce type de logiciel, on peut trouver : création de tâches (évolutions, corrections…), association d'une tâche à une ressource, planification, gestion des documents, etc.

    Redmine a été développé en Ruby et plus particulièrement grâce au framework Ruby on Rails par Jean-Philippe Lang.

    Merci pour vos commentaires.
    Régis.
    Pourquoi cet avatar ? Parce que j'aime bien le tableau "Le Fils de l'homme" de Magritte.
    Mes contributions sur developpez.com

  2. #2
    Futur Membre du Club
    Profil pro
    Inscrit en
    décembre 2009
    Messages
    6
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2009
    Messages : 6
    Points : 6
    Points
    6

    Par défaut Bloqué lors de l'installation

    Bonjour,

    J'ai découvert avec ravissement l'article sur l'installation de redmine.

    J'ai bien suivi l'article mais je bloque dès la fin de l'installation de postgresql lors de la création de l'utilisateur redmine. Le createuser me retourne l'erreur "authentification par mot de passe échouée pour l'utilisateur postgres".
    J'ai bien sur vérifié le mot de passe renseigné lors de l'installation, sans succès. J'ai aussi tenter de réinstaller postgres mais le problème reste le même.

    Je sèche complètement... Je recherche donc votre aide.

    Merci d'avance

  3. #3
    Rédacteur/Modérateur
    Avatar de regis1512
    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    mai 2008
    Messages
    1 263
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Haute Vienne (Limousin)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2008
    Messages : 1 263
    Points : 7 616
    Points
    7 616

    Par défaut

    Bonjour,

    Est-ce que vous obtenez ces lignes :
    Saisir le mot de passe pour le nouveau rôle :
    Le saisir de nouveau :
    Mot de passe :
    Si oui, pour les deux premiers mot de passe, il faut saisir "redmine" et pour le dernier il faut saisir le même mot de passe (c'est celui la celui de l'utilisateur postgre) que celui que dans l'installation (celui dans la quatrième capture d'écran dans le chapitre sur l'installation de postgre que j'ai rajouté juste ci-dessous).

    Nom : II_A_4.png
Affichages : 1346
Taille : 31,4 Ko

    Etes-vous sur du mot de passe saisi durant l'installation de postgre ?
    Le truc bête avec la touche CAPS LOCK où on inverse les majuscules et les minuscules ?

    Bonne journée et bon courage.
    Pourquoi cet avatar ? Parce que j'aime bien le tableau "Le Fils de l'homme" de Magritte.
    Mes contributions sur developpez.com

  4. #4
    Futur Membre du Club
    Profil pro
    Inscrit en
    décembre 2009
    Messages
    6
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2009
    Messages : 6
    Points : 6
    Points
    6

    Par défaut Bloqué lors de l'installation

    Bonjour et d'abord merci pour votre réponse.

    J'ai finalement trouvé d'où venait le problème :
    Lors de l'installation, j'ai dû renseigner un numéro de port différent de celui proposé par défaut (le port n'était pas disponible).
    Dans la ligne de commande createuser, il a donc fallu ajouter le paramètre -p avec le numéro de port différent et la commande est passée.

    Çà pourra peut-être servir à quelqu'un.

    Je continue donc la lecture de l'article.

  5. #5
    Rédacteur/Modérateur
    Avatar de regis1512
    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    mai 2008
    Messages
    1 263
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Haute Vienne (Limousin)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2008
    Messages : 1 263
    Points : 7 616
    Points
    7 616

    Par défaut

    Bonjour,

    Bien vu.
    On ne peut pas dire que le message de PostGre soit très explicite.

    Bon courage pour la suite.
    Et merci pour vos appréciations.
    Pourquoi cet avatar ? Parce que j'aime bien le tableau "Le Fils de l'homme" de Magritte.
    Mes contributions sur developpez.com

  6. #6
    Futur Membre du Club
    Profil pro
    Inscrit en
    décembre 2009
    Messages
    6
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2009
    Messages : 6
    Points : 6
    Points
    6

    Par défaut

    Je bloque à nouveau mais cette fois-ci c'est à l'installation des dépendances gems (V-D)

    La commande "bundle install --without development test" retourne l'erreur "Failed to build gem native extension" / Unable to get ImageMagick version".

    J'ai essayé avec plusieurs versions de Redmine et de ImageMagick, sans succès à chaque tentative.
    Mes recherches sur Google restent vaines.

    Auriez-vous une idée ?

    Merci

  7. #7
    Rédacteur/Modérateur
    Avatar de regis1512
    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    mai 2008
    Messages
    1 263
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Haute Vienne (Limousin)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2008
    Messages : 1 263
    Points : 7 616
    Points
    7 616

    Par défaut

    Bonjour,

    Je ne vois pas trop quel peut etre le problème.
    Je pencherai pour :
    - est-ce que vous avez bien cocher "Install developement headers and libraries for C and C++" durant l'installation de ImageMagick
    - est-ce que vos variables CPATH et LIBRARY_PATH sont correctes (attention au espace meme à la fin de la ligne

    Bon courage.
    Pourquoi cet avatar ? Parce que j'aime bien le tableau "Le Fils de l'homme" de Magritte.
    Mes contributions sur developpez.com

  8. #8
    Futur Membre du Club
    Profil pro
    Inscrit en
    décembre 2009
    Messages
    6
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2009
    Messages : 6
    Points : 6
    Points
    6

    Par défaut

    Effectivement....

    J'avais saisi set PATH au lieu de set CPATH...

    Merci de m'avoir mis sur la bonne piste.

  9. #9
    Rédacteur/Modérateur
    Avatar de regis1512
    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    mai 2008
    Messages
    1 263
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Haute Vienne (Limousin)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2008
    Messages : 1 263
    Points : 7 616
    Points
    7 616

    Par défaut

    Pas de soucis.
    Bonne soirée.
    Pourquoi cet avatar ? Parce que j'aime bien le tableau "Le Fils de l'homme" de Magritte.
    Mes contributions sur developpez.com

  10. #10
    Candidat au Club
    Femme Profil pro
    Inscrit en
    avril 2013
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France

    Informations forums :
    Inscription : avril 2013
    Messages : 2
    Points : 2
    Points
    2

    Par défaut Création d'un plugin

    Bonjour,

    Vu que j'ai utilisé votre tuto pour l'installation de redmine et qu'il a été très clair pour moi, j'aimerais savoir si vous pouviez proposer un tuto détaillé pour la création d'un plugin (version 2.x de préférence) ?
    Même si des documentations existent déjà sur le web (http://www.gogolek.co.uk/blog/2012/0...gins-tutorial/), je bloque par exemple dès la première commande...

    Merci d'avance pour votre réponse !

  11. #11
    Rédacteur/Modérateur
    Avatar de regis1512
    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    mai 2008
    Messages
    1 263
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Haute Vienne (Limousin)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2008
    Messages : 1 263
    Points : 7 616
    Points
    7 616

    Par défaut

    Bonsoir,
    En règle général, je serai preneur de la proposition.
    Malheureusement, je ne connais rien à Ruby.
    Et si rien est exagéré ce que je connais se résume aux commandes et informations présentes dans ce tutoriel.
    Pour le réaliser, je me suis reposé sur ce qui était présent sur les documentations officielles, sur des documents sur le net comme celle sur le blog de Mickael Baron et en dépiautant le Bitnami Redmine Stack pour comprendre les versions qui peuvent fonctionner ensemble.
    Je ne connais pas votre problème et je serais peu capable de vous aider.
    Mais pour ma petite expérience de Ruby pour ce tutoriel, il me semble assez sensible dans la compatibilité entre les versions des dépendances..
    Désolé pour ma réponse peu satisfaisante je me doute.
    Bonne soirée.
    Pourquoi cet avatar ? Parce que j'aime bien le tableau "Le Fils de l'homme" de Magritte.
    Mes contributions sur developpez.com

  12. #12
    Nouveau membre du Club

    Profil pro
    Inscrit en
    septembre 2005
    Messages
    9
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : septembre 2005
    Messages : 9
    Points : 27
    Points
    27

    Par défaut

    Bonjour,

    Je cherche à installer Redmine sur Windows 7, sachant que Wampserver est déjà installé. Inutile donc d'avoir Apache, Php et Mysql en double.

    Est il possible d'installer Redmine sur Wamp ?

    Merci

    Phil

  13. #13
    Rédacteur/Modérateur
    Avatar de regis1512
    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    mai 2008
    Messages
    1 263
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Haute Vienne (Limousin)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2008
    Messages : 1 263
    Points : 7 616
    Points
    7 616

    Par défaut

    Bonjour,

    Je dirais que cela doit être possible.
    Attention toutefois, le PHP n'est pas utile puisque Redmine tourne sous Ruby.
    L'intérêt de Wamp se résume à la base MySQL et Apache.
    Il faut également remarquer que Redmine ne tourne pas avec le serveur Apache (dans l'article Apache est simplement utilisé en tant que serveur frontal).

    Bonne journée.
    Pourquoi cet avatar ? Parce que j'aime bien le tableau "Le Fils de l'homme" de Magritte.
    Mes contributions sur developpez.com

  14. #14
    Membre actif Avatar de Nounoursonne
    Profil pro
    Inscrit en
    mai 2002
    Messages
    264
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2002
    Messages : 264
    Points : 205
    Points
    205

    Par défaut

    Bonjour,

    J'ai suivi les étapes pour l'installation sur Windows, mais quand j'ouvre un navigateur pour accéder à http://localhost:3000/ (chapitre V-I) ça ne fonctionne pas, je n'arrive pas sur la page voulue, il me renvoie sur le moteur de recherche
    Quelqu'un a déjà eu ce problème ?

    Merci

  15. #15
    Rédacteur/Modérateur
    Avatar de regis1512
    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    mai 2008
    Messages
    1 263
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Haute Vienne (Limousin)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2008
    Messages : 1 263
    Points : 7 616
    Points
    7 616

    Par défaut

    Bonjour,

    Etrange...

    Est-ce qu'il y a bien eu la trace :
    >> Using rack adapter
    >> Thin web server (v1.3.1 codename Triple Espresso)
    >> Maximum connections set to 1024
    >> Listening on 0.0.0.0:3000, CTRL+C to stop

    Où bien entendu 3000 indique le port d'écoute.

    Est-ce que cela donne le même résultat avec l'adresse http://127.0.0.1:3000/

    Pour finir est-ce que cela fonctionne mieux en changeant le port dans la commande thin start -p 3000 -e production

    Bonne soirée.
    Pourquoi cet avatar ? Parce que j'aime bien le tableau "Le Fils de l'homme" de Magritte.
    Mes contributions sur developpez.com

  16. #16
    Membre actif Avatar de Nounoursonne
    Profil pro
    Inscrit en
    mai 2002
    Messages
    264
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mai 2002
    Messages : 264
    Points : 205
    Points
    205

    Par défaut

    Bonjour,

    en effet, en changeant le port 3000 vers 6060, cela fonctionne.

    Merci pour votre aide

  17. #17
    Nouveau Candidat au Club
    Inscrit en
    juin 2012
    Messages
    1
    Détails du profil
    Informations forums :
    Inscription : juin 2012
    Messages : 1
    Points : 1
    Points
    1

    Par défaut

    Bonjour,

    J'ai suivi votre merveilleux tutoriel attentivement, malheuresement je me heurte à des difficultées.

    La commande "bundle install --without development test" retourne l'erreur :

    Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension
    .

    C:/RailsInstaller/Ruby1.9.3/bin/ruby.exe extconf.rb
    checking for Ruby version >= 1.8.5... yes
    Spécification du lecteur non valide.
    Unable to get ImageMagick version
    *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of
    necessary libraries and/or headers. Check the mkmf.log file for more
    details. You may need configuration options.

    Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=C:/RailsInstaller/Ruby1.9.3/bin/ruby


    Gem files will remain installed in C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9
    .1/gems/rmagick-2.13.2 for inspection.
    Results logged to C:/RailsInstaller/Ruby1.9.3/lib/ruby/gems/1.9.1/gems/rmagick-2
    .13.2/ext/RMagick/gem_make.out
    An error occurred while installing rmagick (2.13.2), and Bundler cannot
    continue.
    Make sure that `gem install rmagick -v '2.13.2'` succeeds before bundling.
    J'ai bien vérifié, le problème ne se situe pas au niveau des CPATH et LIBRARY_PATH
    puisque j'ai rentré respectivement :
    • set CPATH=C:\redmine\ImageMagick-6.8.7-Q16\include
    • set LIBRARY_PATH=C:\redmine\ImageMagick-6.8.7-Q16\lib
    • bundle install --without development test
    Je ne sais pas du tout où se situe le problème. A priori l'instalation de rmagick ne se fait pas correctement, et je ne sais pas quoi faire.

    Lorsque je continue, j'obtiens une autre erreur :
    C:\redmine\redmine>rake generate_secret_token
    ←[31mCould not find gem 'selenium-webdriver (>= 0) x86-mingw32' in the gems avai
    lable on this machine.←[0m
    ←[33mRun `bundle install` to install missing gems.←[0m

    C:\redmine\redmine>set RAILS_ENV=production

    C:\redmine\redmine>rake db:migrate
    ←[31mCould not find gem 'selenium-webdriver (>= 0) x86-mingw32' in the gems avai
    lable on this machine.←[0m
    ←[33mRun `bundle install` to install missing gems.←[0m


    Pourriez-vous m'aider svp, c'est assez urgent ?

    Votre tutoriel est vraiment parfait, le meilleur que j'ai put trouver. J'espère que cela fonctionnera chez moi.

    Je suis actuellement sous Windows XP, cela pose peut être problème.

    Merci d'avance.

  18. #18
    Rédacteur/Modérateur
    Avatar de regis1512
    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    mai 2008
    Messages
    1 263
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Haute Vienne (Limousin)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2008
    Messages : 1 263
    Points : 7 616
    Points
    7 616

    Par défaut

    Bonsoir,

    Je dois avouer que je ne sais pas trop.
    Que contient le fichier mkmf.log indiqué dans le premier message d'erreur ?
    Est-il possible de le poster en pièce jointe sur le forum s'il n'est pas trop gros ?

    Après une étape important lors de l'installation de RMagick : http://rpouiller.developpez.com/tuto...s-windows/#LIV
    est de bien cocher certaines case comme dans l'image : http://rpouiller.developpez.com/tuto...mages/IV_6.png

    Je me souviens également avoir eu des soucis à la moindre erreur (même un malheureux espace à la fin des lignes) sur les lignes :
    D:\redmine\redmine>set CPATH=D:\redmine\ImageMagick-6.8.7-Q16\include
    D:\redmine\redmine>set LIBRARY_PATH=D:\redmine\ImageMagick-6.8.7-Q16\lib

    Bon courage
    Pourquoi cet avatar ? Parce que j'aime bien le tableau "Le Fils de l'homme" de Magritte.
    Mes contributions sur developpez.com

  19. #19
    Futur Membre du Club
    Profil pro
    Inscrit en
    mars 2006
    Messages
    10
    Détails du profil
    Informations personnelles :
    Âge : 46
    Localisation : France

    Informations forums :
    Inscription : mars 2006
    Messages : 10
    Points : 8
    Points
    8

    Par défaut Mise à jour

    Bonjour

    Merci pour cette notice grâce à qui, il est possible d'installer Redmine sans se prendre trop la tête.
    Par contre j'ai du faire deux modifications car certains modules ont des versions incompatibles.

    dans Installation de Rake (Chapitre III-D-1)
    gem install rake -v 10.1.1
    dans Installation de bundler(Chapitre III-D-2)
    gem install bundler -v 1.5.2
    Sinon rien d'autre comme modifications. Encore merci !

    Du coup j'ai créer une doc du même type pour installer les plugins pour la méthode agile.
    • BackLogs
    • People
    • View Revision
    • XLS export

  20. #20
    Rédacteur/Modérateur
    Avatar de regis1512
    Homme Profil pro
    Chef de projet NTIC
    Inscrit en
    mai 2008
    Messages
    1 263
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 40
    Localisation : France, Haute Vienne (Limousin)

    Informations professionnelles :
    Activité : Chef de projet NTIC
    Secteur : Industrie

    Informations forums :
    Inscription : mai 2008
    Messages : 1 263
    Points : 7 616
    Points
    7 616

    Par défaut

    Bonjour,

    Merci pour ce retour.
    Si je comprends bien, il faut fixer les versions de rake et bundler (les versions plus récentes ne doivent pas fonctionner correctement).
    Je vais modifier l'article pour intégrer ces précisions.

    En effet, c'est un peu compliqué (un vrai euphémisme) d'installer Redmine.
    C'est bien dommage car sinon c'est un produit très intéressant.

    Bonne journée.
    Pourquoi cet avatar ? Parce que j'aime bien le tableau "Le Fils de l'homme" de Magritte.
    Mes contributions sur developpez.com

Discussions similaires

  1. Réponses: 1
    Dernier message: 28/11/2005, 23h20

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo