IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Ubuntu Discussion :

Autostart et autologin


Sujet :

Ubuntu

  1. #1
    Membre confirmé

    Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2009
    Messages
    377
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : novembre 2009
    Messages : 377
    Points : 597
    Points
    597
    Par défaut Autostart et autologin
    Bonjour,

    je suis en train de mettre une place une machine Lubuntu 13.04, je dois configurer cette machine pour démarrer une application automatiquement et se logger automatiquement.

    J'ai ajouter le démarrage de l'application dans :

    </home/manticore/.config/lxsession/Lubuntu/autostart
    Cela fonctionne correctement, mais lorsque je configure l'auto-login en ajoutant la ligne :

    autologin-session=manticore
    Dans /etc/lightdm/ligthdm.conf, j'ai bien l'autologin qui s'effectue, mais plus le démarrage de l'application.

    Je suis un peu perdu avec les greeker-session, user-session et autre, je pense que l'erreur vient de la mais je n'arrive pas à trouver la bonne configuration.

    Merci de votre aide

  2. #2
    Membre confirmé

    Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2009
    Messages
    377
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : novembre 2009
    Messages : 377
    Points : 597
    Points
    597
    Par défaut
    Je suis toujours bloqué sur mon problème, il y a un truc que je comprends pas :

    Quand je reboot avec l'auto-login, il me lance une session manticore normal mais pas de startup.

    Mais si je fais la commande :
    sudo restart lightdm
    Alors la tout marche comme je le veux.

  3. #3
    Rédacteur/Modérateur
    Avatar de Winnt
    Homme Profil pro
    budget et contrôle de gestion
    Inscrit en
    décembre 2006
    Messages
    1 964
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France

    Informations professionnelles :
    Activité : budget et contrôle de gestion
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : décembre 2006
    Messages : 1 964
    Points : 4 107
    Points
    4 107
    Par défaut
    Salut,

    Il n'y aurait pas dans les paramètres de la session graphique un menu avec une case à cocher permet d'arriver directement sur le bureau qui se nommerai session et démarrage ?
    Winnt
    Merci de lire les règles du forum LaTeX et Qu'est ce qu'un ECM ?.
    N'hésitez pas à parcourir la FAQ la réponse y est peut-être déjà.
    Pensez au bouton si votre problème est résolu.


    C'est en Linuxant qu'on devient .... geek
    Et c'est en LateXant qu'on devient flemmard
    Mon blog tout neuf.
    Articles : présentation de la distribution Gentoo, Les index sous LaTeX et leur personnalisation.

  4. #4
    Membre confirmé

    Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2009
    Messages
    377
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : novembre 2009
    Messages : 377
    Points : 597
    Points
    597
    Par défaut
    J'ai rien trouvé de ressemblant, mais j'ai ça :



    Mais je comprends pas trop à quoi correspondent les labels

  5. #5
    Rédacteur/Modérateur
    Avatar de Winnt
    Homme Profil pro
    budget et contrôle de gestion
    Inscrit en
    décembre 2006
    Messages
    1 964
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France

    Informations professionnelles :
    Activité : budget et contrôle de gestion
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : décembre 2006
    Messages : 1 964
    Points : 4 107
    Points
    4 107
    Par défaut
    Salut,

    Autostart ce ne serait pas pour lancer automatiquement des services/applications des fois ?

    Et dans Options ou Settings il n'y aurait rien en rapport avec l'auto-login ?
    Winnt
    Merci de lire les règles du forum LaTeX et Qu'est ce qu'un ECM ?.
    N'hésitez pas à parcourir la FAQ la réponse y est peut-être déjà.
    Pensez au bouton si votre problème est résolu.


    C'est en Linuxant qu'on devient .... geek
    Et c'est en LateXant qu'on devient flemmard
    Mon blog tout neuf.
    Articles : présentation de la distribution Gentoo, Les index sous LaTeX et leur personnalisation.

  6. #6
    Membre confirmé

    Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2009
    Messages
    377
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : novembre 2009
    Messages : 377
    Points : 597
    Points
    597
    Par défaut
    Autostart ce ne serait pas pour lancer automatiquement des services/applications des fois ?
    Oui c'est en faisant un strace sur autostart que j'ai récupérer le fichier utilisé pour le lancement automatique des applications.

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    Et dans Options ou Settings il n'y aurait rien en rapport avec l'auto-login ?
    Non le seul rapport avec l'auto-login que j'ai trouvé dans les menu et sous "utilisateurs et groupes", et il y a une coche auto-login (qui est coché).

  7. #7
    Rédacteur/Modérateur
    Avatar de Winnt
    Homme Profil pro
    budget et contrôle de gestion
    Inscrit en
    décembre 2006
    Messages
    1 964
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 53
    Localisation : France

    Informations professionnelles :
    Activité : budget et contrôle de gestion
    Secteur : Administration - Collectivité locale

    Informations forums :
    Inscription : décembre 2006
    Messages : 1 964
    Points : 4 107
    Points
    4 107
    Par défaut
    Salut,

    Normalement il suffit d'ajouter le programme dans autostart pour qu'il puisse être lancé automatiquement (avec le chemin d'accès correct bien sûr). Donc aucune raison de bidouiller à priori.

    Pour l'auto-login c'est bizarre, chez moi ca a toujours fonctionné quelque soit le DE.
    Maintenant étant actuellement sous KDE...

    As-tu déjà commencé par vérifier le lancement automatique de l'application à l'ouverture de session ?
    Winnt
    Merci de lire les règles du forum LaTeX et Qu'est ce qu'un ECM ?.
    N'hésitez pas à parcourir la FAQ la réponse y est peut-être déjà.
    Pensez au bouton si votre problème est résolu.


    C'est en Linuxant qu'on devient .... geek
    Et c'est en LateXant qu'on devient flemmard
    Mon blog tout neuf.
    Articles : présentation de la distribution Gentoo, Les index sous LaTeX et leur personnalisation.

  8. #8
    Membre confirmé

    Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2009
    Messages
    377
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : novembre 2009
    Messages : 377
    Points : 597
    Points
    597
    Par défaut
    Ce que je comprends pas c'est que l'on dirait que si je fais un reboot il lance un autre type de session que si je fais un :

    sudo lightdm restart
    Dans le premier cas il lance pas mon soft, dans le second oui.

  9. #9
    Membre confirmé

    Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2009
    Messages
    377
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations professionnelles :
    Activité : Ingénieur développement logiciels

    Informations forums :
    Inscription : novembre 2009
    Messages : 377
    Points : 597
    Points
    597
    Par défaut
    Voila problème résolu, mon passage sur lubuntu aura été court.

    J'ai migré sur Debian tout fonctionne en 5 minutes.

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. autologin en root
    Par usf70 dans le forum Administration système
    Réponses: 5
    Dernier message: 26/06/2007, 13h44
  2. Embed -> Autostart?!
    Par Goupo dans le forum Balisage (X)HTML et validation W3C
    Réponses: 6
    Dernier message: 20/04/2007, 12h38
  3. Autostart de Jboss
    Par Shogun dans le forum Wildfly/JBoss
    Réponses: 1
    Dernier message: 28/02/2007, 16h37
  4. Réponses: 1
    Dernier message: 17/02/2007, 02h21
  5. [AutoLogin] Ne peux plus changer de user
    Par BenoitM dans le forum Windows XP
    Réponses: 4
    Dernier message: 14/12/2005, 11h15

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo