Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre confirmé
    [Weblogic 10.3] Déploiement automatique avec mvn deploy "Unable to connect to 't3://localhost:7001'"
    Bonjour

    Je souhaite deployer mes EAR en automatique depuis script maven, ma console tourne bien en local sur le port 7001, et depuis la console d'administration de weblogic, je peux deployer mes EAR.
    Mais lorsque j'essaye depuis Maven, j'ai une erreur
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
     
    Unable to connect to 't3://localhost:7001': invalid type code: 31. Ensure the url represents a running admin server and that the credentials are correct. If using http protocol, tunneling must be enabled on the admin server.


    Dans ma configuration weblogic, j'ai bien autorisé dans le protocole http le tunneling. Ou est mon erreur ?
    Merci
    Phil

    Ma commande
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
     
    /usr/bin/mvn weblogic:deploy -Dweblo.user="toto" -D weblo.password="totopwd"


    Mon pom
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
     
    <plugin>
    <groupId>org.codehaus.mojo</groupId>
    <artifactId>weblogic-maven-plugin</artifactId>
    <version>2.9.0</version>
    <configuration>
    <adminServerHostName>${weblo.admin.host}</adminServerHostName><adminServerPort>${weblo.admin.port}</adminServerPort>
    <!-- <adminServerProtocol>http</adminServerProtocol> -->
    <userId>${weblo.user}</userId>
    <password>${weblo.password}</password>
    <upload>true</upload>
    <remote>${weblo.remote}</remote>
    <verbose>true</verbose>
    <debug>false</debug>
    <targetNames>${weblo.target}
    </targetNames><
    /configuration>
    </plugin>

  2. #2
    Expert éminent
    Salut,

    la réponse à ce problème est donnée ici.
    Alea Jacta Test!

###raw>template_hook.ano_emploi###