IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Installation .NET Discussion :

erreur: previous installation has been detected [Débutant]


Sujet :

Installation .NET

  1. #1
    Membre régulier
    Profil pro
    Inscrit en
    septembre 2006
    Messages
    279
    Détails du profil
    Informations personnelles :
    Localisation : Maroc

    Informations forums :
    Inscription : septembre 2006
    Messages : 279
    Points : 99
    Points
    99
    Par défaut erreur: previous installation has been detected
    Bonjour;
    j'essaye de réinstaller sharepoint 2007 sur mon serveur windows server 2008 , j'ai donc désinstallé et exécuter cccleaner pour effecer toutes ses clés de registre.

    quand je lance l'install à nouvea u j'ai eu ce message d'erreur "previous installation has been detected with a base install language that does not match the install in progress"

    sachant que j'ai vérifié dans les programmes , j'ai eu aucune instance de sharepoint !!

    quelle est la solution ?

    Merci.

  2. #2
    Expert confirmé
    Avatar de ludojojo
    Homme Profil pro
    Développeur SharePoint
    Inscrit en
    avril 2008
    Messages
    2 967
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 34
    Localisation : France

    Informations professionnelles :
    Activité : Développeur SharePoint
    Secteur : Conseil

    Informations forums :
    Inscription : avril 2008
    Messages : 2 967
    Points : 5 372
    Points
    5 372
    Billets dans le blog
    5
    Par défaut
    Bonjour,
    Citation Envoyé par zanoubya Voir le message
    quand je lance l'install à nouvea u j'ai eu ce message d'erreur "previous installation has been detected with a base install language that does not match the install in progress"

    sachant que j'ai vérifié dans les programmes , j'ai eu aucune instance de sharepoint !!
    Et as-tu regardé dans la base de données ?
    Aide les autres...
    Et les autres t'aideront....
    Mon site DVP
    N'oubliez pas de consulter les FAQ SharePoint et les cours et tutoriels SharePoint

    N'oubliez pas de voter pour les messages dont la réponse est pertinente

  3. #3
    Membre régulier
    Profil pro
    Inscrit en
    septembre 2006
    Messages
    279
    Détails du profil
    Informations personnelles :
    Localisation : Maroc

    Informations forums :
    Inscription : septembre 2006
    Messages : 279
    Points : 99
    Points
    99
    Par défaut
    j'ai des instance de sqlrever sur ma machine je dois les désinstaller ?

  4. #4
    Membre chevronné
    Profil pro
    Inscrit en
    mai 2004
    Messages
    1 486
    Détails du profil
    Informations personnelles :
    Âge : 35
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations forums :
    Inscription : mai 2004
    Messages : 1 486
    Points : 2 082
    Points
    2 082
    Par défaut
    Search ou project server sont-ils installes?

    Regarde les cles de registre suivantes (on sait jamais), elles ne devraient pas y être:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server

  5. #5
    Membre régulier
    Profil pro
    Inscrit en
    septembre 2006
    Messages
    279
    Détails du profil
    Informations personnelles :
    Localisation : Maroc

    Informations forums :
    Inscription : septembre 2006
    Messages : 279
    Points : 99
    Points
    99
    Par défaut
    Bonjour;
    sur ma machine j'ai trouvé les clés suivantes :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\12.0\InstalledLanguages
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\12.0\Single Signon


    alors je les supprimes toutes ?

    Merci.

  6. #6
    Expert confirmé
    Avatar de ludojojo
    Homme Profil pro
    Développeur SharePoint
    Inscrit en
    avril 2008
    Messages
    2 967
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 34
    Localisation : France

    Informations professionnelles :
    Activité : Développeur SharePoint
    Secteur : Conseil

    Informations forums :
    Inscription : avril 2008
    Messages : 2 967
    Points : 5 372
    Points
    5 372
    Billets dans le blog
    5
    Par défaut
    Citation Envoyé par zanoubya Voir le message
    j'ai des instance de sqlrever sur ma machine je dois les désinstaller ?
    A minima vérifie qu'il ne reste pas de trace de ton SharePoint dessus...

    Citation Envoyé par zanoubya Voir le message
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server
    Pense à faire un backup de ton registre avant au cas où...
    Aide les autres...
    Et les autres t'aideront....
    Mon site DVP
    N'oubliez pas de consulter les FAQ SharePoint et les cours et tutoriels SharePoint

    N'oubliez pas de voter pour les messages dont la réponse est pertinente

  7. #7
    Expert confirmé Avatar de Lapinpanda
    Homme Profil pro
    Développeur .NET
    Inscrit en
    juin 2009
    Messages
    3 230
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : juin 2009
    Messages : 3 230
    Points : 5 221
    Points
    5 221
    Par défaut
    Je sais que tu peux surement pas faire ainsi mais bon...moi dans ce genre d'erreur qui crame 1 à 2 jours pour des débutants... je réinstalle le serveur entièrement

    Ca me prend 3-4 heures; c'est chiant, mais ca marche
    Merci d'utiliser en cas de résolution de votre problème

    N'oubliez pas non plus le petit pouce vert pour récompenser celui que vous a aidé

  8. #8
    Membre chevronné
    Profil pro
    Inscrit en
    mai 2004
    Messages
    1 486
    Détails du profil
    Informations personnelles :
    Âge : 35
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations forums :
    Inscription : mai 2004
    Messages : 1 486
    Points : 2 082
    Points
    2 082
    Par défaut
    Le mieux pour le tout début, c'est soit de faire des images disque a chaque étape d'install, soit partir sur de la VM et faire du snapshot.

    Il n'y a que comme ça que j'ai pu bosser sereinement sur mes projets d'installation/configuration SharePoint.

  9. #9
    Expert confirmé Avatar de Lapinpanda
    Homme Profil pro
    Développeur .NET
    Inscrit en
    juin 2009
    Messages
    3 230
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : juin 2009
    Messages : 3 230
    Points : 5 221
    Points
    5 221
    Par défaut
    Oui, dans le top du top, on a une VM Windows Serveur 2008 R2 SANS SharePoint, qu'on garde bien au chaud.

    Et encore mieux, j'en fait une avec MOSS 2007, et une autre avec SPS 2010
    Merci d'utiliser en cas de résolution de votre problème

    N'oubliez pas non plus le petit pouce vert pour récompenser celui que vous a aidé

  10. #10
    Membre régulier
    Profil pro
    Inscrit en
    septembre 2006
    Messages
    279
    Détails du profil
    Informations personnelles :
    Localisation : Maroc

    Informations forums :
    Inscription : septembre 2006
    Messages : 279
    Points : 99
    Points
    99
    Par défaut
    Bonjour;

    voilà j'ai supprimé les clés suivantes :

    HKey_Local_Machine\Software\Microsoft\Office Server\12.0

    HKey_Local_Machine\Software\Microsoft\Shared Tools\Web Server Extensions\12.0

    HKey_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Uninstall\OSERVER

    et ca marche très bien.

    Toutefois il faut faire un backup avant de le faire on sait jamais si cela donne un dysfonctionnement, personnellement tout est bon

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Ordinateur bloqué : A problem has been detected
    Par derek corhs dans le forum Windows 7
    Réponses: 25
    Dernier message: 05/01/2012, 11h26
  2. Réponses: 9
    Dernier message: 30/12/2011, 17h18
  3. Réponses: 0
    Dernier message: 06/08/2010, 11h12
  4. Réponses: 4
    Dernier message: 03/08/2010, 22h36
  5. [1.x] Erreur: No driver has been registered to handle connection type
    Par phpiste dans le forum Symfony
    Réponses: 1
    Dernier message: 21/05/2008, 15h59

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo