Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Applications mobiles Discussion :

Développez en natif pour Android avec Qt 5.1


Sujet :

Applications mobiles

  1. #1
    Inactif  
    Développez en natif pour Android avec Qt 5.1
    Bonjour à tous.

    Code Less.
    Create more.
    Deploy everywhere.

    C'est la devise de Qt. C'est encore plus vrai avec la prochaine version 5.1 de Qt, actuellement en bêta (la RC est prévue le 27). En effet, cette version propose le support de Qt sur Android, iOS et BlackBerry (et bien d'autres plateformes). Voir la news de sortie de Qt 5.1 bêta.

    Dans ce tutoriel, je présente comment installer et configurer les outils pour développer une application Qt sur Android, avec Qt Creator sur Ubuntu.

    Développez en natif pour Android avec Qt 5.1

    Que pensez-vous du développement en natif avec Qt ?
    Avez-vous déjà testé Qt sur Android, iOS ou BlackBerry ?

  2. #2
    Candidat au Club
    Bonjour, merci pour cet article, je voulais justement tester Qt5 sur Android (Nexus 7).

    Pour le problème avec ant, il suffit d'installer le paquet :
    sudo apt-get install openjdk-7-jdk

    antoine@antoine-P150HMx:~$ ant -version
    Apache Ant(TM) version 1.8.2 compiled on May 18 2012

  3. #3
    Inactif  
    Merci pour l'information. J'ai modifié l'article

  4. #4
    Membre du Club
    Pour les composant Android (Button, textField ....) y a t il un moyen de les utilisé
    sans les refaires avec QML??

  5. #5
    Candidat au Club
    Citation Envoyé par boumacmilan Voir le message
    Pour les composant Android (Button, textField ....) y a t il un moyen de les utilisé
    sans les refaires avec QML??
    Il existe les Qt Quick Controls disponibles en Qt Quick 2.1 http://doc-snapshot.qt-project.org/q...ols-index.html

  6. #6
    Membre du Club
    J'ai suivi le tuto et j'ai eu une erreur lorsque je lance l'appli. Le simulateur se lance mais j'ai un message d'erreur dans qt creator : erreur : Impossible de déployer : aucun périphérique ou émulateur trouvé pour votre paquet.
    J'ai essayé de changer des paramètres du projet et plein de petit truc que j'ai vu sur internet mais rien n'a fonctionné.

    En cherchant je trouve bien le .so mais pas l'apk ne semblait pas être produit.

    Pour ceux qui auraient comme moi des soucis voilà ce que j'ai fait.
    Je suis sur une ubuntu 13.04 64bits et j'ai du installer le support des libs 32 bits : apt-get install ia32-libs

    Et ensuite tout était ok.

  7. #7
    Nouveau Candidat au Club
    Android en 5.2 (débutant)
    Bonjour,

    Je teste en ce moment Qt 5.2 pour Android . Impeccable pour le début (affichage heure, bouton et compteur..). Mais je sens que ça va vite se compliquer. J'aimerais savoir comment retrouver les fonctions envoi de sms et gps dans le code Qt. Est-ce que je dois déclarer des librairies..?

  8. #8
    Responsable Qt & Livres

    Pour la localisation, tu as le module Qt Positioning : http://qt-project.org/doc/qt-5/qtpos...ing-index.html. Maintenant, pour envoyer un SMS, je n'ai aucune idée (il y a eu QMF http://blog.qt.digia.com/blog/2009/0...ing-framework/, ces fonctionnalités seront peut-être de retour dans une prochaine version de Qt).
    Vous souhaitez participer aux rubriques Qt ou PyQt (tutoriels, FAQ, traductions), HPC ? Contactez-moi par MP.

    Créer des applications graphiques en Python avec PyQt5
    Créer des applications avec Qt 5.

    Pas de question d'ordre technique par MP !

  9. #9
    Candidat au Club
    ....ne semble pas être la racine du SDK Android
    Bonjour, j'ai un soucis avec le SDK quand je rentre son chemin dans les option=>Android.
    Pour le NDK pas de soucis mais j'ai essayer avec plusieurs dossiers contenant plusieurs version du SDK Android et a chaque fois le même message :
    ""/home/ben/Qt5.1.0/Android/adt-bundle-windows-x86_64-20131030/sdk" ne semble pas être la racine du SDK Android."
    Que faire..

    Joyeux Noël !