Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre régulier
    Homme Profil pro
    Développeur Web
    Inscrit en
    février 2005
    Messages
    54
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : Canada

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : février 2005
    Messages : 54
    Points : 108
    Points
    108

    Par défaut Zend Routers ne fonctionnant pas

    Bonjour à tous,

    Ne connaissant pas très bien zend framework, j'essaye de mettre en place un système de routes via un fichier .ini.

    En voici une partie, en sachant que le reste et du même acabit :
    routes.donjons.type = "Zend_Controller_Router_Route"
    routes.donjons.route = "donjons.html"
    routes.donjons.defaults.module = "Core"
    routes.donjons.defaults.controller = "donjons"
    routes.donjons.defaults.action = "index"
    Voilà, comment s'initialise mon router dans le bootstrap de mon module Core :
    protected function _initRouter()
    {
    $routeConfig = new Zend_Config_Ini(
    ROOT_PATH . DIRECTORY_SEPARATOR .
    'application' . DIRECTORY_SEPARATOR .
    'Core' . DIRECTORY_SEPARATOR .
    'configs' . DIRECTORY_SEPARATOR .
    'routes.ini', APPLICATION_ENV
    );

    Zend_Controller_Front::getInstance()
    ->getRouter()
    ->addConfig($routeConfig, 'routes');
    }
    L'URL-rewritting est activé via un fichier .htaccess :
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} -d [OR]
    RewriteCond %{REQUEST_FILENAME} -s [OR]
    RewriteCond %{REQUEST_FILENAME} -l
    RewriteRule ^.*$ - [L]
    RewriteRule ^.*$ index.php [L]
    Si je me trompe pas, en appelant la page, si je fais monsite.com/donjons.html ou monsite.com/donjons/index, çà devrait l'afficher ? Dans mon cas, j'obtiens une erreur :
    Not Found

    The requested URL /public/donjons.html was not found on this server.
    ou
    Not Found

    The requested URL /TNA/index.php was not found on this server.
    Merci d'avance pour votre aide

    PS : Ne me demandez pas de passer sur zf2 ;p C'est pas moi qui décide la version sur laquelle je bosse :p

  2. #2
    Membre régulier
    Homme Profil pro
    Développeur Web
    Inscrit en
    février 2005
    Messages
    54
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 37
    Localisation : Canada

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : février 2005
    Messages : 54
    Points : 108
    Points
    108

    Par défaut

    Je suis toujours au même niveau :/

    Personne aurait une piste pour m'aider à résoudre ce problème ? Cela viendrait de mon code ou du serveur ?

    Merci d'avance.

Discussions similaires

  1. Les redirections Zend ne fonctionnent pas.
    Par babazooka dans le forum Zend Framework
    Réponses: 1
    Dernier message: 29/01/2013, 19h18
  2. [ZF 1.11] zend fonctionne pas après integration doctrine1.2.2
    Par shrek35 dans le forum Zend Framework
    Réponses: 4
    Dernier message: 30/04/2012, 15h46
  3. UNION qui ne fonctionne pas
    Par r-zo dans le forum Langage SQL
    Réponses: 7
    Dernier message: 21/07/2003, 10h04
  4. Un Hint sur un PopupMenu ne fonctionne pas !!??
    Par momox dans le forum C++Builder
    Réponses: 6
    Dernier message: 26/05/2003, 16h48
  5. ca ne fonctionne pas (generateur auto-incrémentant)
    Par tripper.dim dans le forum SQL
    Réponses: 7
    Dernier message: 26/11/2002, 00h10

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo