IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

JOnAS Java Discussion :

Problème d'installation de JOnAS sous Linux Ubuntu


Sujet :

JOnAS Java

  1. #1
    Membre du Club
    Homme Profil pro
    Inscrit en
    février 2010
    Messages
    118
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : février 2010
    Messages : 118
    Points : 43
    Points
    43
    Par défaut Problème d'installation de JOnAS sous Linux Ubuntu
    bonjour les developpeurs ,

    je viens d'installer jonas mais j'ai eu ce problème [err1] lors de démarrage je crois qui je l'est mal installer

    -err1:
    Server JOnAS 5.x was unable to start within 120 seconds. If the server requires more time, try increasing the timeout in the server editor.
    et voila ce qui affiche dans la console [err2]:

    -err2:
    Welcome to OW2 JOnAS (Running on Felix v3.0.9).
    -----------------------------------------------

    2012-09-16 12:34:03,565 : NameServiceManager.startNonStartedNS : Name service for jrmp is started on port ' 1099'.
    2012-09-16 12:34:03,568 : CarolRegistryService.__doStart : Carol Registry Service started
    2012-09-16 12:34:04,172 : JOnASJMXService$2.execute : JMX security is disabled
    2012-09-16 12:34:04,173 : JOnASJMXService.__doStart : JMX Service started using connector(s)[service:jmx:rmi://localhost/jndi/rmi://localhost:1099/jrmpconnector_jonas]
    2012-09-16 12:34:04,766 : J2EEServer.__setStarting : JVM used is 1.6.0_24 version of OpenJDK Client VM-20.0-b12/Sun Microsystems Inc. vendor on Linux 3.2.0-30-generic/i386 OS.
    2012-09-16 12:34:04,780 : JNDIInterceptorsComponent.__start : JNDI Interceptors component started
    2012-09-16 12:34:04,786 : J2EEServer.__info : JOnAS AS v5.2.3 named 'jonas' STARTING
    2012-09-16 12:34:05,365 : PolicyProvider.init : Using JOnAS PolicyConfigurationFactory provider and JOnAS Policy provider
    2012-09-16 12:34:06,522 : JonasSecurityServiceImpl.__doStart : Security Service started
    2012-09-16 12:34:06,770 : JOnASWorkCleanerService.__doStart : WorkCleaner Service started.
    2012-09-16 12:34:07,222 : TransactionRecoveryImpl.<init> : JOTM properties file= /usr/local/jonas-full-5.2.3/conf/jotm.properties
    2012-09-16 12:34:07,225 : Current.setDefaultRecovery : Jotm Recovery= false
    2012-09-16 12:34:07,258 : JOTMTransactionService.__doStart : TransactionService started, default timeout= 60
    2012-09-16 12:34:07,462 : HsqlDBServiceImpl.__doStart : Starting HSQLDB server 1.8.0 on port 9001
    2012-09-16 12:34:07,971 : HsqlDBServiceImpl.__doStart : HSQLDB server started.
    2012-09-16 12:34:08,003 : HsqlDBServiceImpl.__doStart : Dropping and adding user 'jonas' with password 'jonas'.
    2012-09-16 12:34:09,399 : BaseWebContainerService.doStart : OnDemand Feature enabled: Listening on '9000' port (internal:8959).
    2012-09-16 12:34:10,256 : Http11Protocol.init : Initializing Coyote HTTP/1.1 on http-8959
    2012-09-16 12:34:10,307 : StandardService.start : Starting service jonas
    2012-09-16 12:34:10,310 : StandardEngine.start : Starting Servlet Engine: Apache Tomcat/6.0.35
    2012-09-16 12:34:10,469 : Http11Protocol.start : Starting Coyote HTTP/1.1 on http-8959
    2012-09-16 12:34:10,896 : JOnASEARService.__doStart : EAR Service started
    2012-09-16 12:34:11,017 : DeployableMonitorService.__doStart : Use the deploy directories '[]', development mode is 'true'
    2012-09-16 12:34:26,992 : ServiceManagerImpl.__checkServiceStates : JOnAS server cannot reach the RUNNING state
    2012-09-16 12:34:26,993 : ServiceManagerImpl.__checkServiceStates : Service 'resource' is not running
    2012-09-16 12:34:26,993 : ServiceManagerImpl.__checkServiceStates : Service 'ejb3' is not running
    2012-09-16 12:34:26,993 : ServiceManagerImpl.__checkServiceStates : Service 'jaxws' is not running
    2012-09-16 12:34:26,993 : ServiceManagerImpl.__checkServiceStates : Please check the JOnAS server configuration.
    voila les procédures d'installation que j'ai suivi :

    1- j'ai télécharger la version 5.2.3 (jonas-full-5.2.3-bin.tar.gz).
    2- j'ai décompresser le fichier (jonas-full-5.2.3-bin.tar.gz) avec la commande tar zxvf jonas-full-5.2.3-bin.tar.gz dans le repertoire /usr/local
    3- ensuite dans éclipse File>New>Other>Server>Server>OW2>LOnAS 5.x> (j'ai mentionné le repertoire dans mon fichier jonas "browser" /usr/local/jonas-full-5.2.3 )

    NB : juste pour l'info j'ai essayé aussi de le démarrer avec la console ./jonas started et sa marche pas aussi .

    merci d'avance les développeurs

    (j'attends votre aide d'installation ou de configuration)

  2. #2
    Membre confirmé

    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    avril 2002
    Messages
    136
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : avril 2002
    Messages : 136
    Points : 598
    Points
    598
    Par défaut
    Bonjour,

    Je ne connais pas trop la version 5 de jonas, mais j'ai réussi à l'exécuter sans aucun problème la semaine dernière. Alors je te mets ma méthode (il y en a certainement en trop) :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
     
    $> export JONAS_BASE=/usr/local/jonas-full-5.2.3
    $> export JONAS_LIB=/usr/local/jonas-full-5.2.3
    $> export JONAS_REMOTE=/usr/local/jonas-full-5.2.3
    $> export JONAS_ROOT=/usr/local/jonas-full-5.2.3
     
    $> cd $JONAS_BASE
    $> bin/jonas start -fg
    ce qui me lance jonas en mode interactif (c'est à dire que tu peux faire Ctrl+C pour l'arrêter comme un bourrin) ... si tu omets -fg ill le démarrera en arrière plan

    En espérant que ça résolve ton problème !

  3. #3
    Membre du Club
    Homme Profil pro
    Inscrit en
    février 2010
    Messages
    118
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : février 2010
    Messages : 118
    Points : 43
    Points
    43
    Par défaut
    Merci pour ton aide, ta méthode marche parfaitement, sinon j'ai essayé la version 5.2.2 et ça marche trop bien aussi sans configuration, je lance seulement le serveur avec la cammande ($JONAS_PATH)/bin ./jonas start ou directement avec eclipse

  4. #4
    Membre à l'essai
    Inscrit en
    juin 2009
    Messages
    40
    Détails du profil
    Informations forums :
    Inscription : juin 2009
    Messages : 40
    Points : 22
    Points
    22
    Par défaut
    J'ai exactement le même problème sur une distri linux gentoo.
    Dans mon cas, le problème a été résolu après avoir supprimé le répertoire work dans JONAS_BASE.
    Si je relance le service jonas, le problème revient. Le service JOnASWorkServiceManager ne démarre pas.
    Quelle est la raison de ce problème ?

  5. #5
    Membre du Club
    Homme Profil pro
    Inscrit en
    février 2010
    Messages
    118
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : février 2010
    Messages : 118
    Points : 43
    Points
    43
    Par défaut
    tu utilise quel version de jonas?!! moi je te conseil d'utilisé une version stable par exemple : jonas 5.2.2

  6. #6
    Membre à l'essai
    Inscrit en
    juin 2009
    Messages
    40
    Détails du profil
    Informations forums :
    Inscription : juin 2009
    Messages : 40
    Points : 22
    Points
    22
    Par défaut
    J'utilise la version 5.2.3. Cette version est pourtant marquée comme stable.

  7. #7
    Membre du Club
    Homme Profil pro
    Inscrit en
    février 2010
    Messages
    118
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : février 2010
    Messages : 118
    Points : 43
    Points
    43
    Par défaut
    utilise plutôt la version 5.2.2, moi j'ai eu un problème avec la 5.2.3 et j'ai résolu le problème en changeant la version en 5.2.2

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. installer glaux.h sous linux (ubuntu)
    Par Gobelins dans le forum Moteurs 3D
    Réponses: 2
    Dernier message: 10/09/2009, 00h25
  2. Problèmes d'installation d'oracle sous linux
    Par Fatimaaa dans le forum Administration système
    Réponses: 2
    Dernier message: 22/06/2009, 13h55
  3. installation de Java sous Linux Ubuntu
    Par Balbuzard dans le forum Débuter avec Java
    Réponses: 12
    Dernier message: 06/05/2009, 00h57
  4. Réponses: 0
    Dernier message: 08/12/2008, 14h37
  5. Problème d'installation oracle 10G sous linux
    Par magboom dans le forum Installation
    Réponses: 3
    Dernier message: 13/02/2008, 12h00

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo