Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Membre du Club
    Inscrit en
    janvier 2006
    Messages
    194
    Détails du profil
    Informations personnelles :
    Âge : 37

    Informations forums :
    Inscription : janvier 2006
    Messages : 194
    Points : 69
    Points
    69

    Par défaut Configuration d'un ear pour utiliser le module JAAS

    Bonjour,

    Je travaille sur le déploiement de mon application sous WAS et celle-ci utilise JAAS pour gérer les authentification/autorisation, à travers 3 login module.

    Sous Tomcat et JBoss, ça fonctionne parfaitement (avec quelques modifications de configuration).

    Sous WAS, j'ai créé un server dans mon profil sous (/Websphere/profiles/AppSrv01), avec comme admin/password : websphere/websphere.
    J'ai fait les configurations nécessaires (DataSource + configuration des login module ...).

    Par la suite, j'ai installé mon ear et je l'ai démarré, j'accède à la page publique de mon application http://server:port/portal/test (pas de souci tout marche bien).

    Mais lorsque j'essaie de m'authentifier en utilisant un utilisateur de mon application (demo/demo), l'authentification échoue et j'obtiens une exception qui indique que l'utilisateur websphere/websphere ne peut pas se connecter.

    websphere/websphere est l'utilisateur que j'ai créé pour accéder à la console d'administration WAS, il n'a rien à voir avec mon application.

    Quelqu'un aurait-il une idée sur l'origine du problème ?

    Merci d'avance.

  2. #2
    Membre du Club
    Inscrit en
    janvier 2006
    Messages
    194
    Détails du profil
    Informations personnelles :
    Âge : 37

    Informations forums :
    Inscription : janvier 2006
    Messages : 194
    Points : 69
    Points
    69

    Par défaut

    La solution est la suivante :
    • 1-Click Security > Global security > Web and SIP security to open the General settings panel.
    • 2-Select the Use available authentication data when an unprotected URI is accessedoption.
    • 3-Click OK and save the change.
    • 4-Restart WebSphere Application Server.

  3. #3
    Membre régulier
    Profil pro
    Inscrit en
    mars 2009
    Messages
    80
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : mars 2009
    Messages : 80
    Points : 74
    Points
    74

    Par défaut question pour un champion

    Bonjour,

    J'ai un peu d'expérience sur Glassfish et tomcat concernant JAAS et la fabrication / configuration de modules d'authentification, mais avec WebSphere 7 je sèche.
    Mon problème est au niveau de la configuration dans WS7 du LoginModule pour une application particulière.
    J'ai créé un domaine de sécurité (au cas où) et un loginModule
    Pendant le déploiement de l'application j'ai associé le domaine de sécurité
    Maintenant mon application "fonctionne" mais ne prend absolument pas en compte les directives de sécurité J2EE (web.xml).

    Comment faire ?

    Salutations,

Discussions similaires

  1. Besoin d'aide pour utiliser le module rarfile 2.5
    Par MediaVistaIntel dans le forum Général Python
    Réponses: 7
    Dernier message: 17/12/2012, 06h34
  2. Configurer NetBeans 6.9 pour utilisation avec CUDA
    Par champion dans le forum CUDA
    Réponses: 5
    Dernier message: 24/08/2010, 11h08
  3. Réponses: 1
    Dernier message: 14/01/2010, 20h01
  4. Réponses: 0
    Dernier message: 16/07/2009, 00h01
  5. Réponses: 1
    Dernier message: 27/10/2005, 09h26

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo