IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Services Web Discussion :

visualiser et utiliser des classes spécialisées dans un web service [Débutant]


Sujet :

Services Web

  1. #1
    Membre régulier
    Femme Profil pro
    Etudiante en Développement
    Inscrit en
    avril 2012
    Messages
    106
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France

    Informations professionnelles :
    Activité : Etudiante en Développement
    Secteur : Industrie

    Informations forums :
    Inscription : avril 2012
    Messages : 106
    Points : 119
    Points
    119
    Par défaut visualiser et utiliser des classes spécialisées dans un web service
    Bonjour

    J'ai mis en place un Web Service (pas WCF) qui utilise une dll contenant plusieurs classes, avec spécialisation.
    Concrètement, j'ai une classe Administrateur et User, qui spécialisent la classe Personne. La classe Personne possède un attribut protected "Name" et la property associée. Cet attribut est initialisé dans le constructeur.

    Lorsque je fais appel à mon web service via une autre solution, je ne vois pas mes classes spécialisées, je ne vois que les classes mères et sans property.

    J'ai essayé de rajouter l'attribut [Serializable()] à mes classes, l'attribut [SoapElement] ou [XmlElement] à mes properties et même ajouter [SoapInclude(typeof(User))]dans la classe de mon web service : je vois bien toutes mes classes mais les attributs restent désespérément vide

  2. #2
    Expert confirmé
    Homme Profil pro
    Développeur .NET
    Inscrit en
    novembre 2009
    Messages
    1 756
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 32
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : novembre 2009
    Messages : 1 756
    Points : 4 645
    Points
    4 645
    Par défaut
    Les properties sont bien en public et non en protected?
    De même les classes spécialisés sont publics?

  3. #3
    Membre régulier
    Femme Profil pro
    Etudiante en Développement
    Inscrit en
    avril 2012
    Messages
    106
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France

    Informations professionnelles :
    Activité : Etudiante en Développement
    Secteur : Industrie

    Informations forums :
    Inscription : avril 2012
    Messages : 106
    Points : 119
    Points
    119
    Par défaut
    Oui tout est public

    en ajoutant l'attribut SoapInclude j'arrive à les voir dans les types disponibles de mon web service, mais lorsque je m'en sers on dirait que toutes les initialisations faites dans mes constructeurs sont tout simplement ignorées; les attributs des objets que je créé sont tous à leur valeur par défaut( null ou 0)

  4. #4
    Expert éminent
    Avatar de Immobilis
    Homme Profil pro
    Développeur .NET
    Inscrit en
    mars 2004
    Messages
    6 559
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : mars 2004
    Messages : 6 559
    Points : 9 504
    Points
    9 504
    Par défaut
    Salut,

    Tu peux nous montrer le code des classes en question?

    A+
    "Winter is coming" (ma nouvelle page d'accueil)

  5. #5
    Membre régulier
    Femme Profil pro
    Etudiante en Développement
    Inscrit en
    avril 2012
    Messages
    106
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France

    Informations professionnelles :
    Activité : Etudiante en Développement
    Secteur : Industrie

    Informations forums :
    Inscription : avril 2012
    Messages : 106
    Points : 119
    Points
    119
    Par défaut
    Après plusieurs mèches de cheveux arrachés,
    j'ai finalement refait mon projet en WCF et en ajoutant l'attribut [KnownType] de mes classes filles sur mes classes mères, cela a fonctionné

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. Réponses: 1
    Dernier message: 01/08/2012, 09h48
  2. Réponses: 0
    Dernier message: 26/07/2011, 14h04
  3. Utilisation d'un goto dans un web service
    Par VonDutch4520 dans le forum Services Web
    Réponses: 4
    Dernier message: 09/07/2010, 17h54
  4. utiliser des classes dans une classe
    Par dsant dans le forum C++
    Réponses: 4
    Dernier message: 10/03/2008, 17h22
  5. Réponses: 2
    Dernier message: 12/04/2006, 21h48

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo