Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Discussion: Mon premier Bot

  1. #1
    Membre à l'essai
    Profil pro
    Inscrit en
    avril 2012
    Messages
    18
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations forums :
    Inscription : avril 2012
    Messages : 18
    Points : 12
    Points
    12

    Par défaut Mon premier Bot

    Bonjour, voilà je crée mon premier Bot... Et je cale déjà ^^

    J'aimerais seulement que mon bot réponde à !op et !op *. Voilà mon code :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    9
    on *:TEXT:!op *:#:{
      if ( $2 == $null ) {
        mode $chan +o $nick
      }
      else {
        mode $chan +o $2
      }
    }
    Je ne vois pas ce qui cloche, est ce que vous pouvez m'aider ?

    Merci d'avance

  2. #2
    Membre à l'essai
    Profil pro
    Inscrit en
    avril 2012
    Messages
    18
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations forums :
    Inscription : avril 2012
    Messages : 18
    Points : 12
    Points
    12

    Par défaut

    En faite quand je tape !op <pseudo> ça marche, mais quand je tape !op rien ne ce passe...

  3. #3
    Membre régulier

    Profil pro
    Inscrit en
    juin 2004
    Messages
    94
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2004
    Messages : 94
    Points : 118
    Points
    118

    Par défaut

    C'est normal, car tu as un espace entre "op" et "*". Donc ton script s'attend à réagir sur "op " plus quelque chose.
    La correction est donc toute simple:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    8
    on *:TEXT:!op*:#:{
      if ( $2 == $null ) {
        mode $chan +o $nick
      }
      else {
        mode $chan +o $2
      }
    }

  4. #4
    Membre à l'essai
    Profil pro
    Inscrit en
    avril 2012
    Messages
    18
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations forums :
    Inscription : avril 2012
    Messages : 18
    Points : 12
    Points
    12

    Par défaut

    Quelle bétise ^^ Merci beaucoup

Discussions similaires

  1. [JSF] mon premier JSF:Cannot find FacesContext
    Par anitshka dans le forum JSF
    Réponses: 15
    Dernier message: 24/08/2007, 18h19
  2. [Débutant] Mon premier programme: rien ne va...
    Par vincent0 dans le forum OpenGL
    Réponses: 10
    Dernier message: 02/08/2005, 13h59
  3. [JSF] mon premier custom component
    Par anitshka dans le forum JSF
    Réponses: 5
    Dernier message: 14/06/2005, 13h31
  4. [debutant]Mon premier prog OpenGL
    Par Revan777 dans le forum OpenGL
    Réponses: 5
    Dernier message: 04/04/2005, 17h40

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo