IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eric Python Discussion :

Installation de l'EDI eric5-5.1.7


Sujet :

Eric Python

  1. #1
    Membre du Club
    Inscrit en
    octobre 2010
    Messages
    66
    Détails du profil
    Informations forums :
    Inscription : octobre 2010
    Messages : 66
    Points : 44
    Points
    44
    Par défaut Installation de l'EDI eric5-5.1.7
    je veux installé l'ide eric v5-5.1.7 mais me demande l'installation pyqt4.qtcore
    et même quant je lance pyqt4 l' installation ne se fic-tue pas
    et merci d'avance

  2. #2
    Expert éminent

    Homme Profil pro
    Inscrit en
    octobre 2008
    Messages
    4 170
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations forums :
    Inscription : octobre 2008
    Messages : 4 170
    Points : 6 547
    Points
    6 547
    Par défaut
    Sur quel OS ?

    Eric 5 fonctionne avec Python 3 et utilise PyQt4, tu dois t'assurer d'avoir installés les deux avant toutes choses

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
     
    python3
    Python 3.1.2 (r312:79147, Dec  9 2011, 20:54:36) 
    [GCC 4.4.3] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    >>> from PyQt4 import QtCore
    Les erreurs te diront quoi.

  3. #3
    Membre du Club
    Inscrit en
    octobre 2010
    Messages
    66
    Détails du profil
    Informations forums :
    Inscription : octobre 2010
    Messages : 66
    Points : 44
    Points
    44
    Par défaut moi je parle sur l'installation sur Windows
    merci pour la repense
    mais je parle sur une installation sur windows
    et merci d'avance

  4. #4
    Responsable Qt & Livres


    Avatar de dourouc05
    Homme Profil pro
    Ingénieur de recherche
    Inscrit en
    août 2008
    Messages
    25 862
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Val de Marne (Île de France)

    Informations professionnelles :
    Activité : Ingénieur de recherche
    Secteur : Enseignement

    Informations forums :
    Inscription : août 2008
    Messages : 25 862
    Points : 181 669
    Points
    181 669
    Par défaut
    Ce que dit VinsS reste valable quel que soit l'OS (sauf la sortie précise de Python, mais les commandes ne changent pas).
    Vous souhaitez participer aux rubriques Qt (tutoriels, FAQ, traductions) ou HPC ? Contactez-moi par MP.

    Créer des applications graphiques en Python avec PyQt5
    Créer des applications avec Qt 5.

    Pas de question d'ordre technique par MP !

  5. #5
    Nouveau membre du Club
    Homme Profil pro
    Ingénieur
    Inscrit en
    août 2014
    Messages
    40
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 32
    Localisation : France, Seine et Marne (Île de France)

    Informations professionnelles :
    Activité : Ingénieur

    Informations forums :
    Inscription : août 2014
    Messages : 40
    Points : 33
    Points
    33
    Par défaut
    Bonjour,

    Je relance la discussion car j'ai le même problème.
    J'ai installé Python 2.7.9 et PyQt4 (ref : PyQt4-4.11.3-gpl-Py2.7-Qt4.8.6-x64)
    Mais il me dit "Import Error: Dll load failed" au sujet de la ligne PyQt4.QtCore import QDir.

    Pourtant sur le site de l'ide ERIC c'est écrit que ça fonctionne avec Python 2.6.0 ou mieux.

    Une idée d'où ça peut venir ? J'ai vérifié les variables d'env et celle de PyQt4 existe bien.

    Je précise que je suis sous W8

    Merci !

  6. #6
    Expert éminent

    Homme Profil pro
    Inscrit en
    octobre 2008
    Messages
    4 170
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations forums :
    Inscription : octobre 2008
    Messages : 4 170
    Points : 6 547
    Points
    6 547
    Par défaut
    Salut,

    Cette discussion traitait d'eric-5, donc Python 3.

    Si tu as un soucis avec Python 2 eric-4, ouvre un nouveau fil de discussion.

  7. #7
    Nouveau membre du Club
    Homme Profil pro
    Ingénieur
    Inscrit en
    août 2014
    Messages
    40
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 32
    Localisation : France, Seine et Marne (Île de France)

    Informations professionnelles :
    Activité : Ingénieur

    Informations forums :
    Inscription : août 2014
    Messages : 40
    Points : 33
    Points
    33
    Par défaut
    Bonjour,

    D'après ce site : http://eric-ide.python-projects.org/eric-download.html

    eric 5 est aussi utilisable avec python 2.7 ou alors j'ai loupé quelque chose

  8. #8
    Expert éminent

    Homme Profil pro
    Inscrit en
    octobre 2008
    Messages
    4 170
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Belgique

    Informations forums :
    Inscription : octobre 2008
    Messages : 4 170
    Points : 6 547
    Points
    6 547
    Par défaut
    Oui, mais aussi Python >= 3.1

    Pour ma part, eric-5 a toujours été associé à Python 3.

    Quoiqu'il en soit, il y a un autre problème, pour vérification, j'ai été voir les sources [0] et je constate qu'eric-5 utilise PyQt5 et non pas PyQt4.

    Donc soit tu utilises eric-4, soit tu installes PyQt5.
    Mon conseil, autant démarrer avec Python 3 et PyQt5.

    [0] http://die-offenbachs.homelinux.org:...2ff88ddf/E5Gui

Discussions similaires

  1. Réponses: 4
    Dernier message: 23/06/2010, 14h33
  2. Installation de l'edi Eclipse sous OpenSUSE 10.3
    Par floawed dans le forum SUSE
    Réponses: 10
    Dernier message: 02/04/2008, 15h29
  3. [Débutant][Installation] Java et EDI sur Mac OS X
    Par Boune dans le forum Général Java
    Réponses: 3
    Dernier message: 17/02/2006, 08h49
  4. Installation d'un edi java sur mandriva10.2 (GNOME)
    Par jamesleouf dans le forum Applications et environnements graphiques
    Réponses: 11
    Dernier message: 12/09/2005, 16h13
  5. [installation]un EDI java sur linux
    Par jamesleouf dans le forum EDI et Outils pour Java
    Réponses: 40
    Dernier message: 12/09/2005, 16h11

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo