Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

  1. #1
    Candidat au Club
    Inscrit en
    mars 2006
    Messages
    5
    Détails du profil
    Informations forums :
    Inscription : mars 2006
    Messages : 5
    Points : 2
    Points
    2

    Par défaut [Résolu] Mon fichier ne s'affiche pas...

    Bonjour,
    J'ai créé une base de données sous Access, avec des requêtes, de formulaires, etc. et tout allait très bien jusqu'à ce matin.

    Je commence à créer un nouveau formulaire avec l'assistant, et avant de finir je coche la case modifier la conception du formulaire (ou quelque chose dans le style). Puis je clique sur Terminer (je crois), et toutes les sous-fenêtres dans ma fenêtre Access se ferment.

    Je pense à un bug, alors je ferme Access, et j'essaie de rouvrir le fichier (qui a l'air intact, vu la taille qu'il fait), Access s'ouvre mais rien ne s'affiche dedans...

    Je ne sais pas quoi faire, pourtant dans les propriétés il a l'air normal, me dit qu'il y a tant de formulaires et tant de requêtes, donc mes enregistrements doivent bien être là quelque part mais je ne vois rien du tout !

    En copiant le fichier je n'arrive pas à le lire non plus, ni sur un autre PC.

    Merci pour votre aide...

  2. #2
    Rédacteur

    Avatar de Tofalu
    Homme Profil pro
    Technicien maintenance
    Inscrit en
    octobre 2004
    Messages
    9 501
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : France, Ain (Rhône Alpes)

    Informations professionnelles :
    Activité : Technicien maintenance
    Secteur : Associations - ONG

    Informations forums :
    Inscription : octobre 2004
    Messages : 9 501
    Points : 32 236
    Points
    32 236

    Par défaut

    As tu essayer de réparer le fichier (utilitaire de base de données, compacter)

    Quelle version d'Access ?

  3. #3
    Rédacteur/Modérateur

    Avatar de Heureux-oli
    Homme Profil pro
    Contrôleur d'industrie
    Inscrit en
    février 2006
    Messages
    21 019
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 54
    Localisation : Belgique

    Informations professionnelles :
    Activité : Contrôleur d'industrie
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : février 2006
    Messages : 21 019
    Points : 42 648
    Points
    42 648

    Par défaut

    As tu essayé l'assistant de compactage ?
    En français, on ne mentionne que le compactage sur la version anglais c'est compact and repair.

    Il est possible de lancer l'assistant vers une base qui n'est pas ouverte.
    J'ai pas encore de décodeur, alors, postez en clair ! Comment mettre une balise de code ?
    Débutez en VBA

    Mes articles


    Dans un MP, vous pouvez me dire que je suis beau, ... mais si c'est une question technique je ne la lis pas ! Vous êtes prévenus !

  4. #4
    Candidat au Club
    Inscrit en
    mars 2006
    Messages
    5
    Détails du profil
    Informations forums :
    Inscription : mars 2006
    Messages : 5
    Points : 2
    Points
    2

    Par défaut

    J'ai la version 2003 d'Access mais le fichier a l'air d'être sauvegardé sous version 2000.

    Sinon j'ai essayé Compact and Repair, et ça ne fait strictement rien, ni lorsque j'essaie de convertir en version 2002-2003 ou 97...

  5. #5
    Candidat au Club
    Inscrit en
    mars 2006
    Messages
    5
    Détails du profil
    Informations forums :
    Inscription : mars 2006
    Messages : 5
    Points : 2
    Points
    2

    Par défaut

    Est-ce qu'il est possible que ma version d'Access ou qu'un antivirus ou autre me bloque l'ouverture du fichier ?
    Un programme comme AccessFIX me retrouve bien tous les enregistrements, mais avec la version de démo je ne peux pas enregistrer la récup...

  6. #6
    Modérateur

    Homme Profil pro
    Inscrit en
    octobre 2005
    Messages
    13 227
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Canada

    Informations forums :
    Inscription : octobre 2005
    Messages : 13 227
    Points : 20 056
    Points
    20 056

    Par défaut

    Essaye un import de tous tes objets de ta base corrompue dans une base vierge.

    Ou repart d'une sauvegarde, apparement ta modif est légère donc tu ne devrais pas avoir trop de travail à refaire.

    A+
    Vous voulez une réponse rapide et efficace à vos questions téchniques ?
    Ne les posez pas en message privé mais dans le forum, vous bénéficiez ainsi de la compétence et de la disponibilité de tous les contributeurs.
    Et aussi regardez dans la FAQ Access et les Tutoriaux Access. C'est plein de bonnes choses.

  7. #7
    Candidat au Club
    Inscrit en
    mars 2006
    Messages
    5
    Détails du profil
    Informations forums :
    Inscription : mars 2006
    Messages : 5
    Points : 2
    Points
    2

    Par défaut

    J'aimerais bien, mais le problème c'est que je n'ai pas de sauvegarde qui date d'avant "l'accident", et je ne sais pas comment accéder aux objets qui s'y trouvent. Quand j'ouvre le fichier, cela revient au même que si j'ouvrais tout simplement Access (sans que la marge d'accueil Office n'apparaisse à droite), et il y a écrit Ready en bas.

  8. #8
    Membre averti Avatar de mcdotta
    Profil pro
    Inscrit en
    mai 2005
    Messages
    292
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations forums :
    Inscription : mai 2005
    Messages : 292
    Points : 324
    Points
    324

    Par défaut

    Peut-être....


    As-tu essayé d'ouvrir ton fichier avec la touche <Maj> enfoncée...

  9. #9
    Rédacteur/Modérateur

    Avatar de Heureux-oli
    Homme Profil pro
    Contrôleur d'industrie
    Inscrit en
    février 2006
    Messages
    21 019
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 54
    Localisation : Belgique

    Informations professionnelles :
    Activité : Contrôleur d'industrie
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : février 2006
    Messages : 21 019
    Points : 42 648
    Points
    42 648

    Par défaut

    Essaye aussi la touche F11.
    J'ai pas encore de décodeur, alors, postez en clair ! Comment mettre une balise de code ?
    Débutez en VBA

    Mes articles


    Dans un MP, vous pouvez me dire que je suis beau, ... mais si c'est une question technique je ne la lis pas ! Vous êtes prévenus !

  10. #10
    Modérateur

    Homme Profil pro
    Inscrit en
    octobre 2005
    Messages
    13 227
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Canada

    Informations forums :
    Inscription : octobre 2005
    Messages : 13 227
    Points : 20 056
    Points
    20 056

    Par défaut

    Citation Envoyé par natanyanka
    J'aimerais bien, mais le problème c'est que je n'ai pas de sauvegarde qui date d'avant "l'accident", et je ne sais pas comment accéder aux objets qui s'y trouvent. Quand j'ouvre le fichier, cela revient au même que si j'ouvrais tout simplement Access (sans que la marge d'accueil Office n'apparaisse à droite), et il y a écrit Ready en bas.
    Pour esayer l'import fait ceci :

    1) Crée une base vierge¸
    2) Va dans Fichier/Données externes/Importer
    3) Choisi ta base corompue
    Si cela marche il t'ouvre un écran où tu peux chosir ce que tu veux importer.
    4) Importe tous les objets.

    A+
    Vous voulez une réponse rapide et efficace à vos questions téchniques ?
    Ne les posez pas en message privé mais dans le forum, vous bénéficiez ainsi de la compétence et de la disponibilité de tous les contributeurs.
    Et aussi regardez dans la FAQ Access et les Tutoriaux Access. C'est plein de bonnes choses.

  11. #11
    Candidat au Club
    Inscrit en
    mars 2006
    Messages
    5
    Détails du profil
    Informations forums :
    Inscription : mars 2006
    Messages : 5
    Points : 2
    Points
    2

    Par défaut

    Merci infiniment marot_r, ça a marché !
    Je ne comprends tout de même pas ce qui s'est passé... Mais merci !!

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. fichiers uploadés mais mon site ne s'affiche pas.
    Par Pifon dans le forum Hébergement
    Réponses: 1
    Dernier message: 15/08/2014, 01h04
  2. Réponses: 8
    Dernier message: 04/05/2008, 14h09
  3. [XSL]Comment faire ceci ?? Mon for-each n'affiche pas tout !
    Par Devil666 dans le forum XSL/XSLT/XPATH
    Réponses: 4
    Dernier message: 27/07/2005, 15h04
  4. Mon dessin ne s'affiche pas au lancement...
    Par Deedier dans le forum MFC
    Réponses: 6
    Dernier message: 02/05/2005, 16h29
  5. [JApplet]mon applet ne s'affiche pas.
    Par yannick56 dans le forum Applets
    Réponses: 6
    Dernier message: 27/05/2004, 17h05

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo