Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Deski Discussion :

Problème Case migration forcée BOXIR2


Sujet :

Deski

  1. #1
    Membre à l'essai
    Problème Case migration forcée BOXIR2
    Bonjour,

    Je me permets de vous demander un peu d'aide concernant un point sur la case migration forcée.

    j'ai récemment eu un problème difficile à expliquer, je possède un rapport qui est en langue française ( créer en langue française il y a un certain temps et pas modifié entre temps ), mais lorsque je choisis l'importer puis de le rafraichir, je veux saisir des dates dans une invit date manuellement, normalement je les saisis au format français : dd/mm/yyyy mais je me rends compte que le format des dates des invit change et devient mm/dd/yyyy.
    Mon interface Deski ( concernant les menus) est en français mais celui de Deski est en anglais ( outil -> option -> le bouton langue pas la liste défilante). La case migration forcée est cochée.
    Je voudrais savoir comment fonctionne cette case, transforme t'elle les fonctions SQL dans une langue ? Je me rends compte dans mon invit date, si je regarde la case " valeur " je peux me rendre du format choisis, mais que me conseillez vous pour que ce problème de changement de format langue soit prévisible ( ne plus cocher la case migration forcée ou préférez une utilisation de Deski dans la langue du rapport ? )
    Est ce que quelqu'un a déjà rencontré un problème similaire sur Deski BOXRI2 voir BOXIR3 ?

    je vous remercie d'avance pour vos éventuelles réponses, si quelque chose n'est pas clair n'hésitez pas à me le demander, le problème concerne surtout le fonctionnement de la case migration forcée

  2. #2
    Membre régulier
    Bonjour,


    Oui je déterre un sujet, mais j'ai eu le même problème et j'ai trouvé la solution, et vu qu'il n'y a pas grand chose sur le web qui m'a aidé...


    Le problème était le format de date dans le SQL généré avec une invite (dans la clause Where).

    Note: Suite à une migration,

    Sur la XI R2 j’avais du : DD/MM/YYYY
    Sur la 4.1 du : MM/DD/YYYY



    Pour résoudre ce souci il faut aller sur le serveur BO dans :

    D:\Dossier_Intallation\SAP BusinessObjects Enterprise XI 4.0\dataAccess\connectionServer\oledb\extensions\qt

    Et modifier dans les fichiers sqlsrv*.PRM la ligne ci-dessous avec le format qui vous intéresse.

    <Parameter Name="USER_INPUT_DATE_FORMAT">'DD/MM/YYYY HH:m:s'</Parameter>

    Si vous utilisez d'autres BDD ou de l'odbc c'est dans des dossiers différents, cherchez un peu vous trouverez.

    Bonne journée à tous.