IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Silverlight Discussion :

ria services sur serveur mutualisé


Sujet :

Silverlight

  1. #1
    Membre à l'essai
    Profil pro
    Inscrit en
    juillet 2005
    Messages
    14
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juillet 2005
    Messages : 14
    Points : 11
    Points
    11
    Par défaut ria services sur serveur mutualisé
    bonjour,

    voila cela fais maintenant plus de 2 mois que je m'arrache les cheveux,

    en effet j'ai développé un site silverlight 4 (application métier Silverlight)

    Lorsque je déploie celui si en local sur mon IIS 7.0 cela fonctionne parfaitement
    création d'utilisateurs etc...

    alors vous allez me dire ba alors ou est le problème.
    hé bien dés que je déploie en production chez mon hébergeur dont je tairais le nom pour le moment j'ai droit à l'erreur suivante :

    Échec de l'opération Load pour la requête "GetUser". Le serveur distant a retourné une erreur : NotFound
    avec aucun détail sur l'erreur

    alors vous imaginez bien qu'en 2 mois j'ai un peu investigué

    grace à fidler j'ai un peu réduit le champs d'action et je m'appercois que je n'arrive pas à accéder a mon service : si je tape http://www.monappli.fr/ClientBin/monservice.svc

    j'obtiens une jolie 404

    que je n'ai pas en local sur mon IIS

    du coté de mon hébergeur ces joyeux lurons on commencés par me dire que c'était un problème de code (de quoi énerver pas mal de gens lorsque cela fonctionne en préprod)

    puis maintenant ils me demandes les prérequis pour faire fonctionner mon application

    si quelqu'un pourrais me venir en aide afin que je puisse cerner de façon plus précise le problème

    au passage cela ne vient pas de la connexion a la bdd puisque en local je fais pointé sur la base de prod et que cela fonctionne

    d'avance merci pour toute aide.

  2. #2
    Rédacteur
    Avatar de Nathanael Marchand
    Homme Profil pro
    Expert .Net So@t
    Inscrit en
    octobre 2008
    Messages
    3 615
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 35
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Expert .Net So@t
    Secteur : Conseil

    Informations forums :
    Inscription : octobre 2008
    Messages : 3 615
    Points : 8 054
    Points
    8 054
    Par défaut
    Et si tu mets un fichier html tout bateau dans le repertoire ClientBin, t'arrives à y accéder?

  3. #3
    Membre à l'essai
    Profil pro
    Inscrit en
    juillet 2005
    Messages
    14
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juillet 2005
    Messages : 14
    Points : 11
    Points
    11
    Par défaut
    oui j'ai placé une page html dans ClientBin,

    j'y accède si je tape l'url dans le navigateur

    il semblerais que se soit un problème de droit engendrant un problème de compilation.

    en affichant sur un autre hébergeur mutualisé le détail de l'erreur j'ai obtenu la chose suivante :
    Server Error in '/' Application.

    IIS specified authentication schemes 'Basic, Anonymous', but the binding only supports specification of exactly one authentication scheme. Valid authentication schemes are Digest, Negotiate, NTLM, Basic, or Anonymous. Change the IIS settings so that only a single authentication scheme is used.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.InvalidOperationException: IIS specified authentication schemes 'Basic, Anonymous', but the binding only supports specification of exactly one authentication scheme. Valid authentication schemes are Digest, Negotiate, NTLM, Basic, or Anonymous. Change the IIS settings so that only a single authentication scheme is used.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:


    [InvalidOperationException: IIS specified authentication schemes 'Basic, Anonymous', but the binding only supports specification of exactly one authentication scheme. Valid authentication schemes are Digest, Negotiate, NTLM, Basic, or Anonymous. Change the IIS settings so that only a single authentication scheme is used.]
    System.ServiceModel.Web.WebServiceHost.SetBindingCredentialBasedOnHostedEnvironment(ServiceEndpoint serviceEndpoint, AuthenticationSchemes supportedSchemes) +349683
    System.ServiceModel.Web.WebServiceHost.AddAutomaticWebHttpBindingEndpoints(ServiceHost host, IDictionary`2 implementedContracts, String multipleContractsErrorMessage, String standardEndpointKind) +806
    System.ServiceModel.Web.WebServiceHost.OnOpening() +244
    System.ServiceModel.DomainServices.Hosting.WebServiceHostInspector.OnOpening() +12
    System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout) +274
    System.ServiceModel.DomainServices.Hosting.WebServiceHostInspector.Inspect() +67
    System.ServiceModel.DomainServices.Hosting.ServiceUtility.VerifyAuthenticationMode() +94
    System.ServiceModel.DomainServices.Hosting.PoxBinaryEndpointFactory.CreateEndpointForAddress(ContractDescription contract, Uri address) +170
    System.ServiceModel.DomainServices.Hosting.PoxBinaryEndpointFactory.CreateEndpoints(DomainServiceDescription description, DomainServiceHost serviceHost) +150
    System.ServiceModel.DomainServices.Hosting.DomainServiceHost.CreateDescription(IDictionary`2& implementedContracts) +646
    System.ServiceModel.ServiceHostBase.InitializeDescription(UriSchemeKeyedCollection baseAddresses) +154
    System.ServiceModel.ServiceHost.InitializeDescription(Type serviceType, UriSchemeKeyedCollection baseAddresses) +49
    System.ServiceModel.DomainServices.Hosting.DomainServiceHost..ctor(Type domainServiceType, Uri[] baseAddresses) +271
    System.ServiceModel.DomainServices.Hosting.DomainServiceHostFactory.CreateServiceHost(Type serviceType, Uri[] baseAddresses) +29
    System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(String constructorString, Uri[] baseAddresses) +422
    System.ServiceModel.HostingManager.CreateService(String normalizedVirtualPath) +1440
    System.ServiceModel.HostingManager.ActivateService(String normalizedVirtualPath) +44
    System.ServiceModel.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath) +615

    [ServiceActivationException: The service '/Services/SigConcept-Web-AuthenticationService.svc' cannot be activated due to an exception during compilation. The exception message is: IIS specified authentication schemes 'Basic, Anonymous', but the binding only supports specification of exactly one authentication scheme. Valid authentication schemes are Digest, Negotiate, NTLM, Basic, or Anonymous. Change the IIS settings so that only a single authentication scheme is used..]
    System.Runtime.AsyncResult.End(IAsyncResult result) +687598
    System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result) +190
    System.ServiceModel.Activation.ServiceHttpHandler.EndProcessRequest(IAsyncResult result) +6
    System.Web.CallHandlerExecutionStep.OnAsyncHandlerCompletion(IAsyncResult ar) +96

    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1
    j'ai alors cherché et ajouté ceci a mon web.config dans system.webServer
    <security>
    <authentication>
    <basicAuthentication enabled="false" />
    </authentication>
    </security>
    hélas j'obtiens alors ceci :
    Server Error in '/' Application.

    Filename: \\?\UNC\WAGNER\wwwrootamenfr$\38234d8b1.hostnd\htdocs\www\web.config
    Line number: 118
    Error: This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".


    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.IO.FileLoadException: Filename: \\?\UNC\WAGNER\wwwrootamenfr$\38234d8b1.hostnd\htdocs\www\web.config
    Line number: 118
    Error: This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".



    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:


    [FileLoadException: Filename: \\?\UNC\WAGNER\wwwrootamenfr$\38234d8b1.hostnd\htdocs\www\web.config
    Line number: 118
    Error: This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".

    ]
    Microsoft.Web.Administration.Interop.IAppHostAdminManager.GetAdminSection(String bstrSectionName, String bstrPath) +0
    Microsoft.Web.Administration.WebConfigurationManager.GetSectionInternal(String siteName, String virtualPath, String sectionPath, Type sectionType) +281
    Microsoft.Web.Administration.WebConfigurationManager.GetSection(String siteName, String virtualPath, String sectionPath) +30

    [TargetInvocationException: Exception has been thrown by the target of an invocation.]
    System.RuntimeMethodHandle._InvokeMethodFast(IRuntimeMethodInfo method, Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeType typeOwner) +0
    System.RuntimeMethodHandle.InvokeMethodFast(IRuntimeMethodInfo method, Object target, Object[] arguments, Signature sig, MethodAttributes methodAttributes, RuntimeType typeOwner) +72
    System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks) +251
    System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) +28
    System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters) +19
    System.ServiceModel.WasHosting.WebConfigurationManagerWrapper.WebConfigGetSection(String siteName, String virtualPath, String sectionName) +106
    System.ServiceModel.WasHosting.MetabaseSettingsIis7V2.ProcessBasicAuthentication(String siteName, String virtualPath, HostedServiceTransportSettings& transportSettings) +22
    System.ServiceModel.WasHosting.MetabaseSettingsIis7V2.CreateTransportSettings(String relativeVirtualPath) +138
    System.ServiceModel.Activation.MetabaseSettingsIis.GetTransportSettings(String virtualPath) +118
    System.ServiceModel.Activation.MetabaseSettingsIis.GetAccessSslFlags(String virtualPath) +4
    System.ServiceModel.Activation.MetabaseSettings.GetAllowSslOnly(String virtualPath) +10
    System.ServiceModel.Activation.HttpHostedTransportConfiguration.GetBaseAddresses(String virtualPath) +87
    System.ServiceModel.Activation.HostedTransportConfigurationManager.InternalGetBaseAddresses(String virtualPath) +117
    System.ServiceModel.HostingManager.CreateService(String normalizedVirtualPath) +538
    System.ServiceModel.HostingManager.ActivateService(String normalizedVirtualPath) +44
    System.ServiceModel.HostingManager.EnsureServiceAvailable(String normalizedVirtualPath) +615

    [ServiceActivationException: The service '/Services/SigConcept-Web-AuthenticationService.svc' cannot be activated due to an exception during compilation. The exception message is: Exception has been thrown by the target of an invocation..]
    System.Runtime.AsyncResult.End(IAsyncResult result) +687598
    System.ServiceModel.Activation.HostedHttpRequestAsyncResult.End(IAsyncResult result) +190
    System.ServiceModel.Activation.ServiceHttpHandler.EndProcessRequest(IAsyncResult result) +6
    System.Web.CallHandlerExecutionStep.OnAsyncHandlerCompletion(IAsyncResult ar) +96

    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

  4. #4
    Expert confirmé
    Homme Profil pro
    Développeur .NET
    Inscrit en
    novembre 2009
    Messages
    1 755
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 32
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Développeur .NET

    Informations forums :
    Inscription : novembre 2009
    Messages : 1 755
    Points : 4 644
    Points
    4 644
    Par défaut
    Regarde sur ce lien si ca t'aide:
    http://blogs.msdn.com/b/saurabh/arch...eployment.aspx

  5. #5
    Membre à l'essai
    Profil pro
    Inscrit en
    juillet 2005
    Messages
    14
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juillet 2005
    Messages : 14
    Points : 11
    Points
    11
    Par défaut
    merci micka132 c'est très intéressant
    par contre pour la configuration avec une authentification en mode forms

    il écrit :
    Forms Auth + Integrated Auth is not supported.
    lorsqu'il écrit Integrated Auth il entends le Pipeline Mode Framework .Net ou pas

    si ce n'est pas le cas comment configurer en Anonymous plutôt quand Integrated Auth cela ce fait-il au niveau du pool d'application

    je commence à être complètement perdu la

  6. #6
    Membre régulier
    Homme Profil pro
    Inscrit en
    juillet 2011
    Messages
    82
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juillet 2011
    Messages : 82
    Points : 105
    Points
    105
    Par défaut
    Un sujet interessant !

    Le deploiement sur un hebergement mutualise est toujours tres "triviale".
    Premiere question, quel hebergeur ?

    Pour ma part j'etais chez ikoula (abo MSDN) et c'est tres simple, pas de ria sur les mutualises

    J'ai pas suivis le lien de micka, la nouvelle erreur provient du web.config (donc de la config) et je penses au framework 4.0, pas toujours pris en charge par les mutualises.

    Ghostong, tu devrait ouvrir un nouveau sujet car ce n'est pas le meme probleme. Thorfen sembles avoir un pb entre sa config web.config et ce que le serveur as de dispo (manques des DLL dans le GAC? Il faut les integrer depuis le web.config pour les svc notamment, toujours sur l'experience ikoula) alors que pour toi, ca peut etre beaucoup de chose (type MIME, connexion string)

  7. #7
    Futur Membre du Club
    Profil pro
    Inscrit en
    décembre 2010
    Messages
    10
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : décembre 2010
    Messages : 10
    Points : 7
    Points
    7
    Par défaut
    Bonjour,

    ok désolé pour avoir posté sur ce sujet, je pensais que l'erreur était dans le même genre.

    Je vais donc déplacer mon post.

    Ghost

Discussions similaires

  1. Réponses: 2
    Dernier message: 07/12/2011, 10h20
  2. [batch] [services windows] état service sur serveur distant
    Par Deadpool dans le forum Scripts/Batch
    Réponses: 3
    Dernier message: 16/03/2009, 18h50
  3. Ajout d'un module sur serveur mutualisé
    Par polo42 dans le forum Déploiement/Installation
    Réponses: 4
    Dernier message: 05/05/2008, 16h41
  4. [Configuration] limite upload sur serveur mutualisé 'privilege' chez 1and1?
    Par ned-flanders dans le forum EDI, CMS, Outils, Scripts et API
    Réponses: 6
    Dernier message: 13/03/2007, 17h46

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo