Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eclipse Java Discussion :

Déploiement sur un serveur JBoss


Sujet :

Eclipse Java

  1. #1
    Membre régulier
    Déploiement sur un serveur JBoss
    Bonjour,

    Je suis en train de développer une appli web pour m'auto-former, mais j'ai un petit souci de déploiement...
    Lorsque je déploie l'application avec Tomcat tout fonctionne, mais lorsque j'essaye avec JBoss cela ne fonctionne pas.

    J'ai l'exception suivante :
    org.apache.jasper.JasperException: Le fichier "/WEB-INF/c.tld" n'a pas été trouvé
    org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:51)
    org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:409)
    org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:116)
    org.apache.jasper.compiler.TagLibraryInfoImpl.<init>(TagLibraryInfoImpl.java:177)
    org.apache.jasper.compiler.Parser.parseTaglibDirective(Parser.java:382)
    org.apache.jasper.compiler.Parser.parseDirective(Parser.java:444)
    org.apache.jasper.compiler.Parser.parseElements(Parser.java:1394)
    org.apache.jasper.compiler.Parser.parse(Parser.java:130)
    org.apache.jasper.compiler.ParserController.doParse(ParserController.java:255)
    org.apache.jasper.compiler.ParserController.parse(ParserController.java:103)
    org.apache.jasper.compiler.Compiler.generateJava(Compiler.java:181)
    org.apache.jasper.compiler.Compiler.compile(Compiler.java:343)
    org.apache.jasper.compiler.Compiler.compile(Compiler.java:323)
    org.apache.jasper.compiler.Compiler.compile(Compiler.java:310)
    org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:605)
    org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:312)
    org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:326)
    org.apache.jasper.servlet.JspServlet.service(JspServlet.java:253)
    javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
    et le code de la JSP :
    Code :Sélectionner tout -Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    <%@ page language="java" contentType="text/html; charset=ISO-8859-1"
        pageEncoding="ISO-8859-1"%>
    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
    <%@ taglib uri="/WEB-INF/c.tld" prefix="c" %>
    <c:redirect url="/do/"/>
    Cela vient-il d'un paramètre dans Eclipse pour le serveur JBoss ?

    Merci d'avance pour votre aide.

  2. #2
    Rédacteur/Modérateur

    Bonjour,

    Le message signifie qu'il te manque le jar de JSTL... Donc il faut le déployer, d'une manière ou d'une autre.
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire, dont l'utilité et la qualité dépendent du soin apporté à nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

###raw>template_hook.ano_emploi###