IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Développement Sharepoint .NET Discussion :

[SP-2010] Ajouter un editeur wysiwyg dans une custom web part


Sujet :

Développement Sharepoint .NET

  1. #1
    Expert éminent sénior
    Avatar de Baptiste Wicht
    Homme Profil pro
    Étudiant
    Inscrit en
    octobre 2005
    Messages
    7 431
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Suisse

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : octobre 2005
    Messages : 7 431
    Points : 21 318
    Points
    21 318
    Par défaut [SP-2010] Ajouter un editeur wysiwyg dans une custom web part
    Bonjour,

    J'essaie déséspérément d'ajouter un éditeur de texte riche dans une de mes applications Sharepoint, mais je n'y parviens pas

    J'ai trouvé qu'il fallait utiliser le composant InputFormTextBox, ce que j'ai fais :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    <SharePoint:InputFormTextBox class="ms-input" ID="DescriptionTextArea" runat="server" RichText="true" RichTextMode="Compatible" TextMode="MultiLine" Rows="20" />
    Mais seulement une text area est affichée, c'est-à-dire que je n'ai pas de toolbar pour modifier le texte. Je pense que ça vient du faire qu'il y a des erreurs dans le Javascript et que la transformation en éditeur riche n'est pas faite.

    Voici les erreurs JS que je reçois :

    Message: Invalid source HTML for this operation.
    Line: 33
    Char: 3
    Code: 0
    URI: http://localhost/_layouts/1033/form....w0gwqGhg%3D%3D

    Message: 'selection' is null or not an object
    Line: 375
    Char: 2
    Code: 0
    URI: http://localhost/_layouts/1033/form....w0gwqGhg%3D%3D
    Est-ce que quelqu'un aurait une idée ?

    J'ai trouvé pleins de posts parlant de problèmes avec ce composant sur internet, mais aucun ne proposant de solution qui marche dans mon cas.

    Merci d'avance

    Baptiste Wicht

  2. #2
    Membre chevronné
    Profil pro
    Inscrit en
    mai 2004
    Messages
    1 486
    Détails du profil
    Informations personnelles :
    Âge : 36
    Localisation : France, Hérault (Languedoc Roussillon)

    Informations forums :
    Inscription : mai 2004
    Messages : 1 486
    Points : 2 082
    Points
    2 082
    Par défaut
    Salut,

    Ta (master)page référence-t-elle bien les fichiers js suivants ? :
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    <script type="text/javascript" language="javascript" src="/_layouts/1033/init.js"></script>
    <script type="text/javascript" language="javascript" src="/_layouts/1033/core.js"></script>
    <script type="text/javascript" language="javascript" src="/_layouts/1033/form.js"></script>
    1033 n'est peut-être pas applicable dans ton cas si tu utilises un sharepoint français (1036).

  3. #3
    Expert éminent sénior
    Avatar de Baptiste Wicht
    Homme Profil pro
    Étudiant
    Inscrit en
    octobre 2005
    Messages
    7 431
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Suisse

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : octobre 2005
    Messages : 7 431
    Points : 21 318
    Points
    21 318
    Par défaut
    Oui, j'ai bien ajouté les 3 fichiers .js cités. (avec 1033, car Sharepoint anglais).

  4. #4
    Expert éminent sénior
    Avatar de Baptiste Wicht
    Homme Profil pro
    Étudiant
    Inscrit en
    octobre 2005
    Messages
    7 431
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : Suisse

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : octobre 2005
    Messages : 7 431
    Points : 21 318
    Points
    21 318
    Par défaut
    Personne n'a jamais rencontré ce problème ?

    Ou alors est-ce que quelqu'un a une autre solution pour utiliser un éditeur wysiwyg dans une web part personnelle ?

Discussions similaires

  1. [AC-2010] Ajout de pièces jointes dans une liste sharepoint avec runtime access 2010
    Par loic maxwell dans le forum Access
    Réponses: 0
    Dernier message: 28/07/2014, 11h51
  2. [AJAX] ajout / suppression champs ( dynamiquement ) dans une page web
    Par anwar1987 dans le forum Général JavaScript
    Réponses: 1
    Dernier message: 09/03/2009, 19h37
  3. Editeur XML dans une page Web
    Par GregHory dans le forum C#
    Réponses: 3
    Dernier message: 08/12/2008, 17h20
  4. Editeur WYSIWYG dans une page WEB
    Par sami_c dans le forum Flash
    Réponses: 3
    Dernier message: 23/10/2006, 09h34
  5. Pb d'Ajout un noeud fils dans une arborescence
    Par oramine dans le forum Oracle
    Réponses: 5
    Dernier message: 21/12/2004, 16h39

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo