IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Eclipse Java Discussion :

Import soudainement en erreur


Sujet :

Eclipse Java

  1. #1
    Rédacteur

    Homme Profil pro
    Technical Lead Salesforce
    Inscrit en
    février 2009
    Messages
    563
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 31
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Technical Lead Salesforce

    Informations forums :
    Inscription : février 2009
    Messages : 563
    Points : 1 667
    Points
    1 667
    Par défaut Import soudainement en erreur
    Bonjour,

    Aujourd'hui, j'ai lancé Eclipse et quand j'ai regardé un projet, j'ai vu qu'il y avait plein d'erreurs, c'est à dire que tout mes imports ne sont plus bon, il ne reconnait plus la classe String, etc..

    Bizarrement, cela ne me le faisait pas la semaine dernière.

    Une image sera plus simple à comprendre je pense:

    Quelqu'un saurait-il m'indiquer quoi faire ?

    Merci d'avance pour votre aide.
    Images attachées Images attachées  
    - Mes articles
    - Consultant technique Salesforce
    - Salesforce Certified Administrator
    - Salesforce Certified Platform App Builder
    - Salesforce Certified Developper I
    - Salesforce Certified Sales Cloud
    - Salesforce Certified Service Cloud

  2. #2
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 468
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 468
    Points : 17 035
    Points
    17 035
    Par défaut
    Bonjour,

    On va dire que parfois ça peut se produire... Il peut y avoir plusieurs explications.

    Commence par relancer ton Eclipse.
    Si ce n'est pas efficace, alors as-tu des projets dépendants les uns des autres ?
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire, dont l'utilité et la qualité dépendent du soin apporté à nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  3. #3
    Rédacteur

    Homme Profil pro
    Technical Lead Salesforce
    Inscrit en
    février 2009
    Messages
    563
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 31
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Technical Lead Salesforce

    Informations forums :
    Inscription : février 2009
    Messages : 563
    Points : 1 667
    Points
    1 667
    Par défaut
    Je viens de relancer Eclipse et c'est toujours pareil.

    Non, mon projet ne dépend pas d'un autre.

    Quand je clique sur la première croix rouge (le nom de mon package), ca me propose de configurer mon buildpath mais je ne sais pas si ça a un rapport..
    - Mes articles
    - Consultant technique Salesforce
    - Salesforce Certified Administrator
    - Salesforce Certified Platform App Builder
    - Salesforce Certified Developper I
    - Salesforce Certified Sales Cloud
    - Salesforce Certified Service Cloud

  4. #4
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 468
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 468
    Points : 17 035
    Points
    17 035
    Par défaut
    Bon, dans ce cas c'est une histoire plus classique a priori...

    Vérifie ce qu'il te dit, ouvre les propriétés de ton projet et regarde le Build Path. tu devrais y voir des warnings (parmi les onglets).

    Sinon, il faut voir ce que te dit la vue Problems.
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire, dont l'utilité et la qualité dépendent du soin apporté à nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  5. #5
    Rédacteur

    Homme Profil pro
    Technical Lead Salesforce
    Inscrit en
    février 2009
    Messages
    563
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 31
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Technical Lead Salesforce

    Informations forums :
    Inscription : février 2009
    Messages : 563
    Points : 1 667
    Points
    1 667
    Par défaut
    Il n'y a pas de warning dans le Build Path de mon projet...
    - Mes articles
    - Consultant technique Salesforce
    - Salesforce Certified Administrator
    - Salesforce Certified Platform App Builder
    - Salesforce Certified Developper I
    - Salesforce Certified Sales Cloud
    - Salesforce Certified Service Cloud

  6. #6
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 468
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 468
    Points : 17 035
    Points
    17 035
    Par défaut
    Alors...

    T'a fait un Project > Clean de ton projet ?
    T'as tenté un eclipse -clean en ligne de commande ?
    Outre, les erreurs indiquées dans ton screenshot, la vue Problems, elle dit quoi de plus ?
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire, dont l'utilité et la qualité dépendent du soin apporté à nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  7. #7
    Rédacteur

    Homme Profil pro
    Technical Lead Salesforce
    Inscrit en
    février 2009
    Messages
    563
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 31
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Technical Lead Salesforce

    Informations forums :
    Inscription : février 2009
    Messages : 563
    Points : 1 667
    Points
    1 667
    Par défaut
    J'ai fais un Clean de mon projet mais ça ne change.

    Comme autre erreur, j'ai par exemple:
    - The import java.io cannot be resolved
    - the import Android cannot be resolved
    - String cannot be resolved to a type
    ...

    Dans l'onglet Markers, il y a un nombre d'erreurs avec des explications:
    - The project was not built since its build path is incomplete. Cannot find the class file for java.lang.Object. Fix the build path then try building this project
    - The type java.lang.Object cannot be resolved. It is indirectly referenced from required .class files
    - Unable to resolve target 'android-8' until the SDK is loaded.
    - Mes articles
    - Consultant technique Salesforce
    - Salesforce Certified Administrator
    - Salesforce Certified Platform App Builder
    - Salesforce Certified Developper I
    - Salesforce Certified Sales Cloud
    - Salesforce Certified Service Cloud

  8. #8
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 468
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 468
    Points : 17 035
    Points
    17 035
    Par défaut
    T'as un versionning style SVN / CVS ou autre ?
    Ca permettrait de vérifier qu'il n'y a rien qui a changé dans le .classpath par exemple... Sinon regarde quand même dans ce fichier (via la vue Navigator).

    Il y a aussi la vue Error Log qui permet de voir si Eclipse démarre correctement avec tout ce dont il a besoin...

    Créé un nouveau projet pour voir si ça fait la même chose...
    Après ça je crois que je sèche... Une réinstallation de l'IDE et puis c'est marre
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire, dont l'utilité et la qualité dépendent du soin apporté à nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  9. #9
    Rédacteur

    Homme Profil pro
    Technical Lead Salesforce
    Inscrit en
    février 2009
    Messages
    563
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 31
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Technical Lead Salesforce

    Informations forums :
    Inscription : février 2009
    Messages : 563
    Points : 1 667
    Points
    1 667
    Par défaut
    Je viens de créé un nouveau projet et je n'ai pas d'erreur, j'ai créé un attribut de type String, un autre de type int et ca ne me met pas d'erreur.

    Comment je fais pour savoir le versionning?
    - Mes articles
    - Consultant technique Salesforce
    - Salesforce Certified Administrator
    - Salesforce Certified Platform App Builder
    - Salesforce Certified Developper I
    - Salesforce Certified Sales Cloud
    - Salesforce Certified Service Cloud

  10. #10
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 468
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 468
    Points : 17 035
    Points
    17 035
    Par défaut
    Citation Envoyé par absot Voir le message
    Comment je fais pour savoir le versionning?
    Donc, tu n'en n'as pas, sinon tu saurais .
    Pas grave, par contre, tu le vois ton fichier .classpath, n'est-ce pas ???!
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire, dont l'utilité et la qualité dépendent du soin apporté à nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  11. #11
    Rédacteur

    Homme Profil pro
    Technical Lead Salesforce
    Inscrit en
    février 2009
    Messages
    563
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 31
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Technical Lead Salesforce

    Informations forums :
    Inscription : février 2009
    Messages : 563
    Points : 1 667
    Points
    1 667
    Par défaut
    Oui, j'ai bien un fichier .classpath dans le répertoire de mon projet, voilà ce qu'il contient:
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    6
    7
    <?xml version="1.0" encoding="UTF-8"?>
    <classpath>
      <classpathentry kind="src" path="src"/>
      <classpathentry kind="src" path="gen"/>
      <classpathentry kind="con" path="com.android.ide.eclipse.adt.ANDROID_FRAMEWORK"/>
      <classpathentry kind="output" path="bin"/>
    </classpath>
    - Mes articles
    - Consultant technique Salesforce
    - Salesforce Certified Administrator
    - Salesforce Certified Platform App Builder
    - Salesforce Certified Developper I
    - Salesforce Certified Sales Cloud
    - Salesforce Certified Service Cloud

  12. #12
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 468
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 468
    Points : 17 035
    Points
    17 035
    Par défaut
    Bien... Et dans ton autre projet Android, t'as quoi en comparaison ?
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire, dont l'utilité et la qualité dépendent du soin apporté à nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  13. #13
    Rédacteur

    Homme Profil pro
    Technical Lead Salesforce
    Inscrit en
    février 2009
    Messages
    563
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 31
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Technical Lead Salesforce

    Informations forums :
    Inscription : février 2009
    Messages : 563
    Points : 1 667
    Points
    1 667
    Par défaut
    J'ai la même chose.

    Quand j'import d'autres projet non-android, ca fonctionne.

    Hier, j'ai changé de CM mais je n'ai pas réinstaller mon système, je ne pense pas que ca ai un rapport puisque ça ne touche pas à mon projet mais peut-être que si?
    - Mes articles
    - Consultant technique Salesforce
    - Salesforce Certified Administrator
    - Salesforce Certified Platform App Builder
    - Salesforce Certified Developper I
    - Salesforce Certified Sales Cloud
    - Salesforce Certified Service Cloud

  14. #14
    Rédacteur/Modérateur
    Avatar de Laurent.B
    Homme Profil pro
    Ingénieur développement logiciels
    Inscrit en
    novembre 2004
    Messages
    3 468
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 48
    Localisation : France, Bouches du Rhône (Provence Alpes Côte d'Azur)

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : novembre 2004
    Messages : 3 468
    Points : 17 035
    Points
    17 035
    Par défaut
    Citation Envoyé par absot Voir le message
    J'ai la même chose.

    Quand j'import d'autres projet non-android, ca fonctionne.

    Hier, j'ai changé de CM mais je n'ai pas réinstaller mon système, je ne pense pas que ca ai un rapport puisque ça ne touche pas à mon projet mais peut-être que si?
    J'en sais rien, je suis d'accord avec le fait que théoriquement ça ne devrait rien changer mais je serais assez peu étonné que ça ait quand même un impact. La prochaine fois, n'omets pas ce genre d'info, on gagnera peut-être du temps !

    Je cède ma place... Bon courage !
    Responsable FAQ Eclipse | Maintiens et développe un des logiciels destinés aux rédacteurs sur developpez.com
    Gardons toujours à l'esprit que le forum constitue une base documentaire, dont l'utilité et la qualité dépendent du soin apporté à nos questions et nos réponses. Soyons polis, précis (dans le titre et dans le corps des questions), concis, constructifs et faisons de notre mieux pour respecter la langue française et sa grammaire. Merci pour nous (les modérateurs) mais aussi et surtout, merci pour vous.
    Problème solutionné => je vais au bas de la page et je clique sur le bouton (qui suite à mise à jour du forum, a légèrement changé d'aspect).

  15. #15
    Rédacteur

    Homme Profil pro
    Technical Lead Salesforce
    Inscrit en
    février 2009
    Messages
    563
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 31
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Technical Lead Salesforce

    Informations forums :
    Inscription : février 2009
    Messages : 563
    Points : 1 667
    Points
    1 667
    Par défaut
    Ok, merci de ton aide quand même.

    Mon système où il y a le problème est un windows, j'en ai un autre qui est sur un portable avec Ubuntu et ça fonctionne sans problème et c'est celui qui m'est le plus important.
    - Mes articles
    - Consultant technique Salesforce
    - Salesforce Certified Administrator
    - Salesforce Certified Platform App Builder
    - Salesforce Certified Developper I
    - Salesforce Certified Sales Cloud
    - Salesforce Certified Service Cloud

Discussions similaires

  1. [WD10] Importer fichier excel erreur colone heure
    Par Techys dans le forum WinDev
    Réponses: 4
    Dernier message: 31/08/2012, 09h42
  2. Import dump MySQL : erreur pager
    Par CoeurDeSQL dans le forum Administration
    Réponses: 4
    Dernier message: 06/12/2011, 23h13
  3. Import dump MySQL : erreur pager
    Par CoeurDeSQL dans le forum Requêtes
    Réponses: 4
    Dernier message: 06/12/2011, 23h13
  4. Importer contacts msn, erreur cURL
    Par Invité dans le forum Bibliothèques
    Réponses: 4
    Dernier message: 10/10/2007, 13h34
  5. Import CSV et Erreur SQL0181N sur les dates
    Par bladerunners dans le forum DB2
    Réponses: 2
    Dernier message: 16/03/2007, 10h12

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo