IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Connectivité Discussion :

Connexion ODBC - Tables et Vues


Sujet :

Connectivité

  1. #1
    Membre à l'essai
    Inscrit en
    décembre 2010
    Messages
    9
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 9
    Points : 10
    Points
    10
    Par défaut Connexion ODBC - Tables et Vues
    Bonjour,
    J'essaie de me connecter via ODBC sous Crystal mais il ne m'affiche ni mes tables ni mes vues (nb : en revanche en oledb, cela fonctionne,malheureusement j'ai besoin de ma connexon en odbc),
    auriez-vous une idée,
    merci

  2. #2
    Modérateur
    Avatar de luc_chivas
    Profil pro
    Consultant BO/Crystal Reports
    Inscrit en
    avril 2004
    Messages
    1 821
    Détails du profil
    Informations personnelles :
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Consultant BO/Crystal Reports

    Informations forums :
    Inscription : avril 2004
    Messages : 1 821
    Points : 2 488
    Points
    2 488
    Par défaut
    bonjour,

    tu utilises les bons identifiants de connexion qui te mènent au schéma dans lequel tu as tes vues, et procédures ??
    Luc

    Disponible - Intervention sur demande tout pays, toutes régions
    Formateur Crystal Reports (toutes versions)
    Contrat de support possible
    N'hésitez pas.... http://paypal.me/lucrascar

  3. #3
    Membre à l'essai
    Inscrit en
    décembre 2010
    Messages
    9
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 9
    Points : 10
    Points
    10
    Par défaut
    Bonjour,

    Oui, lorsque je mets mes identifiants, je peux voir le nom de la base s'afficher mais pas les vues et tables qu'elle contient, il n'y a que des schémas (qui correspondent à d'autres choses).
    Dans les propriétés de CR,j'ai coché tables et vues etc... mais cela ne change rien

    Merci de votre aide

    PS : je me connecte a une base oracle

  4. #4
    Modérateur
    Avatar de luc_chivas
    Profil pro
    Consultant BO/Crystal Reports
    Inscrit en
    avril 2004
    Messages
    1 821
    Détails du profil
    Informations personnelles :
    Localisation : France, Haute Savoie (Rhône Alpes)

    Informations professionnelles :
    Activité : Consultant BO/Crystal Reports

    Informations forums :
    Inscription : avril 2004
    Messages : 1 821
    Points : 2 488
    Points
    2 488
    Par défaut
    Bonjour

    Excuses moi d'insister, mais cela ressemble à un souci de schéma...
    Peux tu vérifier ton TNSNAME pour voir si tu pointe bien sur la bonne table..
    As tu un utilitaire de genre TOAD qui te permettrais de vérifier tes schémas...
    Luc

    Disponible - Intervention sur demande tout pays, toutes régions
    Formateur Crystal Reports (toutes versions)
    Contrat de support possible
    N'hésitez pas.... http://paypal.me/lucrascar

  5. #5
    Membre à l'essai
    Inscrit en
    décembre 2010
    Messages
    9
    Détails du profil
    Informations forums :
    Inscription : décembre 2010
    Messages : 9
    Points : 10
    Points
    10
    Par défaut
    Bonjour,
    En effet,j'utilise toad.
    Je viens de tester via celui-ci et j'accède bien à toute ma bd.
    Depuis le gestionnaire de pilotes odbc,le test de connexion est aussi ok.
    En revanche,je ne vois pas dans Crystal où je peux spécifier le TNS?

    Merci de votre aide

  6. #6
    Nouveau membre du Club
    Homme Profil pro
    Administrateur de base de données
    Inscrit en
    juillet 2009
    Messages
    17
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 44
    Localisation : Belgique

    Informations professionnelles :
    Activité : Administrateur de base de données

    Informations forums :
    Inscription : juillet 2009
    Messages : 17
    Points : 27
    Points
    27
    Par défaut
    un peu tard pour répondre mais ça peut en aider d'autres

    j'ai eu le même problème d'acces avec crystal version XI et 2008
    pas moyen de voir les tables en crystal alors que cela fonctionnait sous toad et même avec l'acces odbc excel

    il y a un petit Bug/Problème en crystal pour le contourner
    un fois que tu as ajouté ta connexion OBDC à la création de rapport
    ou via l'expert base de données sur un rapport existant

    tu fais un click Droit sur ta connexion et tu sélectionne option

    dans la 2 ème partie de l'onglet tu peut sélectionner si tu veux voir les Tables, vues, table systeme, synonymes, procédures stockèes

    par défaut Tables,vues et procédures stockèes sont sélectionnées
    tu décoche procédures stockèes

    un refresh sur la connexion et les tables & vues devraient être visibles

Discussions similaires

  1. Réponses: 2
    Dernier message: 29/05/2015, 14h29
  2. [WD15] Lecture d'une table après connexion ODBC
    Par bestmoroco dans le forum WinDev
    Réponses: 3
    Dernier message: 05/12/2012, 11h04
  3. [AC-2007] Connexion à des tables liées en ODBC
    Par david71 dans le forum VBA Access
    Réponses: 1
    Dernier message: 06/08/2010, 22h37
  4. [XL-2003] Peut-on faire un update de table sur une connexion ODBC avec Excel ?
    Par tibofo dans le forum Macros et VBA Excel
    Réponses: 3
    Dernier message: 04/11/2009, 18h12
  5. Connexion ODBC
    Par Anonymous dans le forum Réseau
    Réponses: 2
    Dernier message: 23/04/2002, 12h10

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo