IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

Ruby on Rails Discussion :

NetBeans arrête le support du module Ruby on Rails


Sujet :

Ruby on Rails

  1. #1
    Expert éminent sénior
    Avatar de Idelways
    Homme Profil pro
    Développeur Ruby on Rails / iOS
    Inscrit en
    juin 2010
    Messages
    1 374
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Développeur Ruby on Rails / iOS

    Informations forums :
    Inscription : juin 2010
    Messages : 1 374
    Points : 68 508
    Points
    68 508
    Par défaut NetBeans arrête le support du module Ruby on Rails
    NetBeans arrête le support du module Ruby on Rails
    Et concentre ses efforts sur l'intégration de Java SE 7



    NetBeans 7.0, actuellement en bêta et prévu en version définitive pour avril, n'offrira plus de module pour Ruby on Rails. En cause, la faible utilisation de l'IDE d'Oracle par les développeurs Rails et la volonté de l'équipe du projet de se concentrer sur une meilleure intégration de Java 7.

    La décision est assez peu surprenante. Les développeurs Ruby ont généralement un penchant pour des IDE légers comme Textmate sous MaxOS, E-Texteditor sous Windows ou Vim et Emacs sous Linux. L'utilisation quasiment indispensable de la ligne de commande pour les diverses tâches de développement, de test et de déploiement a certainement contribué à cette tendance.

    Quant au très spécialisé et très complet RubyMine, bien que payant, il semble fortement séduire les développeurs de la communauté Rails qui préfèrent les environnements de développement intégrés.

    Le module Ruby on Rails a donc été retiré hier des versions de développement disponibles de NetBeans. Oracle laisse cependant la porte ouverte aux développeurs indépendants qui souhaiteraient maintenir eux même ce module.

    « Java SE 7 et Java Development Kit 7 (JDK 7) sont les prochaines sorties majeures de la plateforme Java SE qu'Oracle s'est engagé à livrer en 2011. L'objectif clé de l'équipe de NetBeans est d'offrir un support supérieur pour la plateforme Java » peut on lire dans le communiqué où Oracle rappelle ses priorités.

    Source : Site officiel de NetBeans

    Et vous ?

    Utilisez-vous NetBeans pour vos développements Ruby on Rails ? Qu'en pensez-vous ?
    Regrettez-vous cette décision ?

  2. #2
    Membre averti
    Profil pro
    Inscrit en
    juin 2006
    Messages
    115
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2006
    Messages : 115
    Points : 403
    Points
    403
    Par défaut
    C'est un cercle vicieux : j'ai commencé avec Netbeans pour Ruby mais cela faisait plusieurs mois que le projet n'avancait plus (depuis le départ de Thor Norbye ?). Dans le même temps, Jetbrains a mis le paquet et je me suis tourné vers cet IDE agréable et dynamique malgré la licence payante et propriétaire.

    Si Oracle avait la volonté de faire un produit innovant, je ne pense pas que ce soit les moyens financiers qui manquent pour recruter des dev mais cette boite n'est qu'une pompe à fric qui n'a que faire du libre, comme les différentes décisions l'ont prouvé ces derniers mois sur d'autres projets issus de Sun.

  3. #3
    Membre éclairé
    Avatar de Floréal
    Profil pro
    Inscrit en
    novembre 2004
    Messages
    456
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France

    Informations forums :
    Inscription : novembre 2004
    Messages : 456
    Points : 841
    Points
    841
    Par défaut
    Jetbrains propose une version gratuite, mais uniquement si tu travailles sur un projet OpenSource (il faut indiquer l'url du projet et celle de son Dépot). Mais c'est vrai que c'est dommage que Netbeans laisse RoR de coté.
    Ancien membre du projet "Le Dernier Âge".

  4. #4
    Membre chevronné
    Profil pro
    Inscrit en
    janvier 2007
    Messages
    1 448
    Détails du profil
    Informations personnelles :
    Âge : 37
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : janvier 2007
    Messages : 1 448
    Points : 2 199
    Points
    2 199
    Par défaut
    C'est pas grave si ils arrêtent, il y à plein de gens, comme vous nous le montrez, qui sont prêts à démontrer de la qualité de leurs logiciels.
    Par contre c'est dommage, netbeans était déjà très centré autour de java et n'avait que peu d'outils pour les autres langages / fw, il se "contentait" de lorgner l'audience de php avec la prise ne charge de fw trop connus.
    Ils ne font qu'accentuer cet état de fait.....


    Ou comment la mort de java entraîna avec lui quelques victimes collatéral.
    Alors c'est l'histoire d'un langage......
    ..

    a+

  5. #5
    Candidat au Club
    Inscrit en
    juillet 2010
    Messages
    4
    Détails du profil
    Informations forums :
    Inscription : juillet 2010
    Messages : 4
    Points : 2
    Points
    2
    Par défaut
    de toute facon netbeans insistait trop sur jruby (et donc java).
    sinon il y as redcar encore en alpha mais c est tres prometteur.

  6. #6
    Membre éclairé

    Profil pro
    Inscrit en
    janvier 2007
    Messages
    510
    Détails du profil
    Informations personnelles :
    Localisation : France, Gironde (Aquitaine)

    Informations forums :
    Inscription : janvier 2007
    Messages : 510
    Points : 652
    Points
    652
    Par défaut
    Utilisez-vous NetBeans pour vos développements Ruby on Rails ? Qu'en pensez-vous ?
    Oui. Au départ j'utilisais Eclipse, puis je suis passé sous Netbeans.
    Et puis finalement, je me suis rendu compte qu'un IDE ne sert pas à grand chose pour faire du Rails. (Aujourd'hui je préfère un bon traitement de texte)
    Regrettez-vous cette décision ?
    Non.

  7. #7
    Nouveau membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    janvier 2006
    Messages
    21
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 41
    Localisation : Burkina Faso

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : janvier 2006
    Messages : 21
    Points : 29
    Points
    29
    Par défaut Netbeans n'arrête pas l'utilisation du support RoR
    Netbeans n'arrête pas l'utilisation du support RoR, mais n'est pas en mesure actuellement ( faute de personnel) de continuer le développement de ce support. En fait. Celui qui veut utiliser RoR devrait télécharger les versions antérieures à la 7.0.
    D'ailleurs la communauté demande des volontaires qui pourraient continuer le développement des fonctionnalités RoR ( http://wiki.netbeans.org/RubySupport).
    Cordialement

  8. #8
    Membre actif Avatar de rivsc
    Homme Profil pro
    Développeur Web
    Inscrit en
    décembre 2008
    Messages
    213
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : décembre 2008
    Messages : 213
    Points : 275
    Points
    275
    Par défaut
    @Zfred : le débuggeur c'était quand même bien utile, et le fait de pouvoir naviguer dans les sources de rails (ctrl + click gauche sur les fonctions de rails ou de mon appli). Intégration de subversion (pas essentiel mais sympa, avec diff).... quand même moi ça va me manquer. Je passerai bien à redCar si vraiment ça devient ingérable avec Netbeans !

  9. #9
    Membre éclairé

    Profil pro
    Inscrit en
    janvier 2007
    Messages
    510
    Détails du profil
    Informations personnelles :
    Localisation : France, Gironde (Aquitaine)

    Informations forums :
    Inscription : janvier 2007
    Messages : 510
    Points : 652
    Points
    652
    Par défaut
    Voila j'ai un super exemple : Je code avec Textmate sous Macos.
    La seule fonctionnalité que j'utilise (que j'utilisais lol), c'est le bunddle "script/generate" qui évite de taper la commande à la main, dans une console.
    Eh bien depuis que j'ai mis à jour Leopard (32bits) en Snow Leopard 64bits) et que je me suis joué la vie avec le connecteur ruby-mysql à recompiler moi même, eh beh résultat le bunddle de Textmate ne fonctionne plus.

    Non seulement je n'ai pas le temps, concrètement, à me demander pourquoi mon pseudo-ide, qui tourne dans un système propriétaire, ne fonctionne plus, mais en plus ça ne m'intéresse pas du tout. Si j'ai acheté un Mac c'est justement pour avoir du prêt à porter "class" sans me prendre la tête.
    Donc la solution à mon problème c'est vite vu : J'ouvre une console et j'écris "script/generate ..." moi même et ça fonctionne quelque soit le système.

    Quant à svn, je n'ai jamais trouvé mieux que d'interroger directement le serveur de version, via Trac ou Redmine.

  10. #10
    Membre actif Avatar de rivsc
    Homme Profil pro
    Développeur Web
    Inscrit en
    décembre 2008
    Messages
    213
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : décembre 2008
    Messages : 213
    Points : 275
    Points
    275
    Par défaut
    @Zfred : Comment déboggues-tu ?

  11. #11
    Membre éclairé

    Profil pro
    Inscrit en
    janvier 2007
    Messages
    510
    Détails du profil
    Informations personnelles :
    Localisation : France, Gironde (Aquitaine)

    Informations forums :
    Inscription : janvier 2007
    Messages : 510
    Points : 652
    Points
    652
    Par défaut
    Comment déboggues-tu ?
    Je me sers des logs de Mongrel, la plupart du temps l'erreur est explicite.
    Je teste avec Firefox + Firebug + Yslow en permanence.
    J'ai bien essayé gem install ruby-debug, mais honnêtement, je n'aime pas trop.
    Quand j'ai besoin de connaitre la valeur d'une variable, j'écris <%= ma_variable %> dans la vue, c'est aussi rapide que d'écrire "debug".
    Sinon j'ai quelques erreurs javascript qui passent sans que je ne puisse rien faire, et là je suis obligé de commenter des paragraphes entiers pour trouver d'ou ça vient. Mais je ne crois pas qu'il existe des outils pour débugguer ça. Si ?

  12. #12
    Membre actif Avatar de rivsc
    Homme Profil pro
    Développeur Web
    Inscrit en
    décembre 2008
    Messages
    213
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Moselle (Lorraine)

    Informations professionnelles :
    Activité : Développeur Web

    Informations forums :
    Inscription : décembre 2008
    Messages : 213
    Points : 275
    Points
    275
    Par défaut
    Ok d'accord.

    Mais je ne crois pas qu'il existe des outils pour débugguer ça. Si ?
    Hum dans Firebug il existe un débogueur javascript. Mais là il ne s'agit plus d'un IDE Ror.

    Je suis passé il y a quelques mois sous chromium (ou chrome) avec les "outils pour développeur" (équivalent de firebug pour firefox), il y a aussi un débogueur javascript.

  13. #13
    Membre éclairé

    Profil pro
    Inscrit en
    janvier 2007
    Messages
    510
    Détails du profil
    Informations personnelles :
    Localisation : France, Gironde (Aquitaine)

    Informations forums :
    Inscription : janvier 2007
    Messages : 510
    Points : 652
    Points
    652
    Par défaut
    Hum dans Firebug il existe un débogueur javascript.
    Oui bien sûr, mais ça débuggue pas tout...
    chromium (ou chrome) avec les "outils pour développeur" (équivalent de firebug pour firefox), il y a aussi un débogueur javascript.
    Tout à fait. Je n'ai pas trouvé que ça soit techniquement "mieux" mais parfois c'est plus clair, et ça peut aider.

Discussions similaires

  1. NetBeans arrête le support du module Ruby on Rails
    Par Idelways dans le forum Actualités
    Réponses: 0
    Dernier message: 28/01/2011, 12h18
  2. Réponses: 7
    Dernier message: 11/12/2007, 10h08
  3. Arrêt du support technique de PB9
    Par ElRed dans le forum Powerbuilder
    Réponses: 0
    Dernier message: 03/11/2006, 12h47
  4. [XHTML] module RUBY, comment l'intégrer?
    Par mikotte dans le forum Balisage (X)HTML et validation W3C
    Réponses: 1
    Dernier message: 17/12/2005, 13h10

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo