+ Répondre à la discussion Actualité déjà publiée
  1. #81
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2015
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Maroc

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Enseignement

    Informations forums :
    Inscription : mai 2015
    Messages : 2
    Points : 3
    Points
    3

    Par défaut

    Comment puis je vérifier la bonne configuration de Apache?

    Vous avez une solution à me proposer?

  2. #82
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    juillet 2015
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 26
    Localisation : France, Seine Saint Denis (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : juillet 2015
    Messages : 3
    Points : 4
    Points
    4

    Par défaut The requested URL/nagios was not found on this server

    Dans cette partie là tu dis:


    YaST ; ====> comment faire ici vu qu'il n'ya pas yast sur ma debian
    Catégorie "Sécurité et utilisateurs" ;
    Pare-feu ;
    Rajoutons "Serveur http" à la liste des services autorisés de la zone externe.
    Maintenant nous pouvons nous connecter à Nagios via le lien suivant : http://supervision/nagios ==> au lieu de ça j'ai plutot mis http://nagios/nagios car le nom de mon compte est nagios et nom supervision


    et là il me donne cet erreur là

    NOT FOUND
    The requested URL/nagios was not found on this server
    ---------------------------------------------------------------
    Apache/2.2.22 (Debian) Server at nagios Port 80


    quand je fais 127.0.0.1 j'ai un gros IT WORKS pourtant


    SVP C'est urgent pourriez vous m'aider Dibril ou qnqn d'autre

  3. #83
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    juillet 2015
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 26
    Localisation : France, Seine Saint Denis (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : juillet 2015
    Messages : 3
    Points : 4
    Points
    4

    Par défaut 404 Not Found

    Dans cette partie là tu dis:


    YaST ; ====> comment faire ici vu qu'il n'ya pas yast sur ma debian
    Catégorie "Sécurité et utilisateurs" ;
    Pare-feu ;
    Rajoutons "Serveur http" à la liste des services autorisés de la zone externe.
    Maintenant nous pouvons nous connecter à Nagios via le lien suivant : http://supervision/nagios ==> au lieu de ça j'ai plutot mis http://nagios/nagios car le nom de mon compte est nagios et nom supervision


    et là il me donne cet erreur là

    NOT FOUND
    The requested URL/nagios was not found on this server
    ---------------------------------------------------------------
    Apache/2.2.22 (Debian) Server at nagios Port 80


    quand je fais 127.0.0.1 j'ai un gros IT WORKS pourtant


    SVP C'est urgent pourriez vous m'aider Dibril ou qnqn d'autre

  4. #84
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    18 999
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 18 999
    Points : 495 670
    Points
    495 670

    Par défaut

    Bonjour,

    Dans la documentation, il est écrit :
    Avant de se connecter à la page Web de Nagios, il est important de vérifier que le pare-feu du serveur ne bloque pas l'affichage des pages Web. C'est la cas sous Suse. Pour cela, allons dans
    donc ce n'est pas le cas sous Debian.

    supervision, d'après la documentation, c'est le nom du serveur où tu installes nagios, à toi de t'adapter.

  5. #85
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    juillet 2015
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 26
    Localisation : France, Seine Saint Denis (Île de France)

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : juillet 2015
    Messages : 3
    Points : 4
    Points
    4

    Par défaut ERROR 404

    Merci pour ta réponse rapide DJibril
    j'ai bien compris que Yast c'était sur SUSE

    mais là mon problème c'est que je ne parviens toujours pas à afficher la première page web suite à cet erreur.
    Comment faire PLZ?

  6. #86
    Futur Membre du Club
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    septembre 2015
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Transports

    Informations forums :
    Inscription : septembre 2015
    Messages : 6
    Points : 5
    Points
    5

    Par défaut

    Citation Envoyé par Compain07 Voir le message
    Bonsoir,


    Je suis aussi débutant sur Linux, et je cherche à utiliser Nagios pour un projet de fin d'année.
    Je n'arrive pas accéder aux différents onglets sur l'interface web. Exemple si je clique sur Host ou services, il me propose de télécharger le fichier status.cgi .

    Comment puis-je régler ce problème ?

    Quelqu'un pour m'aider svp!!!

    hello,
    J'ai exactement le meme problème et je ne trouve pas de solution.As-tu trouvé une solution ?

    Merci !

  7. #87
    Membre à l'essai Avatar de gadje
    Homme Profil pro
    Reconversion développeur, C'EST PAS SIMPLE !!!
    Inscrit en
    mars 2010
    Messages
    69
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Finistère (Bretagne)

    Informations professionnelles :
    Activité : Reconversion développeur, C'EST PAS SIMPLE !!!

    Informations forums :
    Inscription : mars 2010
    Messages : 69
    Points : 18
    Points
    18

    Par défaut Idem

    Bonjour, j'ai également ce problème de téléchargement de fichiers.cgi après avoir cliqué sur l'un des liens.
    Si quelqu'un a la solution, ce serait sympa.
    (Nagios 4.1.1 / Ubuntu 14.04)

    Merci.

    @+

  8. #88
    Futur Membre du Club
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    septembre 2015
    Messages
    6
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : France, Val d'Oise (Île de France)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Transports

    Informations forums :
    Inscription : septembre 2015
    Messages : 6
    Points : 5
    Points
    5

    Par défaut

    Pour ma part j'ai activé les CGI car ce n'est pas parce qu'ils sont installé qu'ils sont activé.
    Sur debian il m'a suffit du commande pour résoudre le probleme.

    a2enmod CGI

  9. #89
    Membre à l'essai
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    septembre 2015
    Messages
    7
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Calvados (Basse Normandie)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Transports

    Informations forums :
    Inscription : septembre 2015
    Messages : 7
    Points : 10
    Points
    10

    Par défaut

    J'ai suivi ton tuto d'installation, rien à faire, quand je vais sur le localhost/nagios, j'ai une erreur "NOT FOUND"...

    edit : Et je viens de le re-refaire, toujours le même soucis, je suis sur une version ubuntu 15.10...

  10. #90
    Membre à l'essai
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    septembre 2015
    Messages
    7
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Calvados (Basse Normandie)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Transports

    Informations forums :
    Inscription : septembre 2015
    Messages : 7
    Points : 10
    Points
    10

    Par défaut

    Citation Envoyé par Tristanae Voir le message
    J'ai suivi ton tuto d'installation, rien à faire, quand je vais sur le localhost/nagios, j'ai une erreur "NOT FOUND"...

    edit : Et je viens de le re-refaire, toujours le même soucis, je suis sur une version ubuntu 15.10...
    Je remarque que durant l'installation des pré-requis j'ai ça comme erreur :
    root@S50SCL002:~# apt-get install apache2 libapache2-mod-php5 php5-gd php5 make gcc build-essential wget libgd-gd2-perl libgd2-dev libgd2-xpm libgd2-xpm-dev libnet-snmp-perl libssl-dev snmp daemon
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    Note : sélection de « libgd-perl » au lieu de « libgd-gd2-perl »
    Note : sélection de « libgd-dev » au lieu de « libgd2-dev »
    Note : sélection de « libgd-dev » au lieu de « libgd2-xpm-dev »
    E: Impossible de trouver le paquet libgd2-xpm

  11. #91
    Membre à l'essai
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    septembre 2015
    Messages
    7
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Calvados (Basse Normandie)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Transports

    Informations forums :
    Inscription : septembre 2015
    Messages : 7
    Points : 10
    Points
    10

    Par défaut

    Bon, après avoir mixer deux trois tuto je suis arrivé à quelques choses qui fonctionne, par contre problème sur l'ajout de machine Linux, au moment du configure du NRPE, effectivement j'ai le problème avec le SSL, mais la commande que tu donne dans le tutoriel ne fonctionne pas...

  12. #92
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    18 999
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 18 999
    Points : 495 670
    Points
    495 670

    Par défaut

    Bonjour,

    Merci de préciser vos dires à savoir commandes ne fonctionnant pas, rajouts effectués pour faire fonctionner vos installations...

  13. #93
    Membre à l'essai
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    septembre 2015
    Messages
    7
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Calvados (Basse Normandie)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Transports

    Informations forums :
    Inscription : septembre 2015
    Messages : 7
    Points : 10
    Points
    10

    Par défaut

    Citation Envoyé par djibril Voir le message
    Bonjour,

    Merci de préciser vos dires à savoir commandes ne fonctionnant pas, rajouts effectués pour faire fonctionner vos installations...
    servprod:/usr/local/src # ./configure --enable-command-args

    « --enable-command-args » : permet d'activer le support des arguments des commandes.
    Si vous obtenez ce message :
    checking for SSL libraries... configure: error: Cannot find ssl libraries
    Il faut effectuer une petite modification car le programme ne trouve pas la bibliothèque SSL.


    Sous ma Debian, j'ai recherché le fichier libssl.so.
    # updatedb
    # locate libssl.so
    /usr/lib/i386-linux-gnu/libssl.so
    /usr/lib/i386-linux-gnu/libssl.so.1.0.0
    /usr/lib/i386-linux-gnu/i586/libssl.so.1.0.0
    /usr/lib/i386-linux-gnu/i686/cmov/libssl.so.1.0.0
    /usr/lib/vmware-tools/lib32/libssl.so.0.9.8
    /usr/lib/vmware-tools/lib32/libssl.so.0.9.8/libssl.so.0.9.8
    /usr/lib/vmware-tools/lib64/libssl.so.0.9.8
    /usr/lib/vmware-tools/lib64/libssl.so.0.9.8/libssl.so.0.9.8
    Ensuite, j'ai créé un lien symbolique :
    ln -s /usr/lib/i386-linux-gnu/libssl.so /usr/lib/libssl.so
    Donc j'ai tenté le "ln -s /usr/lib/i386-linux-gnu/libssl.so /usr/lib/libssl.so", et j'ai comme message "ls: impossible d'accéder à /usr/lib/libssl.so: Aucun fichier ou dossier de ce type"

    De plus quand je fais un locate "libssl.so" je n'ai que deux résultats :
    • /lib/x86_64-linux-gnu/libssl.so.1.0.0
    • /usr/lib/x86_64-linux-gnu/libssl.so

  14. #94
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    18 999
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 18 999
    Points : 495 670
    Points
    495 670

    Par défaut

    Tu t'adaptes à ton environnement .

    Dans ton cas, ce sera
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    ln -s /usr/lib/x86_64-linux-gnu/libssl.so /usr/lib/libssl.so

  15. #95
    Membre à l'essai
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    septembre 2015
    Messages
    7
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Calvados (Basse Normandie)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Transports

    Informations forums :
    Inscription : septembre 2015
    Messages : 7
    Points : 10
    Points
    10

    Par défaut

    Citation Envoyé par djibril Voir le message
    Tu t'adaptes à ton environnement .

    Dans ton cas, ce sera
    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    ln -s /usr/lib/x86_64-linux-gnu/libssl.so /usr/lib/libssl.so
    Oui pardon, c'est ce que j'ai fais, et là j'ai effectivement le message d'erreur sur le "ls: impossible d'accéder à /usr/lib/libssl.so: Aucun fichier ou dossier de ce type".

    Edit : Je suis un demeuré, j'essaye de faire un ls.... *va cherche sa corde*

  16. #96
    Membre à l'essai
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    septembre 2015
    Messages
    7
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Calvados (Basse Normandie)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Transports

    Informations forums :
    Inscription : septembre 2015
    Messages : 7
    Points : 10
    Points
    10

    Par défaut

    Modification du fichier /etc/xinetd.d/nrpe pour définir le service
    servprod:/usr/local/src/nagios-plugins-1.5 # vi /etc/xinetd.d/nrpe

    service nrpe
    {
    flags = REUSE
    socket_type = stream
    port = 5666
    wait = no
    user = nagios
    group = nagios
    server = /usr/local/nagios/bin/nrpe
    server_args = -c /usr/local/nagios/etc/nrpe.cfg --inetd
    log_on_failure += USERID
    disable = no
    only_from = 127.0.0.1 192.168.1.12
    }
    À la place de 192.168.1.12, vous pouvez mettre le nom DNS « HOSTNAME.domaine ».

    only_from : permet de lister les hôtes autorisés à contacter NRPE.
    Vous pouvez rajouter avant le -c, l'option « -n » qui déshabilite SSL (si vous n'utilisez pas SSL).
    Par contre là, je suis pas sûr de comprendre..

    Déjà j'ai pas d'adresse après le 127.0.0.1 Mais derrière je dois rajouter l'adresse du NAGIOS ? Sous la forme <172.20.0.253.STADIUMCOMPANY> ?

  17. #97
    Membre à l'essai
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    septembre 2015
    Messages
    7
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Calvados (Basse Normandie)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Transports

    Informations forums :
    Inscription : septembre 2015
    Messages : 7
    Points : 10
    Points
    10

    Par défaut

    Nouveau test via check_nrpe et check_disk.

    check_disk via nrpe
    /usr/local/nagios/libexec/check_nrpe -H 127.0.0.1 -c check_disk -a 50% 100% /
    DISK CRITICAL - free space: / 227593 MB (96% inode=-);| /=9373MB;118483;0;0;236967
    L'option -a permet de passer des paramètres
    /usr/local/nagios/libexec/check_disk -w 10% -c 5% -u GB
    DISK OK - free space: / 222 GB (96% inode=-); /dev 0 GB (99% inode=99%);| /=9GB;207;219;0;231 /dev=0GB;0;0;0;0
    J'ai un message sur le "/usr/local/nagios/libexec/check_disk -w 10% -c 5% -u GB" - DISK CRITIQUE - /run/user/1000gvfs n'est pas accessible: Permission non accordée.

    J'ai tenté la commande "/usr/local/nagios/libexec/check_disk -w 10% -c 5% -u GB -A -i.gvf", j'ai bien les informations sur la place restante dans les disques, mais on va pas se mentir, ca me donne un paquet de ligne qu'il faut déchiffrer

  18. #98
    Nouveau Candidat au Club
    Femme Profil pro
    Chargé de référencement
    Inscrit en
    avril 2016
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : France, Morbihan (Bretagne)

    Informations professionnelles :
    Activité : Chargé de référencement

    Informations forums :
    Inscription : avril 2016
    Messages : 1
    Points : 1
    Points
    1

    Par défaut

    Avec debian 7.10 ca peut passer ?
    Difficile de trouver la 7.8 de nos jours.

  19. #99
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    18 999
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 18 999
    Points : 495 670
    Points
    495 670

    Par défaut

    Au moment de la rédaction du tutoriel, nous étions à Debian 7.8, mais l'installation fonctionne avec les versions les plus récentes.

  20. #100
    Nouveau Candidat au Club
    Homme Profil pro
    Ingénieur systèmes et réseaux
    Inscrit en
    avril 2016
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Hauts de Seine (Île de France)

    Informations professionnelles :
    Activité : Ingénieur systèmes et réseaux
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : avril 2016
    Messages : 1
    Points : 1
    Points
    1

    Par défaut II-G. Démarrage de Nagios

    Voilà ce qu'il me met quand je lance la commande /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg



    bash: /usr/local/nagios/bin/nagios: Aucun fichier ou dossier de ce type

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo