+ Répondre à la discussion Actualité déjà publiée
  1. #61
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 094
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 094
    Points : 496 043
    Points
    496 043

    Par défaut

    Dans la documentation de Nagios, tu peux aller à plus de mille serveurs sans soucis.

  2. #62
    Candidat au Club
    Homme Profil pro
    Technicien réseau
    Inscrit en
    juillet 2014
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Gironde (Aquitaine)

    Informations professionnelles :
    Activité : Technicien réseau

    Informations forums :
    Inscription : juillet 2014
    Messages : 2
    Points : 2
    Points
    2

    Par défaut

    Merci pour la réponse rapide !

  3. #63
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 094
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 094
    Points : 496 043
    Points
    496 043

    Par défaut

    Bonjour,

    Tutoriel mis à jour en expliquant comment installer openssl-devel sous SLES, ainsi qu'une réponse à la fameuse erreur Could not complete SSL handshake.

    Bonne lecture.

  4. #64
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    juin 2014
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 36
    Localisation : Burkina Faso

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juin 2014
    Messages : 3
    Points : 4
    Points
    4

    Par défaut configurer les hotes

    desoler de debarké de null part
    moi mon problem est que je n'arrive pas configurer les hotes sur (Fully Automated Nagios)
    besoin d'aidehttp://www.developpez.net/forums/images/smilies/icon_sad.gif

  5. #65
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 094
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 094
    Points : 496 043
    Points
    496 043

    Par défaut

    C'est assez peu comme description pour avoir de l'aide !

  6. #66
    Nouveau Candidat au Club
    Homme Profil pro
    Stagiaire
    Inscrit en
    décembre 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Gabon

    Informations professionnelles :
    Activité : Stagiaire
    Secteur : High Tech - Multimédia et Internet

    Informations forums :
    Inscription : décembre 2012
    Messages : 2
    Points : 0
    Points
    0

    Par défaut Etudiant stagiaire

    Bonjour Djibril

    Merci encore pour ton tuto qui je crois va me rendre beaucoup service.
    En effet, je suis actuellement en stage dans une grosse entreprise et il m'a été demandé
    en plus de mon thème de stage, de mettre en place un système de supervision du gros réseau
    de cette structure. Après avoir cherché sur le net, j'ai essayé Cacti sur Windows mais j'ai
    eu du fil à retorde pour le configurer. Pour être honnête, je ne crois pas avoir bien cherché la docs.
    Mais maintenant que j'ai lu ton tuto, je crois que je vais tenter d'utiliser la solution nagios.

    Toutefois, s'il est possible de me conseiller une solution intéressante sur Windows, je suis preneur
    car je suis au biberon avec les système Unix/Linux.

    En tout cas je te ferrai un retour de mes tests que j'effectuerai en virtuel dans un premier temps.

    Cordialement !

  7. #67
    Candidat au Club
    Inscrit en
    juillet 2006
    Messages
    8
    Détails du profil
    Informations forums :
    Inscription : juillet 2006
    Messages : 8
    Points : 2
    Points
    2

    Par défaut

    Salut chers tous,,

    Je débute avec nagios, j'ai donc commencé avec le tuto de Djibril. mais voila que je bloque sur quatres services qui sont sur Unknown (voir image). Je prend l'exemple du service Memory usage, lorsque je l'exécute en mode commande sur la console linux j'ai ceci:
    ./check_nt -H 192.168.112.139 -p 12489 -v MEMUSE -w 80 -c 90 -s motdepasse
    Impossible d'obtenir l'information depuis le serveur

    or si j'exécute celle du cpu load j'ai ceci:
    ./check_nt -H 192.168.112.139 -p 12489 -v CPULOAD -l 5,80,90 -s motdepasse
    Charge CPU 0% (5 moyenne minimale) | '5 Charge moyenne minimale'=0%;80;90;0;100

    pour les autres services en Unknown c'est pareil, je suis un peu dépassé depuis 1 semaine que je farfouille. Merci pour toute aide.

    Nom : Capture.PNG
Affichages : 559
Taille : 71,3 Ko

  8. #68
    Candidat au Club
    Femme Profil pro
    Étudiant
    Inscrit en
    avril 2012
    Messages
    3
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Localisation : Tunisie

    Informations professionnelles :
    Activité : Étudiant
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : avril 2012
    Messages : 3
    Points : 4
    Points
    4

    Par défaut

    Salut tout le monde chui débutante en tout ce qui est linux et tout, mon mini projet consiste a installer Nagious .
    je viens de lire l'article posté sur ce forum a ce propos , et j'ai du mal a commencer , est ce que je dois installer Linux Debian 7.2 ? ou je peux tout simplement utiliser une machine virtuelle ubunto ??

  9. #69
    Candidat au Club
    Homme Profil pro
    Administrateur systèmes et réseaux
    Inscrit en
    octobre 2013
    Messages
    1
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France, Ille et Vilaine (Bretagne)

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux
    Secteur : Enseignement

    Informations forums :
    Inscription : octobre 2013
    Messages : 1
    Points : 3
    Points
    3

    Par défaut

    Bonjour,

    Tout d'abord merci pour ce tuto.

    J'ajoute juste deux trois infos pour une Debian 7.7 amd64 & Nagios 4.0.8

    Pour l'installation de nrpe :

    les lib sont dans /usr/lib/x86_x64-linux-gnu

    la commande pour installer tout ce petit monde :

    ./configure --enable-command-args --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib/x86_64-linux-gnu

    Sauf erreur, on peut se passer de xinetd.
    Depuis le répertoire où on a décompresser nrpe, il suffit de faire :
    cp init-script.debian /etc/init.d/nrpe
    chmod 755 /etc/init.d/nrpe

    Ajouter ceci au fichier :

    ### BEGIN INIT INFO
    # Provides: nrpe
    # Required-Start: $remote_fs $syslog
    # Required-Stop: $remote_fs $syslog
    # Default-Start: 2 3 4 5
    # Default-Stop: 0 1 6
    # Short-Description: Starts and stops the NRPE daemon
    # Description: Starts and stops the NRPE daemon
    ### END INIT INFO

    puis update.rc.d nrpe defaults

  10. #70
    Membre régulier
    Homme Profil pro
    Étudiant
    Inscrit en
    février 2008
    Messages
    377
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : février 2008
    Messages : 377
    Points : 82
    Points
    82

    Par défaut Souci avec nagios

    Bonjour à tous,

    J'ai suivi le tuto et j'ai une petite question. Quand je vais sur l'adresse, il ne me trouve pas la page.
    Et quand je vais sur /var/www/html/ il n'y a pas de dossier nagios.

    Comment faire pour y accèder ?

  11. #71
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 094
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 094
    Points : 496 043
    Points
    496 043

    Par défaut

    Normalement, l'installation de Nagios paramètre le chemin de l'URL automatiquement dans ton apache préalablement installé. Donc tu ne le trouves pas où tu penses et n'a même pas besoin de savoir où il est .

  12. #72
    Futur Membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    octobre 2011
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : octobre 2011
    Messages : 8
    Points : 9
    Points
    9

    Par défaut nagios url not found

    Bonjour, je débute dans tout le domaine linux et nagios pour faire de la supervision snmp, donc j'ai bien suivi les différents tuto, mais une fois que j'ouvre firefox, je tape 127.0.0.1/nagios il me sort un affichage tout dégueulasse à gauche et au milieu le fameux "not found" et quand je clic n'importe ou tout plante,

    j'essais d’installé sur virtualbox, ubuntu 14...., nagios4.1.0rc1, tout ce met bien comme dans vos tuto, le check de nagios tout OK pas d'erreur, apache2 start OK, nagios start OK, donc je ne comprend pas du tout, j'ai demandé à un pote et il me dt qu'il a des fichiers dans "/etc/nagios" mais moi je n'ai rien ce dossier n'existe pas, alors que j'ai suivi le même tuto que lui ( www.unixmen.com/install-configure-nagios-4-ubuntu-14-1014-04 ).

    pourriez vous essayer de me dépatouiller merci.

  13. #73
    Futur Membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    octobre 2011
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : octobre 2011
    Messages : 8
    Points : 9
    Points
    9

    Par défaut

    Citation Envoyé par manganat Voir le message
    Bonjour, je débute dans tout le domaine linux et nagios pour faire de la supervision snmp, donc j'ai bien suivi les différents tuto, mais une fois que j'ouvre firefox, je tape 127.0.0.1/nagios il me sort un affichage tout dégueulasse à gauche et au milieu le fameux "not found" et quand je clic n'importe ou tout plante,

    j'essais d’installé sur virtualbox, ubuntu 14...., nagios4.1.0rc1, tout ce met bien comme dans vos tuto, le check de nagios tout OK pas d'erreur, apache2 start OK, nagios start OK, donc je ne comprend pas du tout, j'ai demandé à un pote et il me dt qu'il a des fichiers dans "/etc/nagios" mais moi je n'ai rien ce dossier n'existe pas, alors que j'ai suivi le même tuto que lui ( ICI ).

    pourriez vous essayer de me dépatouiller merci.
    EDIT : après ré,ré,ré ect... install sur une VM au propre je pense que mon soucis venez qu'il devait me manquer des prérequis que j'ai install presque un par un, car la grande ligne de commande c'est un peut dur a voir clairement.

  14. #74
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 094
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 094
    Points : 496 043
    Points
    496 043

    Par défaut


  15. #75
    Futur Membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    octobre 2011
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : octobre 2011
    Messages : 8
    Points : 9
    Points
    9

    Par défaut

    voila maintenant cela marche bien donc je continu le TUTO que vous avez fait, je suis au chapitre III.A dans la parti ou afficher les info du disc en GB.

    j'ai bien rajouter le ARG4 dans le fichier commands.cfg puis -u GB dans le fichier localhost.cfg , PROBLÈME quand j'allait voir dans le navigateur nagios l'affichage ne bouger pas il restait en MB donc j'ai changer le % du disc pour avoir un warning et idem rien ne ce passer,

    j'ai fermer mon navigateur, relancer..... pareil, puis je suis retourné dans le fichier localhost et j'ai changé le nom "check_local_disk" en "check_disk" et la direct le changement est apparu mon warning en jaune et l'espace disc en GB donc est normale ou faut il modifier cette petite parti dans votre tuto ??

  16. #76
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 094
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 094
    Points : 496 043
    Points
    496 043

    Par défaut

    À chaque modification de configuration, il faut relancer le service nagios pour que la modification soit prise en compte.

  17. #77
    Futur Membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    octobre 2011
    Messages
    8
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : octobre 2011
    Messages : 8
    Points : 9
    Points
    9

    Par défaut

    Citation Envoyé par djibril Voir le message
    À chaque modification de configuration, il faut relancer le service nagios pour que la modification soit prise en compte.
    bien a chaque fois que j'ai modif il me semble que j'ai fait des "service nagios restart" et il me disais "done" a chaque fois et une fois que j'ai modif le nom j'ai pas u besoin de restart et j'ai vu la ligne passer en jaune pour mon warning ( a confirmer car avec tout les changement que j'essai je ne me rappel plus )

  18. #78
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 094
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 094
    Points : 496 043
    Points
    496 043

    Par défaut

    Bonjour,

    Tutoriel mis à jour en expliquant comment installer NSCP au dépend de NSClient++ sous Windows.

    Bonne lecture.

  19. #79
    Candidat au Club
    Homme Profil pro
    Étudiant
    Inscrit en
    mai 2015
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Maroc

    Informations professionnelles :
    Activité : Étudiant
    Secteur : Enseignement

    Informations forums :
    Inscription : mai 2015
    Messages : 2
    Points : 3
    Points
    3

    Par défaut

    Bonsoir,


    Je suis aussi débutant sur Linux, et je cherche à utiliser Nagios pour un projet de fin d'année.
    Je n'arrive pas accéder aux différents onglets sur l'interface web. Exemple si je clique sur Host ou services, il me propose de télécharger le fichier status.cgi .

    Comment puis-je régler ce problème ?

    Quelqu'un pour m'aider svp!!!

  20. #80
    Responsable Perl et Outils

    Avatar de djibril
    Homme Profil pro
    Inscrit en
    avril 2004
    Messages
    19 094
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2004
    Messages : 19 094
    Points : 496 043
    Points
    496 043

    Par défaut

    Bonjour,

    Vous avez surement un souci de configuration apache.

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo