IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Navigation

Inscrivez-vous gratuitement
pour pouvoir participer, suivre les réponses en temps réel, voter pour les messages, poser vos propres questions et recevoir la newsletter

GTK+ Discussion :

Compiler Val (a) ide


Sujet :

GTK+

  1. #1
    Membre actif Avatar de Gamall
    Profil pro
    Étudiant ENSEA
    Inscrit en
    août 2009
    Messages
    252
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant ENSEA

    Informations forums :
    Inscription : août 2009
    Messages : 252
    Points : 221
    Points
    221
    Par défaut Compiler Val (a) ide
    Salut

    Je me demandais si quelqu'un avais déja réussi à compiler Val(a)IDE, vu que à chaque fois que j'ai voulu le compiler, ben j'ai jamais réussi, malgré plein de bonne volonté

    Là, j'ai récuperé le PKGBUILD pour Archlinux, mais waf configure me dit qu'il requiert vala >= 1.0, j'ai patché le wscript en changeant le 1.0 en 0.10 en me disant qu c'est une faute de frappe, mais maintenant, lors de la compilation, j'ai cette erreur:
    [artificier@joker valide-0.7.0]$ ./waf
    Waf: Entering directory `/home/artificier/Programmation/valaide/src/valide-0.7.0/_build_'
    Traceback (most recent call last):
    File "/home/artificier/Programmation/valaide/src/valide-0.7.0/.waf3-1.5.10-470a6353112b965a8e14982b8c571494/wafadmin/Utils.py", line 456, in recurse
    raise WscriptError(traceback.format_exc(),base)
    Utils.WscriptError: /home/artificier/Programmation/valaide/src/valide-0.7.0/libvalide/wscript: error: Traceback (most recent call last):
    File "/home/artificier/Programmation/valaide/src/valide-0.7.0/.waf3-1.5.10-470a6353112b965a8e14982b8c571494/wafadmin/Utils.py", line 456, in recurse
    raise WscriptError(traceback.format_exc(),base)
    Utils.WscriptError: /home/artificier/Programmation/valaide/src/valide-0.7.0/libvalide/ui/wscript: error: Traceback (most recent call last):
    File "/home/artificier/Programmation/valaide/src/valide-0.7.0/.waf3-1.5.10-470a6353112b965a8e14982b8c571494/wafadmin/Utils.py", line 425, in recurse
    txt=readf(base+'_'+name,m='rU')
    File "/home/artificier/Programmation/valaide/src/valide-0.7.0/.waf3-1.5.10-470a6353112b965a8e14982b8c571494/wafadmin/Utils.py", line 389, in readf
    f=open(fname,m)
    IOError: [Errno 2] No such file or directory: '/home/artificier/Programmation/valaide/src/valide-0.7.0/wscript_build'

    During handling of the above exception, another exception occurred:

    Traceback (most recent call last):
    File "/home/artificier/Programmation/valaide/src/valide-0.7.0/.waf3-1.5.10-470a6353112b965a8e14982b8c571494/wafadmin/Utils.py", line 453, in recurse
    exec(txt,dc)
    File "<string>", line 34
    print 'Wrote ' + output
    ^
    SyntaxError: invalid syntax


    During handling of the above exception, another exception occurred:

    Traceback (most recent call last):
    File "/home/artificier/Programmation/valaide/src/valide-0.7.0/.waf3-1.5.10-470a6353112b965a8e14982b8c571494/wafadmin/Utils.py", line 453, in recurse
    exec(txt,dc)
    File "<string>", line 6, in <module>
    File "/home/artificier/Programmation/valaide/src/valide-0.7.0/.waf3-1.5.10-470a6353112b965a8e14982b8c571494/wafadmin/Build.py", line 599, in add_subdirs
    self.recurse(dirs,'build')
    File "/home/artificier/Programmation/valaide/src/valide-0.7.0/.waf3-1.5.10-470a6353112b965a8e14982b8c571494/wafadmin/Utils.py", line 458, in recurse
    raise e
    File "/home/artificier/Programmation/valaide/src/valide-0.7.0/.waf3-1.5.10-470a6353112b965a8e14982b8c571494/wafadmin/Utils.py", line 453, in recurse
    exec(txt,dc)
    File "<string>", line 34
    print 'Wrote ' + output
    ^
    SyntaxError: invalid syntax


    During handling of the above exception, another exception occurred:

    Traceback (most recent call last):
    File "./waf", line 153, in <module>

    [artificier@joker valide-0.7.0]$
    Donc, ben si quelqu'un a une idée, chuis prenneur
    Merci

  2. #2
    Rédacteur

    Avatar de gege2061
    Femme Profil pro
    Administrateur de base de données
    Inscrit en
    juin 2004
    Messages
    5 840
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Âge : 38
    Localisation : France

    Informations professionnelles :
    Activité : Administrateur de base de données

    Informations forums :
    Inscription : juin 2004
    Messages : 5 840
    Points : 11 616
    Points
    11 616
    Par défaut
    Salut,

    J'ai pas forcement le bon moment pour tester

    Citation Envoyé par artificier59 Voir le message
    Là, j'ai récuperé le PKGBUILD pour Archlinux,
    Quel PKGBUILD ? Celui sur AUR n'est plus à jour, ça ne devrait pas changer grand chose mais celui-ci l'est.

    Citation Envoyé par artificier59 Voir le message
    mais waf configure me dit qu'il requiert vala >= 1.0, j'ai patché le wscript en changeant le 1.0 en 0.10 en me disant qu c'est une faute de frappe, mais maintenant, lors de la compilation, j'ai cette erreur:
    ça m'étonne, il doit s'agir de vala-1.0 mais la version doit être 0.8.1

    Citation Envoyé par artificier59 Voir le message
    Donc, ben si quelqu'un a une idée, chuis prenneur
    Là c'est python qui pose problème, il semble ne pas trouver le fichier /home/artificier/Programmation/valaide/src/valide-0.7.0/wscript_build

  3. #3
    Membre actif Avatar de Gamall
    Profil pro
    Étudiant ENSEA
    Inscrit en
    août 2009
    Messages
    252
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Étudiant ENSEA

    Informations forums :
    Inscription : août 2009
    Messages : 252
    Points : 221
    Points
    221
    Par défaut
    Ah, oui, je comprends pas pourquoi je n'ai pas ce fichier. J'ai essayé avec la version que tu m'as donné, mais c'est toujours le même problème

    Si ça avait été les autotools, j'aurais pu me débrouiller, mais je dois avouer que je ne comprends pas grand chose au nouveau système, et je ne connais pas python donc c'est mal barré

  4. #4
    Rédacteur

    Avatar de gege2061
    Femme Profil pro
    Administrateur de base de données
    Inscrit en
    juin 2004
    Messages
    5 840
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Âge : 38
    Localisation : France

    Informations professionnelles :
    Activité : Administrateur de base de données

    Informations forums :
    Inscription : juin 2004
    Messages : 5 840
    Points : 11 616
    Points
    11 616
    Par défaut
    Citation Envoyé par artificier59 Voir le message
    Si ça avait été les autotools, j'aurais pu me débrouiller, mais je dois avouer que je ne comprends pas grand chose au nouveau système, et je ne connais pas python donc c'est mal barré
    Je trouve ça pourtant bien plus simple que les autotools

    Actuellement j'ai une connexion internet exécrable, donc difficile de télécharger l'ISO d'achlinux pour d'installer une machine virtuelle, mais je t'invite à créer un ticket sur launchpad (en français si tu préfère) avec le plus d'informations possible (version de vala, version de python au moins) pour que je n'oublie pas

  5. #5
    Rédacteur

    Avatar de gege2061
    Femme Profil pro
    Administrateur de base de données
    Inscrit en
    juin 2004
    Messages
    5 840
    Détails du profil
    Informations personnelles :
    Sexe : Femme
    Âge : 38
    Localisation : France

    Informations professionnelles :
    Activité : Administrateur de base de données

    Informations forums :
    Inscription : juin 2004
    Messages : 5 840
    Points : 11 616
    Points
    11 616
    Par défaut
    Bonjour,

    J'ai trouvé, par défaut archlinux utilise python 3 hors la version de waf ne semble pas compatible. Il suffit d'exécuter :
    Et ça marche

Discussions similaires

  1. Sortie de Val(a)IDE 0.6.1
    Par gege2061 dans le forum GTK+
    Réponses: 4
    Dernier message: 07/09/2016, 21h39
  2. [Lazarus] Compilation de l'IDE
    Par Pierre GIRARD dans le forum Lazarus
    Réponses: 3
    Dernier message: 27/11/2014, 18h01
  3. [Val(a)IDE] Problème d'installation
    Par mostaamil dans le forum Autres EDI
    Réponses: 1
    Dernier message: 23/06/2012, 14h56
  4. Sortie de Val(a)IDE 0.4
    Par gege2061 dans le forum Contribuez
    Réponses: 1
    Dernier message: 02/04/2009, 16h35
  5. Réponses: 6
    Dernier message: 24/03/2005, 15h29

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo