IdentifiantMot de passe
Loading...
Mot de passe oublié ?Je m'inscris ! (gratuit)
Voir le flux RSS

Philippe Tulliez

Excel - Comment remplacer les valeurs booléenne VRAI et FAUX par le texte Oui et Non

Noter ce billet
par , 28/11/2020 à 15h43 (126 Affichages)
Préambule
On voit régulièrement sur les forum des questions portant sur des colonnes contenant les texte "Oui" et "Non" pour notamment effectuer des formules avec conditions
On a beau dire qu'il est plus simple de traiter directement avec des valeurs booléenne (VRAI et FAUX), il semblerait que cela ne plaise pas.

Est-ce pour une raison d'esthétique ?

Qu'à cela ne tienne, voici une solution

Ci-dessous, une table structurée contenant dans la colonne dont l'étiquette est Traité, des valeurs booléenne VRAI et FAUX et dont le texte affiché est Oui, Non ou rien

Nom : Replace True False by Oui - Non.png
Affichages : 30
Taille : 16,6 Ko

Si cette colonne avait comme valeur des Oui et des Non, la formule en colonne C serait
Code : Sélectionner tout - Visualiser dans une fenêtre à part
=SI([@Traité]="Oui";100;0)
alors qu'avec des VRAI et FAUX, il suffit d'effectuer une simple multiplication
Astuce pour obtenir l'affichage des Oui et Non
Le format personnalisé permet d'effectuer des affichage très intéressants et notamment si la valeur de la cellule est négative, positive ou nulle or curieusement les VRAI et FAUX sont considérés là comme du texte.
L'astuce consiste alors à combiner la mise en forme conditionnelle et le format personnalisé

Les étapes pour obtenir Oui au lieu de VRAI
  • Sélection de la colonne Traité (uniquement les valeurs)
  • Activer la mise en forme conditionnelle
  • Choisir la règle Utiliser une formule pour déterminer pour quelles cellules le format sera appliqué
  • Entrer =B2*1
  • Cliquer sur le bouton Format...
  • Sélectionner l'onglet [Nombre] dans la boîte de dialogue Format de cellule
  • Choisir Personnalisé et taper dans la zone de texte Type : ;;;"Oui"
  • Cliquer sur OK

Recommencer l'opération pour obtenir Non au lieu de FAUX avec la même règle, avec comme formule sera =(B2*1)=0

Pour en savoir plus

Envoyer le billet « Excel - Comment remplacer les valeurs booléenne VRAI et FAUX par le texte Oui et Non » dans le blog Viadeo Envoyer le billet « Excel - Comment remplacer les valeurs booléenne VRAI et FAUX par le texte Oui et Non » dans le blog Twitter Envoyer le billet « Excel - Comment remplacer les valeurs booléenne VRAI et FAUX par le texte Oui et Non » dans le blog Google Envoyer le billet « Excel - Comment remplacer les valeurs booléenne VRAI et FAUX par le texte Oui et Non » dans le blog Facebook Envoyer le billet « Excel - Comment remplacer les valeurs booléenne VRAI et FAUX par le texte Oui et Non » dans le blog Digg Envoyer le billet « Excel - Comment remplacer les valeurs booléenne VRAI et FAUX par le texte Oui et Non » dans le blog Delicious Envoyer le billet « Excel - Comment remplacer les valeurs booléenne VRAI et FAUX par le texte Oui et Non » dans le blog MySpace Envoyer le billet « Excel - Comment remplacer les valeurs booléenne VRAI et FAUX par le texte Oui et Non » dans le blog Yahoo

Mis à jour 28/11/2020 à 19h33 par Philippe Tulliez

Catégories
Sans catégorie

Commentaires