Voir le flux RSS

Philippe Tulliez

Excel : Comment remplacer la fonction SI par une opération logique ?

Noter ce billet
par , 22/01/2020 à 15h58 (356 Affichages)
Introduction
Entrez VRAI en cellule A2 et multipliez le contenu de cette cellule par 100.
Vous obtiendrez 100 alors que si vous entrez FAUX, le résultat renvoyé sera 0

Que pouvons-nous en conclure ? Que VRAI vaut 1 et FAUX vaut 0

Sachant cela, voyons des exemples concrets avec la liste de données illustrée ci-dessous

Nom : Remplacer SI.png
Affichages : 504
Taille : 15,7 Ko

L’équivalent d’un SI
Imagions une ville qui accorderait une prime de 50 € à toutes personnes ayant des enfants.
Sans savoir qu’une valeur logique se multiplie, nous utiliserions bien entendu instinctivement la fonction SI en tapant en cellule E2 et suivantes la formule =SI(C2>0 ;50 ;0) ou si les données sont converties en tableau structuré =SI([@Enfant]>0 ; 50 ; 0)

Au lieu de cela, nous écrirons =(C2>0) * 50 ou ([@Enfant]>0) * 50

L’équivalent d’un SI avec un ET imbriqué
Pour effectuer l’équivalent d’un ET, il y a lieu de multiplier tous les tests logiques

Une prime de 50 € est accordée à toutes personnes de sexe féminin, ayant des enfants et habitant la commune de Moulinsart

La formule avec une plage classique
Code : Sélectionner tout - Visualiser dans une fenêtre à part
=(B2="F") * (C2>0) * (D2="Moulinsart") * 50
La formule avec un tableau structuré
Code : Sélectionner tout - Visualiser dans une fenêtre à part
=([@Sexe]="F") * ([@Enfant]>0) * ([@Habitant]="Moulinsart") * 50
L’équivalent d’un SI avec un OU imbriqué par addition
Pour effectuer l’équivalent d’un OU, il y a lieu d’additionner tous les tests logiques et de tester le résultat de cette addition par l’opérateur de comparaison > soit >0

La prime est accordée à toutes personnes habitant Moulinsart OU ayant des enfants

La formule avec une plage classique
Code : Sélectionner tout - Visualiser dans une fenêtre à part
=( ( (C2>0) + (D2="Moulinsart") ) >0 ) * 50
La formule avec un tableau structuré
Code : Sélectionner tout - Visualiser dans une fenêtre à part
=((([@Enfant]>0) + ([@Habitant]="Moulinsart"))>0) * 50

Envoyer le billet « Excel : Comment remplacer la fonction SI par une opération logique ? » dans le blog Viadeo Envoyer le billet « Excel : Comment remplacer la fonction SI par une opération logique ? » dans le blog Twitter Envoyer le billet « Excel : Comment remplacer la fonction SI par une opération logique ? » dans le blog Google Envoyer le billet « Excel : Comment remplacer la fonction SI par une opération logique ? » dans le blog Facebook Envoyer le billet « Excel : Comment remplacer la fonction SI par une opération logique ? » dans le blog Digg Envoyer le billet « Excel : Comment remplacer la fonction SI par une opération logique ? » dans le blog Delicious Envoyer le billet « Excel : Comment remplacer la fonction SI par une opération logique ? » dans le blog MySpace Envoyer le billet « Excel : Comment remplacer la fonction SI par une opération logique ? » dans le blog Yahoo

Mis à jour 23/01/2020 à 07h56 par Philippe Tulliez

Catégories
Sans catégorie

Commentaires

  1. Avatar de mfoxy
    • |
    • permalink
    Bonjour Philippe,

    Merci pour tous vos billets très instructif et que je lis toujours avec grand intérêt.

    Je pense qu une faute de frappe s'est glissée dans le point "L’équivalent d’un Si" vous parle du nombre d enfant mais faites référence à la cellule B2 qui est celle du sexe.

    Au plaisir de vous lire,et de voir paraître vos prochains billets au sujet des tableaux structurés

    Michaël
  2. Avatar de Philippe Tulliez
    • |
    • permalink
    Bonjour Michaël,
    Merci pour votre commentaire qui fait toujours plaisir.
    Effectivement vous avez raison, une coquille s'est glissée dans la première partie de ce billet. Je viens de la corriger
    Merci de me l'avoir signalé
    Philippe

    Citation Envoyé par mfoxy
    Bonjour Philippe,

    Merci pour tous vos billets très instructif et que je lis toujours avec grand intérêt.

    Je pense qu une faute de frappe s'est glissée dans le point "L’équivalent d’un Si" vous parle du nombre d enfant mais faites référence à la cellule B2 qui est celle du sexe.

    Au plaisir de vous lire,et de voir paraître vos prochains billets au sujet des tableaux structurés

    Michaël
  3. Avatar de Qwazerty
    • |
    • permalink
    Salut

    Merci pour ce billet. Je n'avais jamais pensé (ou du moins pas le souvenir) à le faire pour un formule Si() "classique", j'entends par classique non matricielle. Je suis loin d'être un spécialiste des formules matricielles mais j'avais trouvé pratique cet aspect de remplacer le Si() par une formule mathèmatique... pourquoi ne pas y avoir penser pour le non matricielle.... mystère

    Je te souhaite une bonne journée
    Qwaz
  4. Avatar de Philippe Tulliez
    • |
    • permalink
    Bonjour Qwaz,
    Merci pour ton message
    J'utilise toujours ces exemples lorsque je dois expliquer la manière dont fonctionne SOMMEPROD lorsque l'on place des critères.
    Belle journée à toi également
    Philippe

    Citation Envoyé par Qwazerty
    Salut

    Merci pour ce billet. Je n'avais jamais pensé (ou du moins pas le souvenir) à le faire pour un formule Si() "classique", j'entends par classique non matricielle. Je suis loin d'être un spécialiste des formules matricielles mais j'avais trouvé pratique cet aspect de remplacer le Si() par une formule mathèmatique... pourquoi ne pas y avoir penser pour le non matricielle.... mystère

    Je te souhaite une bonne journée
    Qwaz