Voir le flux RSS

patricktoulon

retrouver la fonction evaluer (macro xl4)sur excel 2007( sans vba )

Noter ce billet
par , 28/08/2019 à 09h42 (230 Affichages)
[CENTER][COLOR=#696969][B][SIZE=3]la fonction EVALUER de excel 4 dans 2007 et + ( sans VBA)[/SIZE]
[/B][/COLOR][/CENTER]

Bonjour a tous
je viens de découvrir une petite astuce intéressante a savoir utiliser les macroxl4 sans vba et notamment la fonction[B] EVALUER() [/B]sans vba
pratique quand les données sont en string dans une même cellule

exemple vous avez un texte " [B]15+17+50+75 "[/B]dans une cellule, la [B]B1 [/B]par exemple


il faut ajouter un Name dans le gestionnaire de noms

on l'appelera "EVAL"
et la référence par exemple sera [B]"EVALUER(Feuil1!B1)" [/B]
e
nsuite en [B]C1 par exemple [/B]on y mettra [COLOR=#b22222][B]=SIERREUR(B1+1<0;EVAL;"")
[/B][/COLOR]
voila le principe c'est de déclencher une erreur pour que eval evalue la chaine de B1

vous constaterez qu'a chaque fois que vous sélectionnez une cellule la référence changera elle est donc réutilisable

voila une sorte de fonction evaluate sans VBA
démonstration
[ATTACH=CONFIG]499922[/ATTACH]
Miniatures attachées Images attachées  

Envoyer le billet « retrouver la fonction evaluer (macro xl4)sur excel 2007( sans vba ) » dans le blog Viadeo Envoyer le billet « retrouver la fonction evaluer (macro xl4)sur excel 2007( sans vba ) » dans le blog Twitter Envoyer le billet « retrouver la fonction evaluer (macro xl4)sur excel 2007( sans vba ) » dans le blog Google Envoyer le billet « retrouver la fonction evaluer (macro xl4)sur excel 2007( sans vba ) » dans le blog Facebook Envoyer le billet « retrouver la fonction evaluer (macro xl4)sur excel 2007( sans vba ) » dans le blog Digg Envoyer le billet « retrouver la fonction evaluer (macro xl4)sur excel 2007( sans vba ) » dans le blog Delicious Envoyer le billet « retrouver la fonction evaluer (macro xl4)sur excel 2007( sans vba ) » dans le blog MySpace Envoyer le billet « retrouver la fonction evaluer (macro xl4)sur excel 2007( sans vba ) » dans le blog Yahoo

Mis à jour 28/08/2019 à 12h10 par patricktoulon

Catégories
Sans catégorie

Commentaires