1. #1
    Membre habitué
    Profil pro
    Inscrit en
    mars 2005
    Messages
    195
    Détails du profil
    Informations personnelles :
    Âge : 42
    Localisation : France

    Informations forums :
    Inscription : mars 2005
    Messages : 195
    Points : 145
    Points
    145

    Par défaut Problème du 31/12/1899

    Bonjour,

    J'ai soucis avec une application C et des champs date récemments ajoutés en base.
    Lorsque je les récupère dans une structure ils sont sous la forme "31/12/1899".
    Et bien sûr ils se retrouvent ensuite dans la base de données...
    Les champs "historique" eux restent null, pas un peu curieux?

    Michel

  2. #2
    Membre du Club
    Inscrit en
    juillet 2010
    Messages
    33
    Détails du profil
    Informations forums :
    Inscription : juillet 2010
    Messages : 33
    Points : 43
    Points
    43

    Par défaut

    Un début d'explication:

    http://stackoverflow.com/questions/1...te-in-informix

    Je pencherais pour un bogue dans le code C...

  3. #3
    Membre du Club
    Inscrit en
    juillet 2010
    Messages
    33
    Détails du profil
    Informations forums :
    Inscription : juillet 2010
    Messages : 33
    Points : 43
    Points
    43

    Par défaut

    Il faudrait essayer avec une autre version de SDK, plus récente... si cela provient d'un bogue du SDK.

  4. #4
    Membre actif
    Homme Profil pro
    Achitecte Informix SGBD et applications - IBM Champion - Data Management - Board of Directors IIUG
    Inscrit en
    octobre 2010
    Messages
    103
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 55
    Localisation : France, Finistère (Bretagne)

    Informations professionnelles :
    Activité : Achitecte Informix SGBD et applications - IBM Champion - Data Management - Board of Directors IIUG
    Secteur : Conseil

    Informations forums :
    Inscription : octobre 2010
    Messages : 103
    Points : 158
    Points
    158

    Par défaut

    Bonjour,

    c'est une erreur classique résultant en général du manque d'initialisation d'une variable de type DATE.
    31/12/1899 apparait quand la colonne de type date prend la valeur zéro. ( confère l'explication de Jonathan )
    Veille bien à affecter la valeur NULL et non pas zéro lorsque tu fais un insert, ou update.

    A surveiller en premier abord dans le code de l'application. Mais dans ton cas on dirait que c'est à la création de nouvelles colonnes que le problème intervient et apparamment le code n'est pas à incriminer, ni encore moins le CSDK. A vérifier le process de création de la nouvelle colonne. Tu peux toujours mettre une "default constraint" à NULL pour cette cette colonne et ainsi tu auras le résultat désiré.
    Eric

    Eric

Discussions similaires

  1. Problème d'installation oracle 8.1.7 sous NT
    Par Anonymous dans le forum Installation
    Réponses: 7
    Dernier message: 02/08/2002, 14h18
  2. Problème d'impression
    Par IngBen dans le forum C++Builder
    Réponses: 7
    Dernier message: 22/05/2002, 11h37
  3. Problème avec la mémoire virtuelle
    Par Anonymous dans le forum CORBA
    Réponses: 13
    Dernier message: 16/04/2002, 16h10
  4. Réponses: 6
    Dernier message: 25/03/2002, 21h11

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo