Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3
  1. #1
    Membre émérite
    Avatar de airod
    Homme Profil pro Benoit Martiré
    Synapse médical, Sèvres (92)
    Inscrit en
    août 2004
    Messages
    742
    Détails du profil
    Informations personnelles :
    Nom : Homme Benoit Martiré
    Âge : 39
    Localisation : France

    Informations professionnelles :
    Activité : Synapse médical, Sèvres (92)
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2004
    Messages : 742
    Points : 815
    Points
    815

    Par défaut erreur de rendu dans certains navigateurs

    voici l'erreur

    *
    Site Error

    An error was encountered while publishing this resource.

    Error Type: UnicodeDecodeError
    Error Value: 'ascii' codec can't decode byte 0xe9 in position 9: ordinal not in range(128)

    Je comprend bien l'erreur mais je ne comprend pas pourquoi dans Firefox, l'affichage se fait bien, que dans Opera l'affichage est remplacé par des ??????? et que j'ai ce msg d'erreur dans les autres navigateur!

    ce qui doit être affiché c'est une simple chaine de carractères (avec des accents) issu d'un traitement d'un script python.
    mon zope de dev est sous windows, j'utilise une BDD MySQL 5.1

    auriez vous une idée svp
    Pensez à la documentation en ligne, ca aide!

  2. #2
    Modérateur
    Avatar de pacificator
    Inscrit en
    août 2006
    Messages
    1 074
    Détails du profil
    Informations personnelles :
    Âge : 35

    Informations forums :
    Inscription : août 2006
    Messages : 1 074
    Points : 1 682
    Points
    1 682

    Par défaut

    Salut,

    Essaye de préciser au début de ta page les infos d'encodage, par exemple:
    Code html :
    1
    2
    <?xml version="1.0" encoding="ISO-8859-15"?> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr">
    "Etre conscient de la difficulté permet de l'éviter.."
    Lao-Tseu.

  3. #3
    Membre émérite
    Avatar de airod
    Homme Profil pro Benoit Martiré
    Synapse médical, Sèvres (92)
    Inscrit en
    août 2004
    Messages
    742
    Détails du profil
    Informations personnelles :
    Nom : Homme Benoit Martiré
    Âge : 39
    Localisation : France

    Informations professionnelles :
    Activité : Synapse médical, Sèvres (92)
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : août 2004
    Messages : 742
    Points : 815
    Points
    815

    Par défaut

    je relance ce post, car j'ai un tout petit peu avancé!!!
    vraiment un tout petit peu.
    Si quelqu'un peu m'aider.

    Voilà, pour eviter le problème, il faut que je mette du decode('latin-1'), a toutes les chaines récupéré d'aprés une script python ou ZSQLMethod.
    J'ai donc ajouter ca dans les pages au niveau du head.
    Code :
    1
    2
     
    <span tal:omit-tag="" tal:define="dummy python:request.RESPONSE.setHeader('Content-Type','text/html;; charset=utf-8')"></span>
    Sachant que ma base de données est en utf-8.
    Mais comment être sur que mes python script et mes ZSQLMethod me renvoie bien aussi de l'UTF-8.

    mon but est bien d'être sûr que tout soit en UTF-8
    Pensez à la documentation en ligne, ca aide!

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •