1. #1
    Invité régulier
    Inscrit en
    février 2010
    Messages
    18
    Détails du profil
    Informations forums :
    Inscription : février 2010
    Messages : 18
    Points : 5
    Points
    5

    Par défaut test Upload photo en local easyphp

    Bonjour bonjour tout le monde,

    Je viens à vous pour eclairer ma lanterne...

    voila mon probleme, je dois, pour un site internet constituer des galleries de photos, et je reste coincé à un endroit.

    Après la selection du fichier à uploader via le formulaire, j'arrive sur ma page de traitement, je recupere donc le fichier et tout le tralala mais quand je fais appele à la fonction copy de php, j'ai droit a ce message d'erreur "Warning: copy() [function.copy]: Filename cannot be empty". J'ai fait afficher toutes mes variables avec un echo et celle qui est vide c'est celle qui correspond à l'emplacement temporaire de la photo uploader...

    ll faut savoir que mon code fonctionne une fois le site mit en ligne, je cherche donc simplement le moyen de faire des test d'upload en local.

    Je suppose que la solution est dans le php.ini mais j'ignore ou et comment...

    D'avance merci pour votre aide

    Cordialement Foucherfou

  2. #2
    Modérateur
    Avatar de sabotage
    Homme Profil pro
    Inscrit en
    juillet 2005
    Messages
    23 639
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juillet 2005
    Messages : 23 639
    Points : 34 798
    Points
    34 798

    Par défaut

    Même si ça ne resoudra pas ton problème, il faut utiliser move_uploaded_file() et non copy().

    Pour ton problème, fait un
    pour controler ce que tu recois.

  3. #3
    Invité régulier
    Inscrit en
    février 2010
    Messages
    18
    Détails du profil
    Informations forums :
    Inscription : février 2010
    Messages : 18
    Points : 5
    Points
    5

    Par défaut

    voila le resultat du print

    Array ( [nom] => Array ( [name] => vergus01.jpg [type] => [tmp_name] => [error] => 2 [size] => 0 ) )

  4. #4
    Modérateur
    Avatar de sabotage
    Homme Profil pro
    Inscrit en
    juillet 2005
    Messages
    23 639
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations forums :
    Inscription : juillet 2005
    Messages : 23 639
    Points : 34 798
    Points
    34 798

    Par défaut

    Les codes d'erreur sont dans la doc :
    http://www.php.net/manual/fr/feature...oad.errors.php

  5. #5
    Invité régulier
    Inscrit en
    février 2010
    Messages
    18
    Détails du profil
    Informations forums :
    Inscription : février 2010
    Messages : 18
    Points : 5
    Points
    5

    Par défaut

    Effectivement, merci j'avais trouvé entre temps.

    Le print m'a permis de trouver mon erreur...

    Merci bcp, a bientot

+ Répondre à la discussion
Cette discussion est résolue.

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo