+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3
  1. #1
    Invité de passage
    Inscrit en
    janvier 2008
    Messages
    4
    Détails du profil
    Informations forums :
    Inscription : janvier 2008
    Messages : 4
    Points : 3
    Points
    3

    Par défaut Perte de session avec 2 applications

    Bonjour,

    J'ai un problème avec les sessions WebSphere.

    J'ai 2 applications installées sur 2 profils WebSphere différents, mais sur le même serveur (donc uniquement avec 2 numéros de ports différents). Chaque application gère ses sessions, je ne cherche pas à faire de partage de session.

    L'application N°1 fait appel à l'application N°2 via un simple lien hypertexte. Mon problème est qu'après cet appel, la session de l'application N°1 est perdue.

    Je ne comprend pas pourquoi la session est perdue, j'aimerais savoir si vous avez déjà eu un problème similaire et comment le résoudre?

    Merci d'avance

  2. #2
    Invité de passage
    Inscrit en
    juin 2010
    Messages
    2
    Détails du profil
    Informations forums :
    Inscription : juin 2010
    Messages : 2
    Points : 3
    Points
    3

    Par défaut

    Bonjour

    Le sujet date un peu mais j'ai exactement le même problème à la différence que ma deuxième application s'ouvre dans une iFrame.

    Merci de votre aide pour comprendre ce problème.

    Cordialement

  3. #3
    Invité de passage
    Inscrit en
    juin 2010
    Messages
    2
    Détails du profil
    Informations forums :
    Inscription : juin 2010
    Messages : 2
    Points : 3
    Points
    3

    Par défaut

    Le problème venait du fait que les deux applications avait le même nom de cookie: JSESSIONID. J'ai fait en sorte qu'ils soientt différents pour les deux applications et le problème est réglé.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •