Publicité
+ Répondre à la discussion Actualité déjà publiée
Page 6 sur 7 PremièrePremière ... 234567 DernièreDernière
Affichage des résultats 101 à 120 sur 125
  1. #101
    Invité de passage
    Inscrit en
    septembre 2012
    Messages
    1
    Détails du profil
    Informations forums :
    Inscription : septembre 2012
    Messages : 1
    Points : 1
    Points
    1

    Par défaut

    Bonjour, j'ai récemment découvert votre outil, il marche vraiment bien, étant débutant j'aimerai savoir une petite chose, comment faites vous pour faire un bouton pointant vers un lien web ?
    Je m'explique, je voudrai créer un bouton du style "Comment faire" et lors du clic celui-ci ouvrirait IE (ou nav' par défaut peu importe) en pointant sur la page spécifier dans le code.
    D'après mes recherches il faut utiliser le callback onAction mais je comprends pas vraiment sa configuration ...

    Merci d'avance

    B4st0s

  2. #102
    Membre régulier
    Profil pro Emmanuel
    Inscrit en
    novembre 2010
    Messages
    110
    Détails du profil
    Informations personnelles :
    Nom : Emmanuel

    Informations forums :
    Inscription : novembre 2010
    Messages : 110
    Points : 98
    Points
    98

    Par défaut Problème pour sauvegarder mon ruban

    Bonsoir Arkham.

    J'ai créer un ruban pour una appli sous Access 2007 il y a plus d'un an. Merci de nous avoir "mâché" le travail, ton assistant ruban est vraiment excellent !!!
    Je suis passé en version Access 2010 depuis 3 jours et ça bug de partout. Y compris mon ruban que je voudrais améliorer mais, la modification faite, je n'arrive pas à sauvegarder le ruban. Un message d'erreur s'affiche : "Erreur de sauvegarde. Vérifiez que le fichier n'est pas ouvert par une autre application".

    Je ne trouve pas le problème.
    As-tu une idée ?
    Merci de ton aide.

  3. #103
    Membre régulier
    Profil pro Emmanuel
    Inscrit en
    novembre 2010
    Messages
    110
    Détails du profil
    Informations personnelles :
    Nom : Emmanuel

    Informations forums :
    Inscription : novembre 2010
    Messages : 110
    Points : 98
    Points
    98

    Par défaut

    Bonsoir,

    Juste pour dire que mon problème de sauvegarde (cité ci-dessus) de mon ruban est bien lié aux backups.
    J'ai vu ici :http://www.developpez.net/forums/d74...n-2007-2010-a/
    la solution.

    Encore merci et bravo pour ce travail superbe.

    Cordialement.

  4. #104
    Invité régulier
    Homme Profil pro Joao DA ROCHA
    Inscrit en
    octobre 2005
    Messages
    40
    Détails du profil
    Informations personnelles :
    Nom : Homme Joao DA ROCHA
    Localisation : France, Rhône (Rhône Alpes)

    Informations forums :
    Inscription : octobre 2005
    Messages : 40
    Points : 9
    Points
    9

    Par défaut Merci

    Super outil ... cela simplifie énormément la tâche de création des rubans et menus contextuels ... encore bravo

    Cela dit, j'ai identifier un bug :
    J'ouvre ma base Access sur un réseau, depuis un lecteur réseau. Au moment de lister les modules de ma base (OnAction des boutons), il ne liste aucun module (malgré leur existence) et je sais pourquoi :
    -> "VBE.VBProjects(lProject).FileName" contient l'adresse complète réseau ("\\xxx\xxx\toto.accdb")
    -> "CurrentProject.FullName" contient l'adresse du lecteur réseau ("R:\toto.accdb")

    Je n'arrive donc pas à faire le lien (en attendant, je lance ma base depuis l'adresse complète réseau)

    TALERE

  5. #105
    Responsable Access
    Avatar de Arkham46
    Profil pro
    Inscrit en
    septembre 2003
    Messages
    4 765
    Détails du profil
    Informations personnelles :
    Localisation : France, Loiret (Centre)

    Informations forums :
    Inscription : septembre 2003
    Messages : 4 765
    Points : 9 160
    Points
    9 160

    Par défaut

    Bonjour,

    Cela faisait longtemps, une nouvelle mise à jour :
    Version 2.0.6
    - Ajout précision sur message d'erreur id (lettres non accentuées)
    - Liste de choix callback déjà utilisés
    - Correction erreur 91 à l'ouverture sur certaines configurations
    @talere : désolé je n'ai pas eu le temps de regarder le problème de modules sur les chemins réseaux

  6. #106
    Membre confirmé
    Inscrit en
    juin 2007
    Messages
    927
    Détails du profil
    Informations forums :
    Inscription : juin 2007
    Messages : 927
    Points : 216
    Points
    216

    Par défaut

    Citation Envoyé par Arkham46 Voir le message
    Bonjour,

    Cela faisait longtemps, une nouvelle mise à jour :


    @talere : désolé je n'ai pas eu le temps de regarder le problème de modules sur les chemins réseaux
    Bonsoir

    Liste de choix callback déjà utilisés
    Cela veut dire qu'on ne peut plus utiliser 2 fois le même callback ?

  7. #107
    Responsable Access
    Avatar de Arkham46
    Profil pro
    Inscrit en
    septembre 2003
    Messages
    4 765
    Détails du profil
    Informations personnelles :
    Localisation : France, Loiret (Centre)

    Informations forums :
    Inscription : septembre 2003
    Messages : 4 765
    Points : 9 160
    Points
    9 160

    Par défaut

    Citation Envoyé par Daejung Voir le message
    Cela veut dire qu'on ne peut plus utiliser 2 fois le même callback ?
    Non c'est juste une aide à la saisie.
    Cela veut dire que si on a défini par exemple un callback onAction="Ribbon_onAction" pour un bouton, alors pour les autres boutons on trouvera "Ribbon_onAction" dans une liste de choix pour éviter de se rappeler du nom du callback qu'on a déjà utilisé (vu que souvent on réutilise la même procédure).

  8. #108
    Membre confirmé
    Inscrit en
    juin 2007
    Messages
    927
    Détails du profil
    Informations forums :
    Inscription : juin 2007
    Messages : 927
    Points : 216
    Points
    216

    Par défaut

    Merci

    J'utilise cet assistant avec Access 2010 et cela marche aussi très bien, mais quand je quitte Access j'ai systématiquement un message d'erreur :

    Runtime Error!

    Program: C:\Program Files\Microsoft Office\Office14\MSACCESS.EXE

    This application has requested the Runtime to terminate it in an
    unusula way.

    Please contact the application's support team for more information.
    et Access plante puis redémarre.

    Je vais voir si ce problème est résolu avec la nouvelle version.

  9. #109
    Membre régulier
    Homme Profil pro Guenaël LE MERRER
    consultant environnement et développement d'applications de base de données
    Inscrit en
    janvier 2006
    Messages
    272
    Détails du profil
    Informations personnelles :
    Nom : Homme Guenaël LE MERRER
    Âge : 40
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : consultant environnement et développement d'applications de base de données
    Secteur : Agroalimentaire - Agriculture

    Informations forums :
    Inscription : janvier 2006
    Messages : 272
    Points : 87
    Points
    87

    Par défaut Menu contextuel

    Bonjour

    J'utilise déjà bcp cet assistant pour créer des rubans dans mes applis et il est vraiment génial. J'ai vu que l'on pouvait aussi créer des menus contextuels avec...
    Pas de souci pour le créer mais comment je l'appelle depuis un formulaire par exemple ?
    J'ai essayé de le charger au démarrage de l'appli comme un ruban puis simplement mettre son nom dans la propriété Barre ed menu contextuel de mon formulaire mais il me dit qu'il ne trouve pas cet objet...
    il faut passer par une macro ?
    Merci

  10. #110
    Responsable Access
    Avatar de Arkham46
    Profil pro
    Inscrit en
    septembre 2003
    Messages
    4 765
    Détails du profil
    Informations personnelles :
    Localisation : France, Loiret (Centre)

    Informations forums :
    Inscription : septembre 2003
    Messages : 4 765
    Points : 9 160
    Points
    9 160

    Par défaut

    Citation Envoyé par guen Voir le message
    J'ai vu que l'on pouvait aussi créer des menus contextuels avec...
    Pas de souci pour le créer mais comment je l'appelle depuis un formulaire par exemple ?
    Bonjour,

    Les menus contextuels sont modifiables à partir de 2010 mais uniquement pour les menus standards : Office 2010 : les nouveautés du Ruban

  11. #111
    Invité de passage
    Homme Profil pro Pierre
    Responsable d'un système d'information métier
    Inscrit en
    novembre 2013
    Messages
    3
    Détails du profil
    Informations personnelles :
    Nom : Homme Pierre
    Localisation : France

    Informations professionnelles :
    Activité : Responsable d'un système d'information métier
    Secteur : Industrie

    Informations forums :
    Inscription : novembre 2013
    Messages : 3
    Points : 3
    Points
    3

    Par défaut Le bouton "Charger un fichier Office" n'est pas accessible

    Bonjour,
    Je suis frustré, car cet outil semble pouvoir m'aider grandement, mais après l'avoir chargé, grosse déception, il m'est impossible de le tester.
    En effet, le Bouton le plus important "Charger un fichier Office" ne m'est pas accessible.[IMG]Bibliothèques\Images\Charger fichier.jpg[/IMG]

    Je ne sais pas ce que j'ai raté dans l'installation, je semble être le seul à qui cela est arrivé (pas trouvé de post sur ce sujet).

    Ma config : Office 2010 Pro sous Seven Ultimate 64 bits.

    Pour l'installation, j'ai tenté les deux solutions évoquées dans le Tuto, à savoir, exécution d'Access en tant qu'administrateur et modification des paramètres de contrôles de comptes utilisateurs (avec reboot).
    Dans les deux cas, le résultat est le même.

    La solution doit être évidente, mais je ne la vois pas.
    Si quelqu'un pouvait m'aider...

    Merci

  12. #112
    Responsable Access
    Avatar de Arkham46
    Profil pro
    Inscrit en
    septembre 2003
    Messages
    4 765
    Détails du profil
    Informations personnelles :
    Localisation : France, Loiret (Centre)

    Informations forums :
    Inscription : septembre 2003
    Messages : 4 765
    Points : 9 160
    Points
    9 160

    Par défaut

    Bonjour,


    Citation Envoyé par Pierre30130 Voir le message
    le Bouton le plus important "Charger un fichier Office" ne m'est pas accessible
    Ce bouton n'est disponible que lorsqu'on exécute directement l'application, pas lors d'une installation en complément Access :
    http://arkham46.developpez.com/artic...nt-ruban/#LIII
    Si vous utilisez l'assistant en tant que complément Access, les rubans de l'application Access courante s'affichent.
    Il n'est pas possible d'ouvrir un autre document dans cette configuration.

  13. #113
    Invité de passage
    Homme Profil pro Pierre
    Responsable d'un système d'information métier
    Inscrit en
    novembre 2013
    Messages
    3
    Détails du profil
    Informations personnelles :
    Nom : Homme Pierre
    Localisation : France

    Informations professionnelles :
    Activité : Responsable d'un système d'information métier
    Secteur : Industrie

    Informations forums :
    Inscription : novembre 2013
    Messages : 3
    Points : 3
    Points
    3

    Par défaut Merci

    Désolé, la réponse était... évidente , mais je ne l'avais pas trouvée.
    Bon je vais pouvoir m'amuser maintenant.


    Encore Merci

  14. #114
    Invité de passage
    Homme Profil pro Pierre
    Responsable d'un système d'information métier
    Inscrit en
    novembre 2013
    Messages
    3
    Détails du profil
    Informations personnelles :
    Nom : Homme Pierre
    Localisation : France

    Informations professionnelles :
    Activité : Responsable d'un système d'information métier
    Secteur : Industrie

    Informations forums :
    Inscription : novembre 2013
    Messages : 3
    Points : 3
    Points
    3

    Par défaut Comment faire pour donner une couleur au Ruban

    Bonjour,
    On peut voir que certains rubans standards ont une couleur dans Excel, c'est le cas par exemple du ruban "Outils de tableau" ou du ruban "Outils de graphique".

    L'assistant création de ruban lui aussi est coloré dans Access.

    J'aimerais faire de même avec le ruban que j'ai créé, j'avoue que ce serait vraiment la cerise sur le gâteau.
    Pouvez vous m'indiquer comment faire ?

    Merci

    PS : Je profite de mon nouveau passage par ici pour dire à quel point je remercie Arkham pour son logiciel. Non seulement il est extrêmement pratique à utiliser et permet de simplifier grandement la création de ruban, mais en plus le logiciel lui même constitue un exemple très complet de mise en oeuvre d'un ruban dans lequel un grand nombre de contrôles différents ont été intégrés. Il est donc aisé de s'en inspirer. Encore merci

  15. #115
    Invité de passage
    Homme Profil pro
    Développeur informatique
    Inscrit en
    novembre 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : novembre 2012
    Messages : 2
    Points : 2
    Points
    2

    Par défaut Plantage office2013 64

    Bonjour, et merci beaucoup pour cet assistant oh combien merveilleux. Je l'utilise avec office 2007 32 au boulot, par contre, j'ai un plantage systématique avec office 2013 64 à la maison. Il semblerait que cela vienne de l'API oleLoadPicture. Déclaration actuelle
    Code :
    1
    2
    3
    Private Declare PtrSafe Function OleLoadPicture Lib "oleaut32" _
                (lpstream As Any, ByVal lSize As Long, ByVal fRunmode As Long, _
                riid As GUID, lplpvObj As Any) As Long
    J'ai essayé de modifier le dernier parametre lplpvObj en le déclarant longptr.
    Nouvelle déclaration
    Code :
    1
    2
    3
    Private Declare PtrSafe Function OleLoadPicture Lib "oleaut32" _
                (lpstream As Any, ByVal lSize As Long, ByVal fRunmode As Long, _
                riid As GUID, lplpvObj As LongPtr) As Long
    Il semblerait que ça marche, mais je ne suis pas sur de moi car je ne connais pas cette API

    En espérant que cette remarque vous sera utile, je vous salut bien amicalement.

    PS: le même plantage se produit avec les exemples d'utilisation de la classe gdi32

  16. #116
    Invité de passage
    Homme Profil pro
    Développeur informatique
    Inscrit en
    novembre 2012
    Messages
    2
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Aéronautique - Marine - Espace - Armement

    Informations forums :
    Inscription : novembre 2012
    Messages : 2
    Points : 2
    Points
    2

    Par défaut plantage office2013 64

    Re bonjour,
    J'ai oublie de precise que j'ai aussi modifie l'appel
    OleLoadPicture ByVal loStream, lSize, 0, PicGUID, ByVal loImg

    A+

  17. #117
    Expert Confirmé Sénior

    Avatar de milkoseck
    Homme Profil pro Malick SECK
    Auditeur
    Inscrit en
    juillet 2012
    Messages
    527
    Détails du profil
    Informations personnelles :
    Nom : Homme Malick SECK
    Âge : 30
    Localisation : Sénégal

    Informations professionnelles :
    Activité : Auditeur
    Secteur : Finance

    Informations forums :
    Inscription : juillet 2012
    Messages : 527
    Points : 4 104
    Points
    4 104

    Par défaut

    Citation Envoyé par Arkham46 Voir le message
    Bonjour à tous,

    Je vous propose un outil d'aide pour créer/modifier vos rubans Office :
    http://arkham46.developpez.com/artic...sistant-ruban/



    Je vous invite à poster à la suite vos commentaires (avis, remerciement, souhait d'évolution, bug, ...).


    Une question plus générale sur les rubans?
    Posez-votre question dans une nouvelle discussion sur le forum adéquat pour avoir plus de chance de réponse.
    (Je ne répond pas sur cette discussion aux questions n'ayant pas de rapport direct avec l'assistant ruban.)
    Bonjour,
    je voulais juste vous remercier pour cette astuce qui m'a beaucoup servi.
    Un petit si le message est pertinent
    si votre problème est résolu, n'oubliez pas le Tag
    Mon blog. Mes articles.

  18. #118
    Membre confirmé
    Inscrit en
    juin 2007
    Messages
    927
    Détails du profil
    Informations forums :
    Inscription : juin 2007
    Messages : 927
    Points : 216
    Points
    216

    Par défaut

    Citation Envoyé par Daejung Voir le message
    Merci

    J'utilise cet assistant avec Access 2010 et cela marche aussi très bien, mais quand je quitte Access j'ai systématiquement un message d'erreur :



    et Access plante puis redémarre.

    Je vais voir si ce problème est résolu avec la nouvelle version.
    Bonjour,

    J'ai toujours le même problème mais apparemment il ne concerne que le ruban Excel (j'utilise Office 2010) et un fichier Excel en particulier. Cela n'empêche pas le ruban d'être correctement généré.

    Avec un ruban généré pour une application Access, pas de problème non plus.

    PC sous Seven et sous Vista


  19. #119
    Responsable Access
    Avatar de Arkham46
    Profil pro
    Inscrit en
    septembre 2003
    Messages
    4 765
    Détails du profil
    Informations personnelles :
    Localisation : France, Loiret (Centre)

    Informations forums :
    Inscription : septembre 2003
    Messages : 4 765
    Points : 9 160
    Points
    9 160

    Par défaut

    Bonjour,

    Version 2.0.7 en ligne

    J'ai corrigé quelques sources de plantage sur Access 2013 (et 2010 par la même occasion je pense).

    @gillou5576 : OleLoadPicture ne plante pas sur mon Access 2013 64 bits
    Peut-être que les corrections que j'ai apportées corrigeront ton problème ?

    @Daejung : j'ai corrigé un plantage qui survenait à la fermeture sur certaines config.
    Si tu as toujours un plantage, et sur un fichier particulier, tu peux me donner ce fichier pour que je regarde.

    @Pierre30130 : les onglets "en couleur" sont des onglets contextuels (contextualTabs)

    Merci.

  20. #120
    Membre confirmé
    Inscrit en
    juin 2007
    Messages
    927
    Détails du profil
    Informations forums :
    Inscription : juin 2007
    Messages : 927
    Points : 216
    Points
    216

    Par défaut

    merci, je vais tester cette dernière version.

    Je ne pourrai de toutes façons malheureusement pas te donner copie du fichier Access 2010 en cause car c'est un fichier professionnel et l'entreprise où je bosse est très pointilleuse la dessus

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •