Publicité

Affichage des résultats du sondage: Quelle version de Java utilisez vous principalement ?

Votants
290. Vous ne pouvez pas participer à ce sondage.
  • Java SE 7

    9 3,10%
  • Java SE 6

    130 44,83%
  • Java SE 5

    98 33,79%
  • J2SE 1.4

    50 17,24%
  • J2SE 1.3 et antérieures

    3 1,03%
Discussion fermée
Page 2 sur 3 PremièrePremière 123 DernièreDernière
Affichage des résultats 21 à 40 sur 53
  1. #21
    Modérateur

    Inscrit en
    août 2006
    Messages
    3 091
    Détails du profil
    Informations forums :
    Inscription : août 2006
    Messages : 3 091
    Points : 3 380
    Points
    3 380

    Par défaut

    Pour moi, c'est plutôt 1.4 au boulot.
    A la maison c'est au mieux 1.5 (eh oui, sur mac, on a pas mieux pour l'instant) ou 1.4 si je veux un maximum de compatibilité avec les JRE.
      0  0

  2. #22
    Expert Confirmé Sénior Avatar de Uther
    Homme Profil pro
    Inscrit en
    avril 2002
    Messages
    3 055
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2002
    Messages : 3 055
    Points : 5 975
    Points
    5 975

    Par défaut

    Citation Envoyé par elitost Voir le message
    Principalement la 5 chez moi et dans des précédentes missions, actuellement au boulot on bloque encore à la 1.4 migration prévue cette année vers la 5
    Il y a une raison particulière de ne pas migrer directement a la 6?

    Migrer de version est quelquechose qui est souvent problèmatique, donc je serais tenté d'en profiter pour passer directement à la dernière version dispo. D'autant plus que Java 6 est quand même assez eprouvée maintenant.
      0  0

  3. #23
    Modérateur

    Inscrit en
    août 2006
    Messages
    3 091
    Détails du profil
    Informations forums :
    Inscription : août 2006
    Messages : 3 091
    Points : 3 380
    Points
    3 380

    Par défaut

    Oui, sauf qu'au boulot, on est pas toujours décideur, et qu'ensuite, on installe rarement les dernières versions, même si celles-ci sont éprouvées.
    Là ou je bosse (grande entreprise), on vient seulement de passer à Windows Xp.
      0  0

  4. #24
    Membre expérimenté Avatar de bassim
    Homme Profil pro
    Ingénieur Réseaux
    Inscrit en
    février 2005
    Messages
    657
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 29
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur Réseaux
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : février 2005
    Messages : 657
    Points : 533
    Points
    533

    Par défaut

    L'avantage d'être chomeur, c'est de choisir soi même sa version (6)
    Faites comme moi et vous n'aurez plus de problèmes de ce coté là
      0  0

  5. #25
    Expert Confirmé
    Avatar de natha
    Profil pro
    Inscrit en
    janvier 2006
    Messages
    2 346
    Détails du profil
    Informations personnelles :
    Localisation : Suisse

    Informations forums :
    Inscription : janvier 2006
    Messages : 2 346
    Points : 2 735
    Points
    2 735

    Par défaut

    Citation Envoyé par fr1man Voir le message
    Là ou je bosse (grande entreprise), on vient seulement de passer à Windows Xp.
    Comment ??? Pour Java passe encore mais pour XP... vous étiez sous 98 ou 2000 avant ? C'est un peu dangereux étant donné tout ce qui traîne...



    Par rapport au sondage je trouve cool que beaucoup soient sous Java5 ou mieux au travail. J'pensais que la proportion aurait été plus faible.
    Comment ça ? La réponse à ton problème n'est ni dans la faq, ni dans les tutos, ni dans sources ??? Etonnant...
    De la bonne manière de poser une question (et de répondre).
    Je ne fais pas de service par MP. Merci (...de lire les règles...).
    Ma page dvp.com
      0  0

  6. #26
    Expert Confirmé Sénior Avatar de Uther
    Homme Profil pro
    Inscrit en
    avril 2002
    Messages
    3 055
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2002
    Messages : 3 055
    Points : 5 975
    Points
    5 975

    Par défaut

    Tout dépends ce qu'il avait avant.

    Windows 2000 est tout à fait acceptable. Windows NT 4 moins. Si tu me dis Windows 9x, il faut pendre l'admin.
      0  0

  7. #27
    Modérateur

    Inscrit en
    août 2006
    Messages
    3 091
    Détails du profil
    Informations forums :
    Inscription : août 2006
    Messages : 3 091
    Points : 3 380
    Points
    3 380

    Par défaut

    Comment ??? Pour Java passe encore mais pour XP... vous étiez sous 98 ou 2000 avant ? C'est un peu dangereux étant donné tout ce qui traîne...
    On était sous 2000.
    Là, on a eu des machines toutes neuves avec XP.

    C'est la politique générale de l'entreprise.
    On est encore en java 1.3 selon les projets.
      0  0

  8. #28
    Membre actif
    Profil pro
    Inscrit en
    avril 2007
    Messages
    219
    Détails du profil
    Informations personnelles :
    Âge : 31
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : avril 2007
    Messages : 219
    Points : 153
    Points
    153

    Par défaut

    Au boulot : Java 1.4 il y'a 6 mois, maintenant 1.5 ca pas été une mince affaire pour pouvoir décider tout le monde de changer.
      0  0

  9. #29
    Membre Expert
    Avatar de fabszn
    Homme Profil pro Fabrice Sznajderman
    Développeur Java
    Inscrit en
    mars 2002
    Messages
    976
    Détails du profil
    Informations personnelles :
    Nom : Homme Fabrice Sznajderman
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur Java

    Informations forums :
    Inscription : mars 2002
    Messages : 976
    Points : 1 529
    Points
    1 529

    Par défaut

    Au bureau la 1.4 .. Je pousse pour migrer vers la 5
    Version 5 à la maison..
    @+

    Fabszn
    Twitter : @fsznajderman

    N'oubliez pas le bouton
    Comment bien poser ses questions sur le forum

      0  0

  10. #30
    Membre éprouvé Avatar de JoloKossovar
    Inscrit en
    décembre 2007
    Messages
    532
    Détails du profil
    Informations forums :
    Inscription : décembre 2007
    Messages : 532
    Points : 497
    Points
    497

    Par défaut

    Citation Envoyé par fr1man Voir le message
    On était sous 2000.
    Là, on a eu des machines toutes neuves avec XP.

    C'est la politique générale de l'entreprise.
    On est encore en java 1.3 selon les projets.
    java 1.3 ... Tu bosse dans une fabrique de bougie à l'ancienne ? ^^
      0  0

  11. #31
    Modérateur
    Avatar de sinok
    Profil pro
    Inscrit en
    août 2004
    Messages
    8 761
    Détails du profil
    Informations personnelles :
    Âge : 34
    Localisation : France, Paris (Île de France)

    Informations forums :
    Inscription : août 2004
    Messages : 8 761
    Points : 11 836
    Points
    11 836

    Par défaut

    Citation Envoyé par JoloKossovar Voir le message
    java 1.3 ... Tu bosse dans une fabrique de bougie à l'ancienne ? ^^
    Beaucoup d'entreprises tournent encore en 1.3 ou 1.4 car elles ont du passif dessus, et faire migrer un parc d'applis çà douille (même si java est compatible de façon ascendante il faut quand même tout retester et mettre à jour le code source de certaines applis éventuellement)
    Hey, this is mine. That's mine. All this is mine. I'm claiming all this as mine. Except that bit. I don't want that bit. But all the rest of this is mine. Hey, this has been a really good day. I've eaten five times, I've slept six times, and I've made a lot of things mine. Tomorrow, I'm gonna see if I can't have sex with something.
      0  0

  12. #32
    Membre actif
    Inscrit en
    novembre 2006
    Messages
    156
    Détails du profil
    Informations forums :
    Inscription : novembre 2006
    Messages : 156
    Points : 169
    Points
    169

    Par défaut

    Comme certain.
    Au boulot du java 1.4. On a l'espoir de migrer un jour en 1.5.
    Sinon j'utilise un jdk 6 mais code du 1.5. (En clair je n'ai pas encore commencer à integrer dans mes devs des spécificités de la 6 )
      0  0

  13. #33
    Membre éprouvé Avatar de billynirvana
    Homme Profil pro Billy
    Ingénieur développement logiciels
    Inscrit en
    décembre 2004
    Messages
    469
    Détails du profil
    Informations personnelles :
    Nom : Homme Billy
    Âge : 33
    Localisation : France

    Informations professionnelles :
    Activité : Ingénieur développement logiciels
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : décembre 2004
    Messages : 469
    Points : 448
    Points
    448

    Par défaut

    La moitié de nos applis tournent sous JAVA 1.3 (WebSphere 5) et l'autre sous JAVA 1.4 (BEA Weblogic 8 et WebSphere 6). Chez moi sous JAVA 6.
      0  0

  14. #34
    Membre actif Avatar de DrHelmut
    Homme Profil pro Hugo Capocci
    Directeur technique
    Inscrit en
    octobre 2005
    Messages
    110
    Détails du profil
    Informations personnelles :
    Nom : Homme Hugo Capocci
    Âge : 33
    Localisation : France, Hauts de Seine (Île de France)

    Informations professionnelles :
    Activité : Directeur technique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : octobre 2005
    Messages : 110
    Points : 178
    Points
    178

    Par défaut

    java 1.4 chez mon client actuel (AXA), et ce uniquement car il est persuadé que la retro compatibilité n'est pas assurée en java 5+ .....

    pourtant, vu le code des applis à maintenir, on gagnerais énormément avec les apports syntaxiques (notamment le 'foreach' et les énumération)
      0  0

  15. #35
    Membre Expert
    Avatar de narmataru
    Profil pro
    Inscrit en
    décembre 2002
    Messages
    1 537
    Détails du profil
    Informations personnelles :
    Âge : 34
    Localisation : France, Loire Atlantique (Pays de la Loire)

    Informations forums :
    Inscription : décembre 2002
    Messages : 1 537
    Points : 1 497
    Points
    1 497

    Par défaut

    J'utilise la version 6 depuis sa sortie pour mes nouveaux projets. Les autres sont en 1.4.
    La version 6 est vraiment bien abouti.
    L'amélioration qui m'a le plus servi dans l'API est l'intégration des Queue et autres listes bloquante. Quel bonheur de n'avoir pas a gérer les threads de concurence !
    Je trouve aussi l'amélioration des performances assez notable.

    Vivement la 7
      0  0

  16. #36
    Invité de passage
    Inscrit en
    novembre 2005
    Messages
    8
    Détails du profil
    Informations forums :
    Inscription : novembre 2005
    Messages : 8
    Points : 4
    Points
    4

    Par défaut

    J'ai voté Java 6 car c'est avec cette version que j'ai fait mon travail de diplôme et depuis toutes mes appli sont fait avec.
      0  0

  17. #37
    Candidat au titre de Membre du Club
    Inscrit en
    janvier 2007
    Messages
    23
    Détails du profil
    Informations forums :
    Inscription : janvier 2007
    Messages : 23
    Points : 13
    Points
    13

    Par défaut

    j'ai voté java se 6,car je l'utilise
      0  0

  18. #38
    Invité régulier
    Inscrit en
    novembre 2007
    Messages
    10
    Détails du profil
    Informations forums :
    Inscription : novembre 2007
    Messages : 10
    Points : 9
    Points
    9

    Par défaut

    JDK 1.5 / JRE 1.6 au travail, JDK 1.5 / JRE 1.5 pour mon projet personnel.
    Tiger répond aujourd'hui aux besoins que je rencontre.

    Je suis les débats sur la versions 1.7 et je me dis que je passerai peut-être directement à la 1.7 pour mon projet.
      0  0

  19. #39
    Modérateur
    Avatar de OButterlin
    Homme Profil pro
    Inscrit en
    novembre 2006
    Messages
    5 610
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : novembre 2006
    Messages : 5 610
    Points : 6 237
    Points
    6 237

    Par défaut

    Java6 sur le dernier projet, mais java5 également sur d'anciens (imposé par le client)
    Mais pour être franc, je ne vois pas (encore) de différences dans le type d'utilisation que j'en fais (appli web), il paraît que la 6 est plus rapide que la 5... on verra à l'usage !
      0  0

  20. #40
    Membre Expert Avatar de willoi
    Profil pro
    Développeur informatique
    Inscrit en
    décembre 2006
    Messages
    1 355
    Détails du profil
    Informations personnelles :
    Âge : 41
    Localisation : France, Haute Garonne (Midi Pyrénées)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : décembre 2006
    Messages : 1 355
    Points : 1 484
    Points
    1 484

    Par défaut

    Java 5 sur le projet actuel et java 1.4 sur les precedents.

    Cela depend des clients.

    Personnellement si j'ai le choix, j'utilise java 5 (voire plus à decouvrir ...)
      0  0

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •