Publicité
+ Répondre à la discussion Actualité déjà publiée
Page 6 sur 7 PremièrePremière ... 234567 DernièreDernière
Affichage des résultats 101 à 120 sur 128
  1. #101
    Invité régulier
    Inscrit en
    janvier 2009
    Messages
    5
    Détails du profil
    Informations forums :
    Inscription : janvier 2009
    Messages : 5
    Points : 6
    Points
    6

    Par défaut Ça ne marche pas fort à date

    Moi j'ai téléchargé la version architecte du site CodeGear en évaluation. Et il m'est totalement impossible de me servir de la moindre Base de Donnée. J'ai toujours comme erreur, la 1ère fois, erreur de protection dans le fichier ntdll.dll, et, les fois suivantes, Erreur lors de l'initialisation de Borland Database Engine.

    Je ne sais pas si d'autres que vous avez eu ce problème. J'ai une vielle version de Delphi 3 qui elle marche toujours et je voulais essayer une version plus à date mais actuellement, je n'ai que des problèmes

  2. #102
    Membre Expert Avatar de chaplin
    Inscrit en
    août 2006
    Messages
    1 213
    Détails du profil
    Informations forums :
    Inscription : août 2006
    Messages : 1 213
    Points : 1 437
    Points
    1 437

    Par défaut

    J'ai installé Delphi 2009 sur Vista, tout c'est très bien passé.
    Quelle est ta version Windows ?

  3. #103
    Invité régulier
    Inscrit en
    janvier 2009
    Messages
    5
    Détails du profil
    Informations forums :
    Inscription : janvier 2009
    Messages : 5
    Points : 6
    Points
    6

    Par défaut

    Windows XP

  4. #104
    Membre Expert Avatar de chaplin
    Inscrit en
    août 2006
    Messages
    1 213
    Détails du profil
    Informations forums :
    Inscription : août 2006
    Messages : 1 213
    Points : 1 437
    Points
    1 437

    Par défaut

    SP1,SP2,SP3 ?

    Sinon j'ai trouvé ce lien http://www.dll-files.com/dllindex/dll-files.shtml?ntdll,
    C'est une piste, autrement je ne vois pas, mais c'est lié à l'OS.

  5. #105
    Invité régulier
    Inscrit en
    janvier 2009
    Messages
    5
    Détails du profil
    Informations forums :
    Inscription : janvier 2009
    Messages : 5
    Points : 6
    Points
    6

    Par défaut

    J'ai recopié le dll, j'ai scanné mes registres et rien à faire, il y a toujours une erreur dans ntdll.dll lorsqu'il utilise la fonction RtlpWaitForCriticalSection. C'est ce que j'ai en tout cas quand je regarde la source de l'erreur.

    Est-ce que d'autres personnes ont déjà essayées leurs programmes Delphi 2009 sur Windows XP?

  6. #106
    Invité régulier
    Inscrit en
    janvier 2009
    Messages
    5
    Détails du profil
    Informations forums :
    Inscription : janvier 2009
    Messages : 5
    Points : 6
    Points
    6

    Par défaut

    Même problème avec Delphi 2007

  7. #107
    Membre Expert Avatar de chaplin
    Inscrit en
    août 2006
    Messages
    1 213
    Détails du profil
    Informations forums :
    Inscription : août 2006
    Messages : 1 213
    Points : 1 437
    Points
    1 437

    Par défaut

    Remarque débile, mais as tu essayé de l'installé (2007 ou 2009) sur une autre machine XP ?

  8. #108
    Membre habitué Avatar de Cpt Anderson
    Profil pro
    Développeur informatique
    Inscrit en
    novembre 2005
    Messages
    210
    Détails du profil
    Informations personnelles :
    Âge : 40
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : novembre 2005
    Messages : 210
    Points : 143
    Points
    143

    Par défaut

    Citation Envoyé par Charly910 Voir le message
    Bonjour,

    je passe de D7 à D2009 - j'ai un peu de mal à m'habituer à l'interface et je travaille moins vite.

    Le Help me parait aussi moins pratique que le hlp de D7

    les images GIF ne semblent pas être reconnues ni avec la VCL, ni avec la JVCL (JvGifAnimator par exemple) j'ai un message n° de version de Gif incorrect

    Sinon cela fonctionne je pense que je vais m'habituer.

    La compilation me semble plus lente qu'avec D7

    A+

    Charly
    Salut,

    Pareil pour après 5 ou 6 ans en Delphi 7, je migre en Delphi 2009 à mon boulot.
    J'ai simplement personnalisé mon interface pour que ça ressemble beaucoup à mon delphi 7. Par contre la barre des composants ou plutôt la disparition de la barre des composants est vraiment pas une bonne idée.

    Le Help est extrêmement long et beaucoup moins instinctif qu'avec delphi 7.
    Voici la méthode de mon chef:

    copy (DateTimeToStr(Now),7,4)+
    copy (DateTimeToStr(Now),4,2)+copy (DateTimeToStr(Now),1,2)+copy (DateTimeToStr(Now),12,2)+
    copy (DateTimeToStr(Now),15,2)+copy (DateTimeToStr(Now),18,2)

    Je lui ai dit que FormatDateTime irait surement mieux


  9. #109
    Membre Expert Avatar de chaplin
    Inscrit en
    août 2006
    Messages
    1 213
    Détails du profil
    Informations forums :
    Inscription : août 2006
    Messages : 1 213
    Points : 1 437
    Points
    1 437

    Par défaut

    Par contre la barre des composants ou plutôt la disparition de la barre des composants est vraiment pas une bonne idée.
    C'est une question d'habitude, on s'y fait vite, à la longue je préfère cette méthode. Mais tu peux faire une recherche du composant dans le cadre, et ça c'est vachement bien !

  10. #110
    Expert Confirmé

    Profil pro Franck Soriano
    Leader Technique
    Inscrit en
    juin 2005
    Messages
    1 757
    Détails du profil
    Informations personnelles :
    Nom : Franck Soriano
    Âge : 36
    Localisation : France, Rhône (Rhône Alpes)

    Informations professionnelles :
    Activité : Leader Technique
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juin 2005
    Messages : 1 757
    Points : 3 661
    Points
    3 661

    Par défaut

    Citation Envoyé par chaplin Voir le message
    C'est une question d'habitude, on s'y fait vite, à la longue je préfère cette méthode. Mais tu peux faire une recherche du composant dans le cadre, et ça c'est vachement bien !
    +1
    Je préfère aussi cette nouvelle façon de travailler. Avec l'ancienne palette, je passais mon temps à chercher le bon onglet, puis à scroller pour trouver le composant.
    Maintenant, j'utilise systématiquement la recherche de composant.

    Citation Envoyé par Cpt Anderson
    Le Help est extrêmement long et beaucoup moins instinctif qu'avec delphi 7.
    C'est comme ça depuis un moment.
    Personnellement, je trouve que l'aide Delphi s'est très fortement dégradée le jour où ils sont passé au format html (d'ailleurs je ne la regarde plus).

  11. #111
    Membre du Club
    Inscrit en
    mai 2003
    Messages
    64
    Détails du profil
    Informations forums :
    Inscription : mai 2003
    Messages : 64
    Points : 50
    Points
    50

    Par défaut

    Citation Envoyé par Cpt Anderson Voir le message
    Salut,

    Pareil pour après 5 ou 6 ans en Delphi 7, je migre en Delphi 2009 à mon boulot.
    J'ai simplement personnalisé mon interface pour que ça ressemble beaucoup à mon delphi 7. Par contre la barre des composants ou plutôt la disparition de la barre des composants est vraiment pas une bonne idée.

    Le Help est extrêmement long et beaucoup moins instinctif qu'avec delphi 7.

    Bonjour

    il existe une extention pour avoir une barre des composants comme celle de delphi 7 :
    http://andy.jgknet.de/blog/?page_id=10

    cordialement
    Sébastien
    --
    Mes freewares : http://www.perrysoft.org

  12. #112
    Invité régulier
    Inscrit en
    janvier 2009
    Messages
    5
    Détails du profil
    Informations forums :
    Inscription : janvier 2009
    Messages : 5
    Points : 6
    Points
    6

    Par défaut

    Citation Envoyé par chaplin Voir le message
    Remarque débile, mais as tu essayé de l'installé (2007 ou 2009) sur une autre machine XP ?
    Oui, je l'ai fait hier et ça semble correct sur cet autre XP qui malheureusement ne m'appartient pas. Peut-être qu'un reformattage s'impose car toutes les solutions à date pour essayer de stabiliser mon XP ne semble pas avoir d'effet sur ce logiciel Delphi

  13. #113
    Invité de passage
    Inscrit en
    août 2004
    Messages
    1
    Détails du profil
    Informations forums :
    Inscription : août 2004
    Messages : 1
    Points : 1
    Points
    1

    Par défaut

    Bonjour,

    Moi aussi, j'ai essayé Delphi 2009 pour voir quelques étaient les impacts sur mes codes sources et je suis assez déçu :
    Les bons points : IDE moins lourd, me semble plu stable,démarrage plus rapide, l'aide en ligne fonctionne enfin correctement (sous 2007, il mettait 5 min à démarrer et l'aide contextuelle n'a jamais fonctionné ).

    Les mauvais points :
    - composants tierces parties à mettre à jour : les versions pour Delphi 2007 ne compilent pas (merci l'unicode....).A vos licences (pour obtenir des mises à jour de ces composants).
    A mon avis, beaucoup de pro ne passeront pas à 2009 : rien que dans certaines banques ou j'ai bossé, il y a des milliers de codes sources qui ne passent pas l'unicode, ça couterait un fric immense pour les mettre à jour.

    Franchement, même si mes codes sources à moi semblent peux impactés, il faudrait que je mette à jour tout les composants extrnes, et là, ça me gave grave.

    Et puis le fait qu'embarcadero est repris le bébé ne me plait pas beaucoup : au bureau, on utilise rapidsql d'embarcadero et c'est une pure saloperie : pas stable, délais de connexion super long, prend plus de 100 Mo en mémoire, ne libère pas la mémoire après avoir fermer le résultat d'une requête.......

    Le problème c'est qu'on va pas avoir le choix : le jour ou M$ sort un OS sur lequel delphi 2007 ne marche pas, on sera obligé de franchir le pas.
    (c'est vista qui nous a obligé à passer à delphi 2007, sinon, au bureau, on serait toujours sous delphi 7).

    Bon dimanche

  14. #114
    Invité de passage
    Étudiant
    Inscrit en
    juin 2006
    Messages
    2
    Détails du profil
    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : juin 2006
    Messages : 2
    Points : 2
    Points
    2

    Par défaut Problème Delphi 2009

    Bonjour,
    J'utilisais depuis longtemps la version Delphi 7 et je vient de passer à la version Delphi 2009, Je trouve cette version pas mal, à par comme pas mal de monde ici : le ruban Office 2007 est nul, seul les infos bulles on l'air d'être pas mal (à ce que j'ai vu dans leurs démos) mais ces infos bulles sont très compliquer à placer, je n'ai pas réussi. Ce ruban est un échec.
    Pour la gestion des PNG, ça faisait longtemps que j'attendais ça, même si je n'est pas encore testé. L'aide est vraiment nul et c'est incroyable le temps qu'elle met à ce lancer !

    Sinon je vais vous parler de mon problème avec cette version 2009.
    Avant, avec delphi 7, j'appuyais sur le bouton CTRL et je cliquait sur une fonction ou une propriété, etc... et je voyait le code de cette fonction, ce qui m'était très utile. Ces fonctions était stocké dans windows.pas ou SysUtils.pas ou encore ExtCtrls.pas par exemple.
    Maintenant, avec D2009, quand je fait un CTRL+clic sur IntToStr (par exemple) je vois l'erreur suivante : "impossible de trouvé le fichier 'SysUtils.pas'".
    J'ai chercher sur mon disque dur et effectivement il n'y a pas dans la librairie de fichier .pas, uniquement les fichiers compilés (par exemple SysUtils.dcu).

    J'aimerais en savoir plus la dessus, si c'est codeGear qui ne veut plus montrer le code avec les fichiers .pas si c'est le cas, depuis quand. Ou si c'est juste un problème durant l'installation (que j'ai quand même refait 3 fois).

    Ce problème me gène beaucoup, si vous avez une solution, je vous en remercie.

    (PS : Mon système est un XP SP3)

  15. #115
    Membre Expert
    Avatar de Thierry Laborde
    Homme Profil pro Thierry LABORDE
    Inscrit en
    avril 2002
    Messages
    1 106
    Détails du profil
    Informations personnelles :
    Nom : Homme Thierry LABORDE
    Âge : 44
    Localisation : France

    Informations forums :
    Inscription : avril 2002
    Messages : 1 106
    Points : 1 475
    Points
    1 475

    Par défaut

    Citation Envoyé par christophe-44 Voir le message
    Sinon je vais vous parler de mon problème avec cette version 2009.
    Avant, avec delphi 7, j'appuyais sur le bouton CTRL et je cliquait sur une fonction ou une propriété, etc... et je voyait le code de cette fonction, ce qui m'était très utile. Ces fonctions était stocké dans windows.pas ou SysUtils.pas ou encore ExtCtrls.pas par exemple.
    Maintenant, avec D2009, quand je fait un CTRL+clic sur IntToStr (par exemple) je vois l'erreur suivante : "impossible de trouvé le fichier 'SysUtils.pas'".
    J'ai chercher sur mon disque dur et effectivement il n'y a pas dans la librairie de fichier .pas, uniquement les fichiers compilés (par exemple SysUtils.dcu).

    J'aimerais en savoir plus la dessus, si c'est codeGear qui ne veut plus montrer le code avec les fichiers .pas si c'est le cas, depuis quand. Ou si c'est juste un problème durant l'installation (que j'ai quand même refait 3 fois).

    Ce problème me gène beaucoup, si vous avez une solution, je vous en remercie.

    (PS : Mon système est un XP SP3)
    Bonjour,

    Ce problème est seulement lié à la version Trial. En effet, à partir du moment ou l'on installe une version avec un numéro de série d'une version Trial, certains fichiers installés ne seront disponible qu'en version compilés, sans les sources.
    Bien entendu ce problème n'existe pas avec une version complète.
    Thierry Laborde

    Embarcadero
    Directeur des Ventes France

    Blog : http://blogs.embarcadero.com/tlaborde
    _____________________________________________
    Un logiciel permet de remplir certaines taches. Mais la plupart du temps il est également destiné à des utilisateurs. Alors n'oubliez jamais l'Ergonomie

  16. #116
    Membre chevronné
    Inscrit en
    mars 2002
    Messages
    720
    Détails du profil
    Informations forums :
    Inscription : mars 2002
    Messages : 720
    Points : 608
    Points
    608

    Par défaut

    Citation Envoyé par christophe-44 Voir le message
    Maintenant, avec D2009, quand je fait un CTRL+clic sur IntToStr (par exemple) je vois l'erreur suivante : "impossible de trouvé le fichier 'SysUtils.pas'".
    Je te rassure : cela doit toujours fonctionné en D2009.
    tu n'utilises pas une version trial car je ne suis pas sur que les sources de la VCL sont fournis ?

  17. #117
    Invité de passage
    Étudiant
    Inscrit en
    juin 2006
    Messages
    2
    Détails du profil
    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : juin 2006
    Messages : 2
    Points : 2
    Points
    2

    Par défaut

    Merci Thierry Laborde et VLDG, Je suis rassurer, je pense que cette version va me plaire !!

  18. #118
    Invité de passage
    Inscrit en
    octobre 2004
    Messages
    1
    Détails du profil
    Informations forums :
    Inscription : octobre 2004
    Messages : 1
    Points : 1
    Points
    1

    Par défaut Delphi 2009 est à déconseiller

    Version totalement instable : si vous lancez une compilation ou une construction, il arrive aléatoirement que Delphi 2009 se ferme sans aucun message d'erreur. Par ailleurs, Rave Report 7.6.0, et même 7.6.1 est totalement buggé : impossible d'imprimer au delà de la première page. Intervient alors une erreur "impossible d'imprimer". Rajoutez à cela des violations d'accès aléatoires, et, cerise sur le gâteau : mon application se bloque en mode débogage, sans aucun message d'erreur ni (bien sûr) de point d'arrêt.

    En conclusion : une version probablement bien trop rapidement sortie. Comme disent les américains : il ne vaut pas l'argent que j'y ai mis dedans.

  19. #119
    Membre Expert Avatar de skywaukers
    Homme Profil pro Dany Leblanc
    Directeur de projet
    Inscrit en
    juin 2005
    Messages
    1 071
    Détails du profil
    Informations personnelles :
    Nom : Homme Dany Leblanc
    Localisation : France, Charente (Poitou Charente)

    Informations professionnelles :
    Activité : Directeur de projet
    Secteur : Industrie

    Informations forums :
    Inscription : juin 2005
    Messages : 1 071
    Points : 1 459
    Points
    1 459

    Par défaut

    Bonjour,

    Citation Envoyé par GAILLEDREAU Voir le message
    Version totalement instable : si vous lancez une compilation ou une construction, il arrive aléatoirement que Delphi 2009 se ferme sans aucun message d'erreur. Par ailleurs, Rave Report 7.6.0, et même 7.6.1 est totalement buggé : impossible d'imprimer au delà de la première page. Intervient alors une erreur "impossible d'imprimer". Rajoutez à cela des violations d'accès aléatoires, et, cerise sur le gâteau : mon application se bloque en mode débogage, sans aucun message d'erreur ni (bien sûr) de point d'arrêt.

    En conclusion : une version probablement bien trop rapidement sortie. Comme disent les américains : il ne vaut pas l'argent que j'y ai mis dedans.
    Avant de tirer ces conclusions, as-tu essayés de l'installer sur un autre poste, une autre configuration, cela a-t-il confirmé tes observations ?

    @++
    Dany

  20. #120
    Membre habitué
    Inscrit en
    mars 2003
    Messages
    272
    Détails du profil
    Informations personnelles :
    Âge : 40

    Informations forums :
    Inscription : mars 2003
    Messages : 272
    Points : 140
    Points
    140

    Par défaut

    Est-ce que quelqu'un à tester ECO sous D2009 ?
    - en migrant un projet bds2006
    - en démarrant un nouveau projet

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •