+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3
  1. #1
    Invité de passage
    Inscrit en
    mai 2008
    Messages
    2
    Détails du profil
    Informations forums :
    Inscription : mai 2008
    Messages : 2
    Points : 1
    Points
    1

    Par défaut pb a la compilation avec yagarto

    Bonjour !!!!!

    Dans mon stage, je dois installer un IDE, une chaine de compilation et tout ce qu'il faut pour pouvoir communiquer avec des cartes ARM7 ou ARM9.

    Pour l'instant, j'ai installé Eclipse avec Cygwin et j'essaye différente chaine de compilation (YAGARTO,GNUARM,...)

    Mais voila je n'arrive pas à compiler mon petit programme pour faire mon comparatif entre toutes ces chaine de compilation. Eclipse me dit qu'il ne ne trouve pas -lgcc

    Ca fait toute la journée que je coince sur ce pb

    aidez-moi pléplé !!!

    voici ce qu'indique la console d'Eclipse.....

    **** Build of configuration Release for project test_yagarto ****

    make -k all
    Building target: test_yagarto.elf
    Invoking: C Linker
    arm-elf-ld ./hello.o -o"test_yagarto.elf" -static -lc -lgcc -Map=test_yagarto.map
    c:\WinARM\bin\arm-elf-ld.exe: cannot find -lgcc
    make: *** [test_yagarto.elf] Error 1
    make: Target `all' not remade because of errors.

  2. #2
    Invité de passage
    Inscrit en
    mai 2008
    Messages
    2
    Détails du profil
    Informations forums :
    Inscription : mai 2008
    Messages : 2
    Points : 1
    Points
    1

    Par défaut

    Salut j'ai réussis à trouver la solution à mon problème il y a quelques jours!!

    En fait Eclipse ne trouvait pas la librairie libgcc.a. Celle ci se trouve dans le dossier des librairie de yagarto.

    J'aurais vraiment aimé avoir des réponses mais bon..... je ne dirais rien

  3. #3
    Invité de passage
    Homme Profil pro
    Inscrit en
    mars 2012
    Messages
    4
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : mars 2012
    Messages : 4
    Points : 1
    Points
    1

    Par défaut

    Bonjour nico026,

    Je suis dans le même cas que toi en stage, je dois utiliser éclipse/yagarto pour compiler/debuger un ARM9. j'ai installer tout ce qui est eclipse yagarto mais lors de la compilation j'ai énormément d'erreur alors si tu pouvais me procurer des exemples que tu as, ou tes propres sources pour que je puisse comparer et voir mes erreurs.
    Je te remercie d'avance

    Sheva

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •