Soutenez-nous
Publicité

Affichage des résultats du sondage: Quelle version de Java utilisez vous principalement ?

Votants
245. Vous ne pouvez pas participer à ce sondage.
  • Java SE 7

    5 2,04%
  • Java SE 6

    144 58,78%
  • Java SE 5

    76 31,02%
  • J2SE 1.4

    18 7,35%
  • J2SE 1.3 et antérieures

    2 0,82%
+ Répondre à la discussion Actualité déjà publiée
Page 2 sur 2 PremièrePremière 12
Affichage des résultats 21 à 34 sur 34
  1. #21
    Membre extrêmement actif
    Avatar de kedare
    Profil pro Mathieu
    Administrateur systèmes et réseaux
    Inscrit en
    juillet 2005
    Messages
    1 487
    Détails du profil
    Informations personnelles :
    Nom : Mathieu
    Localisation : France

    Informations professionnelles :
    Activité : Administrateur systèmes et réseaux

    Informations forums :
    Inscription : juillet 2005
    Messages : 1 487
    Points : 1 407
    Points
    1 407

    Par défaut

    Citation Envoyé par ptitbob Voir le message
    Java 1.6 au niveau perso (vivement JEE 6) - Et que Java 7 sorte vite sous OSX
    Faudrais déja qu'Apple se descide a sortir la version 32bits de java6...

  2. #22
    Nouveau Membre du Club
    Homme Profil pro
    Développeur Java
    Inscrit en
    septembre 2007
    Messages
    15
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations professionnelles :
    Activité : Développeur Java

    Informations forums :
    Inscription : septembre 2007
    Messages : 15
    Points : 37
    Points
    37

    Par défaut

    Bonjour,

    Pour mes réalisations perso j'utilise Java 6. Jusque-là c'est facile !

    Au boulot, nous étions jusqu'à présent contraints d'utiliser le Java 1.4 pour notre framework Java/J2EE. Ce framework est destiné à nous permettre d'intégrer plusieurs gros progiciels dans une même architecture. Le plus gros de ces progiciels était réalisé depuis plusieurs années en Java 1.4. Le discours initial des architects revenait à dire qu'il n'était pas possible d'utiliser le Java 5 à cause de la présence de ce progiciel.

    La situation vient de changer brutalement car lors du développement de notre framework, entièrement fondé sur des outils open source, nous avons eu des soucis avec les outils dont nous avions le plus besoin. En effet, leurs dernières versions (qui contenaient des fonctionnalités essentielles pour nous) exigent au minimum le Java 5.

    Nous avons finalement été forcés de trouver une solution architecturale permettant d'utiliser le Java 5 tout en "isolant" le progiciel principal sur son environnement 1.4.

    Malheureusement, ce changement intervient un peu tard et nous n'allons peut-être pas pouvoir beaucoup profiter des apports du Java 5 (générécité, anotations, autoboxing) . En effet, nous avons déjà livré une première version de notre framework avec ses documentations et nous aurons donc très peu d'occasions de le remanier. Plus les équipes de développement vont utiliser notre framework, plus il sera difficile de "refactorer" les API ou autres éléments du framework qui auraient pu bénéficier des apports du Java 5.

    Petite consolation : les performances. Certains éléments de notre architecture semblent tourner deux fois plus rapidement après passage au Java 5.

  3. #23
    Futur Membre du Club
    Inscrit en
    septembre 2004
    Messages
    19
    Détails du profil
    Informations forums :
    Inscription : septembre 2004
    Messages : 19
    Points : 18
    Points
    18

    Par défaut Java 6

    Je m'étais bloquer au 5 car stable et épouvré sous debian jusqu'à ce qu'un jour je soit obligé d'installer la version 6.
    Et là miracle : le gain de performance est fulgurant!
    Depuis c'est java 6, même si je me limite aux classes et api de la version 5 pour le moment.

  4. #24
    Futur Membre du Club
    Inscrit en
    mars 2007
    Messages
    19
    Détails du profil
    Informations forums :
    Inscription : mars 2007
    Messages : 19
    Points : 19
    Points
    19

    Par défaut

    Il serait intéressant de faire un sondage spécifique sur les versions qu'on utilise au boulot. Car il est clair que de façon personnelle, je ne vois pas trop pourquoi je choisirai autre chose que la version 6.

    Par contre, pour le boulot, pour des raisons d'architectures, on reste bloqué sur la version 1.4 (le fameux problème du mot-clé enum qui empêche de passer en 1.5). On est des centaines de développeurs, avec un système d'information SOA, et ça oblige tout le monde à bouger en même temps, d'où une grosse inertie et un blocage dans un jdk antédiluvien ou presque.

  5. #25
    Invité régulier
    Inscrit en
    novembre 2007
    Messages
    10
    Détails du profil
    Informations forums :
    Inscription : novembre 2007
    Messages : 10
    Points : 9
    Points
    9

    Par défaut

    Au travail : Java 5.
    Personnellement : Java 5.

    Je pense que lorsque la version Java 6 EE sera sortie et éprouvée, je passerai sur Java 6.

  6. #26
    Membre expérimenté Avatar de Haywire
    Homme Profil pro
    Développeur Java
    Inscrit en
    mars 2006
    Messages
    462
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 31
    Localisation : Belgique

    Informations professionnelles :
    Activité : Développeur Java
    Secteur : Finance

    Informations forums :
    Inscription : mars 2006
    Messages : 462
    Points : 554
    Points
    554

    Par défaut

    Chez moi Java 6.
    Au boulot Java 5 mais Java 6 sur le dernier projet en cours.

  7. #27
    Expert Confirmé Sénior Avatar de Uther
    Homme Profil pro
    Inscrit en
    avril 2002
    Messages
    2 960
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : avril 2002
    Messages : 2 960
    Points : 6 047
    Points
    6 047

    Par défaut

    Par contre, pour le boulot, pour des raisons d'architectures, on reste bloqué sur la version 1.4 (le fameux problème du mot-clé enum qui empêche de passer en 1.5). On est des centaines de développeurs, avec un système d'information SOA, et ça oblige tout le monde à bouger en même temps, d'où une grosse inertie et un blocage dans un jdk antédiluvien ou presque.
    Le problème est si gênant que ca? Avec des outils de refactoring ce genre de problème est généralement assez facile a régler.
    En tout cas chez nous la migration a été réalisée assez rapidement.

  8. #28
    Candidat au titre de Membre du Club
    Homme Profil pro Marc
    Inscrit en
    septembre 2007
    Messages
    19
    Détails du profil
    Informations personnelles :
    Nom : Homme Marc
    Localisation : Belgique

    Informations forums :
    Inscription : septembre 2007
    Messages : 19
    Points : 12
    Points
    12

    Par défaut Java 5

    Ben oui ... java 5 !
    C'est le standard de développement à la Défense.
    Soyons déjà heureux que les nouveaux projets soient développés en Java ! Pas mal de collègues maintiennent encore des applics en Power Buidler et dot Net !
    Même si je crie "vive le libre", pouvez pas savoir le mal que l'on se donne pour faire accepter l'utilisation de MySql comme DB sur un serveur Linux au lieu de Oracle ou Sql Server !

  9. #29
    Membre du Club
    Profil pro
    Inscrit en
    octobre 2006
    Messages
    43
    Détails du profil
    Informations personnelles :
    Localisation : Belgique

    Informations forums :
    Inscription : octobre 2006
    Messages : 43
    Points : 42
    Points
    42

    Par défaut

    1.5 et 1.4

    1.5 au boulot en général ca me suffit pour l'instant

    1.4 malheureusement nous utilisons un sofware qui nous oblige à utiliser cette version pour développer des modules spécifiques, mais je suis déja obliger dans certain cas de démarer une jvm 1.5 à partir de cette version 1.4 (via runtime.exec) pour me sortir de certain probléme

  10. #30
    lvr
    lvr est déconnecté
    Membre chevronné Avatar de lvr
    Inscrit en
    avril 2006
    Messages
    727
    Détails du profil
    Informations forums :
    Inscription : avril 2006
    Messages : 727
    Points : 622
    Points
    622

    Par défaut

    Java 5, car Java 6 mal ou pas supporté sur les Macs. Et comme pour moi Java c'est "Develop once, run ...", j'attends un meilleur support Java 6 sur mac pour y passer.

  11. #31
    Invité de passage
    Inscrit en
    juillet 2009
    Messages
    4
    Détails du profil
    Informations forums :
    Inscription : juillet 2009
    Messages : 4
    Points : 3
    Points
    3

    Par défaut Java 6

    Tout d'abord bonjour je suis un nouvel inscris sur ce forum !.

    Je développe sur mac en java 6 ( qui est bien installé sur les mac leopards même s'il n'est pas activé par défaut) et je n'ai pas de problème particulier.
    Quelque problème de couleurs avec swing pour colorer des boutons. (ils apparaissent colorés comme je le veux sous windows mais non sous mac !).


    Je suis venu sous java 6 pour les fonctions desktop qui marchent très bien sous mac et sous xp mais qui sous vista, refusent d'afficher un lien url avec la méthode browse url j'ai laissé un message aujourd'hui la dessus mais aucune reponse (j'espère qu'il y a une solution )

  12. #32
    Membre du Club
    Inscrit en
    mars 2008
    Messages
    109
    Détails du profil
    Informations forums :
    Inscription : mars 2008
    Messages : 109
    Points : 64
    Points
    64

    Par défaut

    java 1.5 au boulot c'est deja pas mal

  13. #33
    Nouveau Membre du Club Avatar de Mr-Mobou
    Profil pro Mohammed Boulaich
    Inscrit en
    juin 2007
    Messages
    58
    Détails du profil
    Informations personnelles :
    Nom : Mohammed Boulaich

    Informations forums :
    Inscription : juin 2007
    Messages : 58
    Points : 38
    Points
    38

    Par défaut

    dans des entreprise java 5 emporte

  14. #34
    Membre habitué
    Profil pro Fares Pascal
    Inscrit en
    juin 2010
    Messages
    104
    Détails du profil
    Informations personnelles :
    Nom : Fares Pascal
    Âge : 51

    Informations forums :
    Inscription : juin 2010
    Messages : 104
    Points : 145
    Points
    145

    Par défaut

    Toujours la dernière sortie

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •