Soutenez-nous
Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3
  1. #1
    Membre régulier Avatar de skysee
    Profil pro
    Inscrit en
    décembre 2002
    Messages
    184
    Détails du profil
    Informations personnelles :
    Localisation : France, Sarthe (Pays de la Loire)

    Informations forums :
    Inscription : décembre 2002
    Messages : 184
    Points : 90
    Points
    90

    Par défaut Modification de php.ini

    Bonjour à tous,
    je commence à regarder du côté de php-gtk en suivant le tuto dispo sur développez.
    Je suis sous ubuntu. J'ai tout bien installer. Mais quand je souhaite éxécuter un script php (ceux fourni en exemple du genre run-test.php) un message apparait :

    Please load the php-gtk2 module in your php.ini

    Bon je vais faire un tour du coté de php.ini, je fais une recherche du fichier, je tombe déjà sur 2 fichier php.ini situé dans /etc/php5/apache2 et dans /etc/php5/cli. Par élimination je me dis que ce doit etre celui situé dans /cli. je l'édite

    Après pas mal de recherche sur divers forum je tombe sur une ligne:

    ; For Unix only.
    ;php-gtk.extensions = php_gtk_combobutton.so, php_gtk_libglade.so, php_gtk_scrollpane.so, php_gtk_spaned.so, php_gtk_sqpane.so

    Je l'ajoute, évidement, ca ne fonctionne toujours pas.....

    je vous montre la fin de mon php.ini situé dans le /cli:
    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    [soap]
    ; Enables or disables WSDL caching feature.
    soap.wsdl_cache_enabled=1
    ; Sets the directory name where SOAP extension will put cache files.
    soap.wsdl_cache_dir="/tmp"
    ; (time to live) Sets the number of second while cached file will be used 
    ; instead of original one.
    soap.wsdl_cache_ttl=86400
     
    ; For Unix only.
    ;php-gtk.extensions = php_gtk_combobutton.so, php_gtk_libglade.so, php_gtk_scrollpane.so, php_gtk_spaned.so, php_gtk_sqpane.so
     
    ; Local Variables:
    ; tab-width: 4
    ; End:

  2. #2
    Rédacteur
    Avatar de gege2061
    Inscrit en
    juin 2004
    Messages
    5 845
    Détails du profil
    Informations personnelles :
    Âge : 30

    Informations forums :
    Inscription : juin 2004
    Messages : 5 845
    Points : 9 971
    Points
    9 971

    Par défaut

    Bonjour,

    Citation Envoyé par skysee Voir le message
    Code :
    1
    2
    ; For Unix only.
    ;php-gtk.extensions = php_gtk_combobutton.so, php_gtk_libglade.so, php_gtk_scrollpane.so, php_gtk_spaned.so, php_gtk_sqpane.so
    Les lignes commençant pas un point-virgules sont des commentaires

    Mais pour charger une extension PHP, il faut ajouter une ligne :

  3. #3
    Membre régulier Avatar de skysee
    Profil pro
    Inscrit en
    décembre 2002
    Messages
    184
    Détails du profil
    Informations personnelles :
    Localisation : France, Sarthe (Pays de la Loire)

    Informations forums :
    Inscription : décembre 2002
    Messages : 184
    Points : 90
    Points
    90

    Par défaut

    Merci beaucoup, ca fonctionne à merveille

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •