+ Répondre à la discussion
Affichage des résultats 1 à 11 sur 11
  1. #1
    Rédacteur/Modérateur
    Avatar de Siguillaume
    Homme Profil pro
    Chef de projet en SSII
    Inscrit en
    août 2007
    Messages
    2 394
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : Chef de projet en SSII
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : août 2007
    Messages : 2 394
    Points : 3 602
    Points
    3 602

    Par défaut Configuration DNS sous Fedora Core 6

    Bonjour à tous!
    [Suite de la configuration sous RedHat: http://www.developpez.net/forums/sho...35#post2551535]

    J'ai un problème sur la configuration de DNS sous Fedora COre 6. Je crois avoir fait tout l'essentiel, mais le problème démeure. Voici le contenu de mes fichiers:
    <J'ai revisé ces fichiers dans un post qui se trouvent plus en bas. Merci>
    * /etc/resolv.conf:
    domain mondomaine
    nameserver 192.168.2.12

    -----------------------------------------------------------
    * /etc/hosts:
    ::1 localhost.localdomain localhost
    192.168.2.12 mondomaine.localdomain mondomaine
    -----------------------------------------------------------------------

    * /etc/named.conf:
    options {
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    };
    controls {
    inet 127.0.0.1 allow { localhost; } keys { rndckey; };
    };

    zone "." IN {
    type hint;
    file "named.ca";
    };

    zone "localhost" IN {
    type master;
    file "localhost.zone";
    allow-update { none; };
    };
    zone "0.0.127.in-addr.arpa." IN {
    type master;
    file "named.local";
    allow-update { none; };
    };
    zone "2.168.192.in-addr.arpa " IN {
    notify no;
    type master;
    file "mondomaine.rev";
    allow-update { none; };
    };
    zone "mondomaine" IN {
    notify no;
    type master;
    file "mondomaine";
    allow-update { none; };
    };
    include "/etc/rndc.key";
    ------------------------------------------------------------------------

    Dans le repertoire /var/named/:

    * named.local:
    $TTL 86400
    @ IN SOA comserveur.mondomaine. root.comserveur.mondomaine. (
    42 ; Serial
    28800 ; Refresh
    14400 ; Retry
    3600000 ; Expire
    86400 ) ; Minimum
    IN NS comserveur.mondomaine.
    1 IN PTR localhost.

    * mondomaine:
    $TTL 86400

    @ IN SOA comserveur.mondomaine. root.comserveur.mondomaine. (
    1997022700 ; Serial
    28800 ; Refresh
    14400 ; Retry
    3600000 ; Expire
    86400 ) ; Minimum


    TXT "Serveur DNS Primaire"

    @ IN NS comserveur.
    @ IN NS comserveur.mondomaine.
    @ IN A 192.168.2.12


    TXT "Les postes"

    localhost IN A 127.0.0.1
    poste1 IN A 192.168.2.2


    TXT "Les sites"

    site1 IN A 192.168.2.12
    site2 IN A 192.168.2.12
    site3 IN A 192.168.2.12
    ------------------------------------------------------------------------------------

    * mondomaine.rev:
    $TTL 86400
    @ IN SOA localhost. root.comserveur.mondomaine. (
    1997022700 ; Serial
    28800 ; Refresh
    14400 ; Retry
    3600000 ; Expire
    86400 ) ; Minimum

    @ IN NS comserveur.mondomaine.
    12 IN PTR comserveur.mondomaine.
    2 IN PTR comserveur.poste1.

    Le test avec nslookup me donne un message d'erreur contenant NXDOMAIN.
    Quand je saisis itelecom dans l'URL du navigateur, j'ai la page de test du navigateur. Ce qui n'est pas le cas avec site1.mondomaine.

    Merci à tous pour votre aide.

  2. #2
    Rédacteur/Modérateur
    Avatar de Siguillaume
    Homme Profil pro
    Chef de projet en SSII
    Inscrit en
    août 2007
    Messages
    2 394
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : Chef de projet en SSII
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : août 2007
    Messages : 2 394
    Points : 3 602
    Points
    3 602

    Par défaut

    Je voudrais aussi ajouter qu'il s'agit d'une configuration en local (pour un intranet composé de machines sous LInux et sous Windows XP).
    Dans le réseau local, l'adresse IP de serveur est 192.168.2.12
    J'avais fait une config similaire à celle-ci sous RedHat et elle marchait passablement bien.
    Merci à tous de m'éclairer!

  3. #3
    Membre éprouvé Avatar de _shuriken_
    Homme Profil pro
    Inscrit en
    mars 2006
    Messages
    455
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30

    Informations professionnelles :
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : mars 2006
    Messages : 455
    Points : 405
    Points
    405

    Par défaut

    Essaie de faire en mode console cette commande Et regarde si named est bien coché dans la liste des services affichés.
    "When you can measure what you are speaking about, and express it in numbers, you know something about it; but when you cannot measure it, when you cannot express it in numbers, your knowledge is of a meager and unsatisfactory kind; it may be the beginning of knowledge, but you have scarcely in your thoughts advanced to the state of Science, whatever the matter may be."

    Lord Kelvin - 1883.

  4. #4
    Rédacteur/Modérateur
    Avatar de Siguillaume
    Homme Profil pro
    Chef de projet en SSII
    Inscrit en
    août 2007
    Messages
    2 394
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : Chef de projet en SSII
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : août 2007
    Messages : 2 394
    Points : 3 602
    Points
    3 602

    Par défaut

    Bonjour!
    Quand je fais cette commande dans la console, on me dit qu'elle n'exite pas. Effectivement, quand j'ai regardé dans les répertoires bin et sbin, cette commande n'y était pas.
    Toutes fois, quand graphiquement, j'accède à la liste des services, named est bien coché et est démarré.
    Une autre inquiétude peu bizarre est que: quand je renomme le /etc/named.conf, named peut toujours rédemarrer. Il me semble alors que /etc/named.conf, n'est pas le vrai fichier de configuration.
    Pour ajouter plus de précisons:
    bind-chroot, system-config-bind et caching-name-server sont installés en plus du bind lui-même.
    Je ne sais plus quels sont les fichiers de configuration de chacun de ses éléments.
    Merci à tous pour votre aide!
    Je ne sais vraiment plus...

  5. #5
    Membre éprouvé Avatar de _shuriken_
    Homme Profil pro
    Inscrit en
    mars 2006
    Messages
    455
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 30

    Informations professionnelles :
    Secteur : High Tech - Opérateur de télécommunications

    Informations forums :
    Inscription : mars 2006
    Messages : 455
    Points : 405
    Points
    405

    Par défaut

    Citation Envoyé par Danjos Voir le message
    Bonjour!
    Quand je fais cette commande dans la console, on me dit qu'elle n'exite pas. Effectivement, quand j'ai regardé dans les répertoires bin et sbin, cette commande n'y était pas.
    Toutes fois, quand graphiquement, j'accède à la liste des services, named est bien coché et est démarré.
    Une autre inquiétude peu bizarre est que: quand je renomme le /etc/named.conf, named peut toujours rédemarrer. Il me semble alors que /etc/named.conf, n'est pas le vrai fichier de configuration.
    Pour ajouter plus de précisons:
    bind-chroot, system-config-bind et caching-name-server sont installés en plus du bind lui-même.
    Je ne sais plus quels sont les fichiers de configuration de chacun de ses éléments.
    Merci à tous pour votre aide!
    Je ne sais vraiment plus...
    Dis, t'a quelle version de Redhat?
    "When you can measure what you are speaking about, and express it in numbers, you know something about it; but when you cannot measure it, when you cannot express it in numbers, your knowledge is of a meager and unsatisfactory kind; it may be the beginning of knowledge, but you have scarcely in your thoughts advanced to the state of Science, whatever the matter may be."

    Lord Kelvin - 1883.

  6. #6
    Rédacteur/Modérateur
    Avatar de Siguillaume
    Homme Profil pro
    Chef de projet en SSII
    Inscrit en
    août 2007
    Messages
    2 394
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : Chef de projet en SSII
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : août 2007
    Messages : 2 394
    Points : 3 602
    Points
    3 602

    Par défaut

    Bonjour!
    En fait, je ne suis plus sur RedHat. VOici pourquoi j'ai crée cette nouvelle discussion. La distibution utlisée ici est Fedora Core 6.

    Je voudrais aussi savoir quel est le nom du journal qui enregistre les événements de demarrage du named. Il semblerait que je peux y trouver le nom du fichier de conf du bind.

    Merci!

  7. #7
    Rédacteur/Modérateur
    Avatar de Siguillaume
    Homme Profil pro
    Chef de projet en SSII
    Inscrit en
    août 2007
    Messages
    2 394
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : Chef de projet en SSII
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : août 2007
    Messages : 2 394
    Points : 3 602
    Points
    3 602

    Par défaut

    Rebonjour!
    J'ai maintenant pu déterminer les fichiers de configuration du named. Voici comment j'ai procédé:
    - j'ai redemarré named
    - j'ai consulté le journal /var/log/messages qui a déclaré le chargement ddu fichier /etc/named.caching-nameserver.conf
    - Ce fichier incluait un autre fichier: /etc/named.rfc1912.zones. C'est ce dernier fichier qui contient les zones du DNS.

    Sur le poste (en local), tout semble bien marché. Mais qu'en je suis en intranet lenom alloué à ma machine tapé bdans l'URL d'un navigateur à l'exterieur ne donne rien.
    Je suis plus explicite sur ce dernier paragraphe:
    -le nom du domaine est: ledomaine
    - quand je tape l'adresse IP du serveur sur un poste à l'exteriieur, ça marche
    - quand je tape ledmaine sur un poste à l'extérieur:message :impossible d'affiicher la page .....

    Voici le contenu des differents fichiers:

    /etc/resolv.conf
    domain ledomaine
    nameserver 127.0.0.1

    /etc/named.caching-nameserver.conf

    options {
    listen-on port 53 { 127.0.0.1; };
    listen-on-v6 port 53 { ::1; };
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    memstatistics-file "/var/named/data/named_mem_stats.txt";
    query-source port 53;
    query-source-v6 port 53;
    allow-query { localhost; };
    };
    logging {
    channel default_debug {
    file "data/named.run";
    severity dynamic;
    };
    };
    view localhost_resolver {
    match-clients { localhost; };
    match-destinations { localhost; };
    recursion yes;
    include "/etc/named.rfc1912.zones";
    };
    -----------------------------------------------------------------------------------
    /etc/named.rfc1912.zones
    zone "." IN {
    type hint;
    file "named.ca";
    };
    zone "localdomain" IN {
    type master;
    file "localdomain.zone";
    allow-update { none; };
    };
    zone "localhost" IN {
    type master;
    file "localhost.zone";
    allow-update { none; };
    };
    zone "0.0.127.in-addr.arpa" IN {
    type master;
    file "named.local";
    allow-update { none; };
    };
    zone "0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa" IN {
    type master;
    file "named.ip6.local";
    allow-update { none; };
    };
    zone "255.in-addr.arpa" IN {
    type master;
    file "named.broadcast";
    allow-update { none; };
    };
    zone "0.in-addr.arpa" IN {
    type master;
    file "named.zero";
    allow-update { none; };
    };
    // Ce que j'ai ajouté
    zone "ledomaine" IN {
    type master;
    file "ledomaine";
    allow-update { none; };
    };
    zone "2.168.192.in-addr-arpa" IN {
    type master;
    file "ledomaine.rev";
    allow-update { none; };
    };
    ----------------------------------------------------------------------------------------------------------------
    Dans le repertoire /var/named/

    named.local
    $TTL 86400
    @ IN SOA localhost. root.comserveur.ledomaine. (
    1997022700 ; Serial
    28800 ; Refresh
    14400 ; Retry
    3600000 ; Expire
    86400 ) ; Minimum
    IN NS comserveur.ledomaine.
    1 IN PTR localhost.
    -------------------------------------------------------------------------------------------------------------
    ledomaine
    $TTL 86400
    @ IN SOA comserveur.ledomaine. root.comserveur.ledomaine. (
    1997022700 ; Serial
    28800 ; Refresh
    14400 ; Retry
    3600000 ; Expire
    86400 ) ; Minimum


    TXT "Serveur DNS primaire"

    @ IN NS comserveur.
    @ IN NS comserveur.ledomaine.

    ledomaine IN A 192.168.2.12
    TXT "Les sites"
    site1 IN A 192.168.2.12
    site2 IN A 192.168.2.12
    site3 IN A 192.168.2.12

    --------------------------------------------------------------------------------------------------
    ledomaine.rev
    $TTL 86400
    @ IN SOA comserveur.ledomaine. root.comserveur.ledomaine. (
    1997022700 ; Serial
    28800 ; Refresh
    14400 ; Retry
    3600000 ; Expire
    86400 ) ; Minimum


    @ IN NS comserveur.ledomaine.
    12 IN NS comserveur.ledomaine.
    -----------------------------------------------------------------------------------------------

    Quand je modifie le contenu du fichier /etc/resolv.conf par
    nameserver 192.168.2.12
    192.168.2.12 est l'adresse IP du serveur sur l'intranet
    Le test avec nslookup ne donne rien: affiche time-out ...

    je crois avoir donné les éléments qu'il faut.

    Merci

  8. #8
    Invité de passage
    Inscrit en
    octobre 2007
    Messages
    3
    Détails du profil
    Informations forums :
    Inscription : octobre 2007
    Messages : 3
    Points : 3
    Points
    3

    Par défaut

    danjos, tes configs semblent en bonnes syntax
    Questions:
    la résolution de tous les noms d' hôtes fonctionne t elle bien sur le serveur?
    (tests avec dig/host)
    as tu bien donné en dns a tes postes clients le 192.168.2.12 ??

    ----------------------------------------------------------------------------
    il faut que tu saches que si tu as le paquet bind-chroot installé alors le named est "chrooté" par défaut.
    faut dc travailler dans le répertoire /etc/named/chroot/ et non ailleurs.
    tu y retrouveras tous les fichiers de config dns.
    -> donc au lieu d'éditer /etc/named.conf il faut éditer /etc/named/chroot/etc/named.conf ; au lieu de travailler tes zones sous /var/named il faut les éditer sous /etc/named/chroot/var/named et ainsi de suite.

    autre possibilité: il ya peut être des paramètres qui empêchent le droit de resoudre les noms par dns.

    pour cela, consulte les fichier /etc/host.conf et /etc/nsswitch.conf
    dans le premier repères la ligne "order hosts bind" et remplace par order "bind hosts" pour prioriser la recherche par dns au lieu que par simple fichier /etc/hosts
    dans le second tu priorises les droits d'acces dns au niveau de la ligne commencant par "hosts: ...."

    derniere possibilité:y a ptetr une regle iptables qui empechent les postes exterieur de communiquer avec le port 53 du server.

    voilà, jesper ke ces infos t'auront aidé.

  9. #9
    Rédacteur/Modérateur
    Avatar de Siguillaume
    Homme Profil pro
    Chef de projet en SSII
    Inscrit en
    août 2007
    Messages
    2 394
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : Chef de projet en SSII
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : août 2007
    Messages : 2 394
    Points : 3 602
    Points
    3 602

    Par défaut

    Bonjour kwakou.
    Citation Envoyé par kwakou Voir le message
    la résolution de tous les noms d' hôtes fonctionne t elle bien sur le serveur?
    (tests avec dig/host)
    J'ai lancé ces deux commandes. Mais quels résultats devraient-elles me donner pour que je m'assure que le DNS fonctionnent bien?

    Citation Envoyé par kwakou Voir le message
    as tu bien donné en dns a tes postes clients le 192.168.2.12 ??
    je crois que non. Comment devrais-je procéder? D'ailleurs je pense que c'est la que se trouvera la solution à mon problème. Mes postes clients sont sous Windows XP.

    Citation Envoyé par kwakou Voir le message
    dans le second tu priorises les droits d'acces dns au niveau de la ligne commencant par "hosts: ...."
    De quoi voulais-tu parler?
    Voici l'extrait du contenu de mon nsswitch.conf qui me semble concerné:
    passwd: files
    shadow: files
    group: files

    #hosts: db files nisplus nis dns
    hosts: files dns

    bootparams: nisplus [NOTFOUND=return] files
    ethers: files
    netmasks: files
    networks: files
    protocols: files
    rpc: files
    services: files
    netgroup: nisplus
    publickey: nisplus
    automount: files nisplus
    aliases: files nisplus
    Que dois-je reviser?

    Citation Envoyé par kwakou Voir le message
    derniere possibilité:y a ptetr une regle iptables qui empechent les postes exterieur de communiquer avec le port 53 du server.
    Qu'est ce que cela veut dire?
    Citation Envoyé par kwakou Voir le message
    voilà, jesper ke ces infos t'auront aidé.
    Oui beaucoup! Et merci pour ton intérêt et pour ton apport!

  10. #10
    Rédacteur/Modérateur
    Avatar de Siguillaume
    Homme Profil pro
    Chef de projet en SSII
    Inscrit en
    août 2007
    Messages
    2 394
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : Chef de projet en SSII
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : août 2007
    Messages : 2 394
    Points : 3 602
    Points
    3 602

    Par défaut

    Bonjour!
    Je pense que je progresse. En effet, le DNS semble fonctionne à moitié. Le problème qui me est au niveau de son intégration avec le serveur Apache. J'ai configuré des VirtualHost dans le httpd.conf qui me donne pas les resultats requis. Ce contenu est dans la discussion http://www.developpez.net/forums/sho...d.php?t=423112

    merci pour vote intérêt!

  11. #11
    Rédacteur/Modérateur
    Avatar de Siguillaume
    Homme Profil pro
    Chef de projet en SSII
    Inscrit en
    août 2007
    Messages
    2 394
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : Côte d'Ivoire

    Informations professionnelles :
    Activité : Chef de projet en SSII
    Secteur : High Tech - Produits et services télécom et Internet

    Informations forums :
    Inscription : août 2007
    Messages : 2 394
    Points : 3 602
    Points
    3 602

    Par défaut Le problème persiste

    Bonjour!

    http://ledomaine me donne la page du site1, alors que www.site2.ledomaine me dit impossible d'afficher la page.
    J'ai regardé dans les journaux d'erreurs d'Apache et il me parle d'un fichier favicon.ico qui est introuvable. De quoi s'agit-il?

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •