+ Répondre à la discussion
Affichage des résultats 1 à 7 sur 7
  1. #1
    Membre actif
    Inscrit en
    mars 2006
    Messages
    293
    Détails du profil
    Informations forums :
    Inscription : mars 2006
    Messages : 293
    Points : 152
    Points
    152

    Par défaut ¨RSèDémarrage replication server

    Je travail sur ma répli, et en voulant rédémarrer le rep server cela ne passe pas malgré avoir utilisé la méthodologie écrite par Fadace truncate table logins et roles et bcp out in dedans.
    J'ai ce méssage
    Code :
    1
    2
    3
    4
    5
    I. 2007/07/04 15:56:00. Server using Open Server version Sybase Server-Library/12.5.1/P-EBF11759-11758 ESD #2/DRV.12.5.1.0/SPARC/Solaris 2.8 Native Threads/BUILD1251-002/OPT/Tue Mar  9 22:02:04 2004
    I. 2007/07/04 15:56:00. Server using Open Client version Sybase Client-Library/12.5.1/P-EBF11758 ESD #2/DRV.12.5.1.0/SPARC/Solaris 2.8 Native Threads/BUILD1251-002/OPT/Tue Mar  9 20:37:42 2004
    F. 2007/07/04 15:56:00. FATAL ERROR #1030 GLOBAL RS(GLOBAL RS) - /errhand.c(730)
            Open Server error: Error: 16029, State: 0, Severity 20 -- 'Failed to start any network listeners'.
    T. 2007/07/04 15:56:00. (-1): Exiting due to a fatal error
    Je vais aller voir chez sybase pour le num d'erreur, mais avant d'open un case qq'un a eu ce genre de chose ???

  2. #2
    Membre Expert

    Inscrit en
    janvier 2006
    Messages
    1 307
    Détails du profil
    Informations personnelles :
    Âge : 55

    Informations forums :
    Inscription : janvier 2006
    Messages : 1 307
    Points : 1 750
    Points
    1 750

    Par défaut

    "failed to start any network listeners" veut dire qu'il y a déjà un process qui écoute sur le port qui est défini pour le serveur que tu essaye de démarrer, ou alors que le fichier interface est incorrecte (par example que le hostname est faux).

    Est-ce que le repserver est bien arrêté lorsque tu le démarre?

    Michael

  3. #3
    Membre actif
    Inscrit en
    mars 2006
    Messages
    293
    Détails du profil
    Informations forums :
    Inscription : mars 2006
    Messages : 293
    Points : 152
    Points
    152

    Par défaut

    Tu veux dire ma base RSSD ?? si c'est cela elle est éffectivement démarré sinon le rep en tant que tel impossible de le lancer

  4. #4
    Membre Expert

    Inscrit en
    janvier 2006
    Messages
    1 307
    Détails du profil
    Informations personnelles :
    Âge : 55

    Informations forums :
    Inscription : janvier 2006
    Messages : 1 307
    Points : 1 750
    Points
    1 750

    Par défaut

    Non - le serveur de répli.

    Je répéte - ce message vient de la couche réseaux si l'addresse que le serveur Sybase (ASE, rep, backupserver, etc) veut utiliser n'est pas disponible (p.ex. déjà utilisé par un autre process, address IP fausse, etc)

    Fais un
    Code :
    1
    2
     
    netstat -a -n | grep <no de port>
    pour voir si le port d'écoute utilisé par ton repserver est libre...

    Michael

  5. #5
    Membre actif
    Inscrit en
    mars 2006
    Messages
    293
    Détails du profil
    Informations forums :
    Inscription : mars 2006
    Messages : 293
    Points : 152
    Points
    152

    Par défaut

    Ben j'ai vérifié avec ton netstat et il ne trouve rien donc libre visiblement j'ai de plus regrdé le fichier interfaces et pas d'incohérences non plus.je fais mon
    Code :
    startserver -f RUN_toto_REP
    et là rien ne se passe outre le méssage d'erreur :
    Code :
    1
    2
    3
    4
    5
    6
    E. 2007/07/04 18:27:08. ERROR #31083 GLOBAL RS(GLOBAL RS) - /cfginit.c(2042)
            Cannot connect to RSSD server. ct_connect failed.
    E. 2007/07/04 18:27:08. ERROR #1027 GLOBAL RS(GLOBAL RS) - /cfginit.c(2042)
            Open Client Client-Library error: Error: 84083972, Severity 5 -- 'ct_connect(): network packet layer: internal net library error: Net-Lib protocol driver call to connect two endpoints failed'.
    F. 2007/07/04 18:27:08. FATAL ERROR #18028 GLOBAL RS(GLOBAL RS) - servmain.c(304)
            Initialization failed. Server is shutting down.
    Me gonfle ça ....

  6. #6
    Membre Expert

    Inscrit en
    janvier 2006
    Messages
    1 307
    Détails du profil
    Informations personnelles :
    Âge : 55

    Informations forums :
    Inscription : janvier 2006
    Messages : 1 307
    Points : 1 750
    Points
    1 750

    Par défaut

    Bon - ce coup ci c'est que le serveur avec la RSSD n'est pas accessible. Problème de fichier interface qui ne pointe pas au bon endroit, ou problème que le dataserver est arrêté, ou... ?

    Michael

  7. #7
    Membre actif
    Inscrit en
    mars 2006
    Messages
    293
    Détails du profil
    Informations forums :
    Inscription : mars 2006
    Messages : 293
    Points : 152
    Points
    152

    Par défaut

    thx mickael, je te dirais ;-)

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •