1. #1
    Membre régulier
    Profil pro
    Inscrit en
    juin 2007
    Messages
    123
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2007
    Messages : 123
    Points : 100
    Points
    100

    Par défaut Comment configurer Eclipse et le CDT

    Bonjour à vous !

    si cette question a déjà été posé, merci de m'orienter au bon endroit, mais je n'ai pas réussi à trouver une réponse sur ce forum alors voilà mon problème :

    J'ai installé Eclipse. Avec je fais du Latex, du Java et j'aimerais faire du C et C++. J'ai donc installé le plugin CDT avec le système de mise à jour.

    Mais j'imagine que je dois installer un compilateur C.
    1) Lequel installer ?

    Ensuite, comment configurer CDT pour qu'il utilise ce compilateur ? Quel est la ligne de commande à rentrer, et où ?

    Merci d'avance pour vos réponses.
    Pour ceux qui veulent bronzer avec autre chose que des tubes cathodiques : quelques idées de balades !

  2. #2
    Membre éclairé
    Avatar de mamelouk
    Profil pro
    Inscrit en
    mai 2005
    Messages
    867
    Détails du profil
    Informations personnelles :
    Localisation : France, Rhône (Rhône Alpes)

    Informations forums :
    Inscription : mai 2005
    Messages : 867
    Points : 810
    Points
    810

    Par défaut

    Bonjour,

    Tu es sous Windows, Linux ou Mac ? Tu utilises quelle version d'Eclipse et/ou de CDT ?

    Débugger du code est deux fois plus dur que d'en écrire.
    Donc, si vous écrivez votre code aussi intelligemment que vous le pouvez, vous n'etes, par définition, pas assez intelligent pour le débugger.

  3. #3
    Membre régulier
    Profil pro
    Inscrit en
    juin 2007
    Messages
    123
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2007
    Messages : 123
    Points : 100
    Points
    100

    Par défaut

    Merci de m'avoir répondu.

    - Windows XP
    - Eclipse Version: 3.2.2
    - CDT : 3.1.2

    Mais je crois que mon problème venait du fait que rien n'était dans mon PATH. Ca peut être l'origine du problème ?

    Si j'utilise cette méthode : http://max.berger.name/howto/cdt/index.jsp

    Je peux peut-être m'en sortir non ?
    (j'ai eu du mal à trouver cette page mais je ne sais pas si la procédure décrite fonctionne...)
    Pour ceux qui veulent bronzer avec autre chose que des tubes cathodiques : quelques idées de balades !

  4. #4
    Membre éclairé
    Avatar de mamelouk
    Profil pro
    Inscrit en
    mai 2005
    Messages
    867
    Détails du profil
    Informations personnelles :
    Localisation : France, Rhône (Rhône Alpes)

    Informations forums :
    Inscription : mai 2005
    Messages : 867
    Points : 810
    Points
    810

    Par défaut

    Ca m'a l'air d'etre un bon tutoriel en effet.

    Si tu as des problèmes en le suivant, décrit de manière précise ton problème, pour espérer obtenir une réponse. (par ex. tu dis "mon problème venait du fait que rien n'était dans mon PATH", mais de quel problème tu parle ?)

    De manière générale, lis ceci dès que tu auras le temps

    Débugger du code est deux fois plus dur que d'en écrire.
    Donc, si vous écrivez votre code aussi intelligemment que vous le pouvez, vous n'etes, par définition, pas assez intelligent pour le débugger.

  5. #5
    Membre régulier
    Profil pro
    Inscrit en
    juin 2007
    Messages
    123
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2007
    Messages : 123
    Points : 100
    Points
    100

    Par défaut

    Ah zut je croyais avoir parlé du problème avant, désolé.
    Bon je suis le tutoriel, et je reviens après !
    Pour ceux qui veulent bronzer avec autre chose que des tubes cathodiques : quelques idées de balades !

  6. #6
    Membre régulier
    Profil pro
    Inscrit en
    juin 2007
    Messages
    123
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2007
    Messages : 123
    Points : 100
    Points
    100

    Par défaut

    Bon ben j'ai toujours un problème :
    - j'ai installé MSYS
    - MinGW
    - Eclipse
    - le plugin CDT (pas le SDK, l'autre)

    Tout est dans le PATH (j'ai testé en ligne de commande). En ligne de commande ça compile mais avec Eclipse, après avoir créé un projet, j'essaie de compiler et j'ai ça :
    Error launching builder (make -k all )
    (Exec error:Launching failed)
    Alors je n'ai plus aucune idée...
    Pour ceux qui veulent bronzer avec autre chose que des tubes cathodiques : quelques idées de balades !

  7. #7
    Membre régulier
    Profil pro
    Inscrit en
    juin 2007
    Messages
    123
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations forums :
    Inscription : juin 2007
    Messages : 123
    Points : 100
    Points
    100

    Par défaut

    Bon ben j'ai trouvé : après avoir tout configuré et redémarré l'ordinateur. Je sais pas pourquoi, mais c'est mieux pour qu'Eclipse comprenne que le PATH a changé !

    Je regrette d'avoir autant galéré pour une solution aussi bête. Dommage qu'il n'y ait que toi qui m'aies aidé mamelouk.
    Pour ceux qui veulent bronzer avec autre chose que des tubes cathodiques : quelques idées de balades !

  8. #8
    Membre éclairé
    Homme Profil pro
    Développeur
    Inscrit en
    juin 2006
    Messages
    645
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 31
    Localisation : France, Paris (Île de France)

    Informations professionnelles :
    Activité : Développeur

    Informations forums :
    Inscription : juin 2006
    Messages : 645
    Points : 694
    Points
    694

    Par défaut

    Je réponds un peu après la bataille, mais ça pourra servir pour quelqu'un d'autre.

    Windows lance les applications en faisait un fork et en lui passant l'environnement courant (qui inclut donc le PATH). Ainsi, lorsqu'on change la valeur du PATH, celle-ci n'est pas propagée vers les applications déjà ouvertes, il faut redémarrer celles-ci pour qu'elles prennent en compte la nouvelle valeur.

    A noter que l'on tombe (moi le premier) souvent dans le piège lorsqu'on lance une invite de commande depuis l'explorateur, après avoir changé le PATH. Le fork est fait depuis l'explorateur... qui n'a pas été redémarré : l'invite de commande en question possède donc l'environnement d'avant qu'on change le PATH. Et de fait, il est normal que ça ne fonctionne pas avant d'avoir redémarré.
    « Se demander si un ordinateur peut penser est aussi intéressant que de se demander si un sous-marin peut nager. »
    -- Edsger Dijkstra

+ Répondre à la discussion
Cette discussion est résolue.

Discussions similaires

  1. [JIRA / Mylyn] Comment configurer Eclipse ?
    Par ilhamishka dans le forum Eclipse
    Réponses: 0
    Dernier message: 23/02/2011, 17h36
  2. Comment configurer Eclipse pour JSF ?
    Par mat.net dans le forum Eclipse Java
    Réponses: 0
    Dernier message: 30/11/2009, 15h41
  3. Comment configurer Eclipse pour travailler avec xml ?
    Par lotfi.gaaloul dans le forum Eclipse
    Réponses: 1
    Dernier message: 09/09/2009, 22h28
  4. Configurer Eclipse CDT sous Windows
    Par mamelouk dans le forum Eclipse C & C++
    Réponses: 0
    Dernier message: 21/11/2007, 17h48
  5. Comment Configurer Eclipse pour utiliser SWT
    Par brahim_SUPTEM dans le forum SWT/JFace
    Réponses: 1
    Dernier message: 18/05/2007, 19h31

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo