Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 4 sur 4
  1. #1
    Membre du Club
    Inscrit en
    avril 2003
    Messages
    216
    Détails du profil
    Informations forums :
    Inscription : avril 2003
    Messages : 216
    Points : 40
    Points
    40

    Par défaut gdb : No symbol table is loaded

    Bonjour,

    Je vien d'apprendre à utiliser gdb sur un petit fichier c++ et tout fonctionnait parfaitement.
    Maintenant j'aimerais bien débugger un plus gros programme qui contient plusieur fichiers mais je n'y arrive pas.

    J'ai esseyé de placer un breakpoint à la ligne 120 d'un fichier mais voici l'erreur que j'ai:
    (gdb) b ./src/fichier/ouvrir.cpp:120
    No symbol table is loaded. Use the "file" command.

    Et quand j'utilise la commande file :
    (gdb) file ./src/fichier/ouvrir.cpp
    "/home/zenux/wxrad/src/fichier/ouvrir.cpp": not in executable format: Format de fichier non reconnu

    Savez-vous m'aider ? Je tien à signaler que j'utilise bien l'option -g pour compiler chaque fichier de mon programme.

    Merci...

  2. #2
    Rédacteur
    Avatar de gege2061
    Inscrit en
    juin 2004
    Messages
    5 845
    Détails du profil
    Informations personnelles :
    Âge : 31

    Informations forums :
    Inscription : juin 2004
    Messages : 5 845
    Points : 10 506
    Points
    10 506

    Par défaut

    Bonjour,

    Citation Envoyé par casafa
    (gdb) b ./src/fichier/ouvrir.cpp:120
    No symbol table is loaded. Use the "file" command.
    Tu utilise bien l'option -g de gcc pour avoir les options de débugage ?

  3. #3
    Membre du Club
    Inscrit en
    avril 2003
    Messages
    216
    Détails du profil
    Informations forums :
    Inscription : avril 2003
    Messages : 216
    Points : 40
    Points
    40

    Par défaut

    Oui, j'utilise bien l'option -g (je l'ait précisé en bas de mon premier message) mais pas avec gcc mais g++.

  4. #4
    Membre du Club
    Inscrit en
    avril 2003
    Messages
    216
    Détails du profil
    Informations forums :
    Inscription : avril 2003
    Messages : 216
    Points : 40
    Points
    40

    Par défaut

    C'est bon, j'ai trouvé d'où venait l'erreur :
    A la compilation j'utilise bien l'option -g mais au linkage j'utilisait l'option -s, ce qui annulait le -g !

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •