Soutenez-nous
Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 6 sur 6
  1. #1
    Invité régulier
    Inscrit en
    septembre 2005
    Messages
    91
    Détails du profil
    Informations forums :
    Inscription : septembre 2005
    Messages : 91
    Points : 8
    Points
    8

    Par défaut Fatal error: Call to a member function getActive() on a non-object

    Bonjour,
    depuis deux jours je me démène avec une erreur sur mon site web Joomla.
    j'ai l'erreur suivante :
    Fatal error: Call to a member function getActive() on a non-object in E:\inetpub\vhosts\cjcm.ca\httpdocs\includes\application.php on line 292
    quand j'ouvre le fichier à la ligne 292 , j'ai le code suivant :
    Code :
    $item = $menu->getActive();
    j'ai cherché sur le net , quelques mentions à ce problème mais rien de concret.
    Pour info, il n'y a eu aucun changement majeur avant la panne, juste quelques textes modifiés.
    Je vous remercie de votre aide

  2. #2
    Membre du Club
    Homme Profil pro
    Développeur informatique
    Inscrit en
    février 2013
    Messages
    27
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 33
    Localisation : France

    Informations professionnelles :
    Activité : Développeur informatique
    Secteur : Services de proximité

    Informations forums :
    Inscription : février 2013
    Messages : 27
    Points : 56
    Points
    56

    Par défaut

    Bonjour,

    Ta variable $menu n'est pas un objet, il faudrait que tu vérifie son affectation.

  3. #3
    Invité régulier
    Inscrit en
    septembre 2005
    Messages
    91
    Détails du profil
    Informations forums :
    Inscription : septembre 2005
    Messages : 91
    Points : 8
    Points
    8

    Par défaut

    C'est du code joomla, je n'ai jamais modifié l'affectation de cette variable

  4. #4
    Futur Membre du Club
    Inscrit en
    septembre 2008
    Messages
    65
    Détails du profil
    Informations forums :
    Inscription : septembre 2008
    Messages : 65
    Points : 16
    Points
    16

    Par défaut

    il n'y a eu aucun changement majeur avant la panne, juste quelques textes modifiés.
    en front ou en backend ? avec quel utilisateur ?

    peut-être que les changements ont été opérés par un utilisateur à droits différents et que maintenant les articles ne sont plus en concordances de droits...

    une install d'un composant ? modif template ?...

  5. #5
    Invité régulier
    Inscrit en
    septembre 2005
    Messages
    91
    Détails du profil
    Informations forums :
    Inscription : septembre 2005
    Messages : 91
    Points : 8
    Points
    8

    Par défaut

    Bonjour,
    les modifs ont été faites par un seul compte en backend.
    J'ai depublié tous les modules, j'ai changé de template et rien .
    Je me tire les cheveux depuis une semaine sur cette affaire, je n'y comprend plus rien.

  6. #6
    Futur Membre du Club
    Inscrit en
    septembre 2008
    Messages
    65
    Détails du profil
    Informations forums :
    Inscription : septembre 2008
    Messages : 65
    Points : 16
    Points
    16

    Par défaut

    désolé pour le temps, je m'étais désabonné du sujet par erreur...

    où en est la situation ?

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •