Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 6 sur 6
  1. #1
    Nouveau Membre du Club
    Inscrit en
    novembre 2008
    Messages
    255
    Détails du profil
    Informations forums :
    Inscription : novembre 2008
    Messages : 255
    Points : 38
    Points
    38

    Par défaut [KVM] relier carte wifi intégrée à VM

    Bonjour,
    Je virtualise un backtrack à l'aide de KVM (sous Kubuntu pour info).
    Je souhaite pouvoir faire fonctionner ma carte wifi avec backtrack, mais il faut vraiment que backtrack reconnaisse le périphérique en tant que carte wifi. Je suis un peu perdu dans les paramètres.

    Pouvez-vous m'indiquer comment faire s'il vous plait ?

    Merci énormément

  2. #2
    Membre habitué
    Profil pro
    Technicien Systèmes d'Information
    Inscrit en
    juillet 2009
    Messages
    144
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Technicien Systèmes d'Information

    Informations forums :
    Inscription : juillet 2009
    Messages : 144
    Points : 121
    Points
    121

    Par défaut

    Bonjour,

    Bon, je ne connais pas KVM, mais il me semble qu'une VM ne voit pas le périphérique wifi de l'hôte physique mais voit un réseau Ethernet classique "virtualisé". Dans ce cas là, il suffit de démarrer les services réseau sur la VM via une commande sudo -s /etc/init.d/networking start suivi si besoin de la commande ifconfig eth0 up pour activer la carte réseau.
    Peut-être est ce possible aussi d'ajouter un périphérique USB wifi directement à la VM, comme on le ferait sur VirtualBox.

  3. #3
    Modérateur
    Avatar de sevyc64
    Homme Profil pro Yves
    Développeur informatique
    Inscrit en
    janvier 2007
    Messages
    6 789
    Détails du profil
    Informations personnelles :
    Nom : Homme Yves
    Âge : 41
    Localisation : France, Pyrénées Atlantiques (Aquitaine)

    Informations professionnelles :
    Activité : Développeur informatique

    Informations forums :
    Inscription : janvier 2007
    Messages : 6 789
    Points : 16 151
    Points
    16 151

    Par défaut

    pour qu'une carte wifi soit reconnue dans une vm, outre les drivers nécessaire dans la vm, il faut d'abords qu'elle soit reconnue et fonctionne correctement sur la machine hôte.

    Ensuite pour configurer dans backtrack, je ne serais d'aucun secours
    --- Sevyc64 ---

    Parce que le partage est notre force, la connaissance sera notre victoire

  4. #4
    Nouveau Membre du Club
    Inscrit en
    novembre 2008
    Messages
    255
    Détails du profil
    Informations forums :
    Inscription : novembre 2008
    Messages : 255
    Points : 38
    Points
    38

    Par défaut

    Merci pour vos réponses

    La carte wifi fonctionne bien sur la machine hôte, mais non, cela n'a pas d'importance, puisque j'utilise un hyperviseur complétement différent que virtualbox.

    Visiblement vous ne connaissez pas KMV, c'est un hyperviseur de type "barre-métal", et non pas "host-based" comme virtualbox ou vmware Workstation. La couche virtualisation est installée directement sur le Hardware, et non pas sur l'OS hôte comme les deux cités précédemment.

    En fait, avec ça je fais de la para-virtualisation ou de la virtualisation assistée matérielle, qui permet à l'hyperviseur KVM d'interagir directement avec le CPU (hypercalls...). Les périphériques ne sont pas simulés, on les utilise réellement.

    Mon problème, c'est que je n'arrive pas à dire à KVM de faire un pont sur la carte wifi pour ma machine virtuelle. Pour administrer KVM j'utilise Virtual Machine Manager. J'ai essayé d'ajouter une carte pci à ma machine virtuelle, pointant sur ma carte wifi, mais j'ai une erreur qui me dit : "device 'pci-assign' could not be initialized". D'après google, d'autres ont eu cette erreur mais vraiment, je ne comprends pas ou est le problème.

    Est ce que quelqu'un connait ?
    Merci

  5. #5
    Rédacteur
    Avatar de CedrX
    Inscrit en
    avril 2007
    Messages
    1 110
    Détails du profil
    Informations forums :
    Inscription : avril 2007
    Messages : 1 110
    Points : 1 368
    Points
    1 368

    Par défaut

    Il me semble qu'il faut cacher le périphérique pci au système hôte avant même de pouvoir l'assigner à une vm.
    J'avais réussi à faire ça avec XEN.
    J'avoue ne pas avoir essayé avec qemu
    Tu trouveras peut être ton bonheur ici:
    http://www.linux-kvm.org/page/How_to...th_VT-d_in_KVM

    Et dernièrement il y a eu ça de nouveau aussi au niveau de qemu/kvm:

    http://www.linux-kvm.com/content/pci...-linux-36-vfio

  6. #6
    Nouveau Membre du Club
    Inscrit en
    novembre 2008
    Messages
    255
    Détails du profil
    Informations forums :
    Inscription : novembre 2008
    Messages : 255
    Points : 38
    Points
    38

    Par défaut

    Merci, je note ça dans un coin.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •