+ Répondre à la discussion
Affichage des résultats 1 à 3 sur 3
  1. #1
    Invité de passage
    Homme Profil pro
    Étudiant
    Inscrit en
    décembre 2012
    Messages
    27
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : décembre 2012
    Messages : 27
    Points : 2
    Points
    2

    Par défaut Erreur dans web.xml

    Bonsoir !
    Je suis en train d'apprendre JEE et j'ai un petit problème au niveau du web.xml de mon application (je travaille sous EclipseEE et Tomcat).

    J'ai en effet une croix rouge au niveau du <multipart-config>

    Voici la structure englobant cette balise:

    Code :
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
     
    <servlet>
    <servlet-name>Upload</servlet-name>
    <servlet-class>indexeur.servlets.Upload</servlet-class>
    <init-param>
    <param-name>chemin</param-name>
    <param-value>/fichiers/</param-value>
    </init-param>
    <multipart-config>  <!-- Erreur ici 'X'-->
    <location>c:/fichiers</location>
    <max-file-size>10485760</max-file-size> 
    <max-request-size>52428800</max-request-size> 
    <file-size-threshold>1048576</file-size-threshold>
    </multipart-config>
    </servlet>

    Et voici le message d'erreur:

    cvc-complex-type.2.4.a: Invalid content was found starting with element 'multipart-config'. One of '{"http://
    java.sun.com/xml/ns/javaee":init-param, "http://java.sun.com/xml/ns/javaee":load-on-startup, "http://
    java.sun.com/xml/ns/javaee":run-as, "http://java.sun.com/xml/ns/javaee":security-role-ref}' is expected.

    Savez-vous de quoi ça vient ? Et enfin si ça vient d'une erreur toute bête du genre oublié une balise ou ordre, pouvez-vous me dire sur quel référence je peux me baser sur internet car malgré mes recherches ça fait 1h que je suis dessus.

    Merci à vous !

  2. #2
    Expert Confirmé
    Avatar de olivier.pitton
    Homme Profil pro
    Développeur Java
    Inscrit en
    juin 2012
    Messages
    355
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 26
    Localisation : France, Hauts de Seine (Île de France)

    Informations professionnelles :
    Activité : Développeur Java
    Secteur : High Tech - Éditeur de logiciels

    Informations forums :
    Inscription : juin 2012
    Messages : 355
    Points : 2 844
    Points
    2 844

    Par défaut

    Plop,

    As-tu spécifié que tu utilisais les Servlets 3.0 dans le web.xml ?

    L'en-tête est :

    Code :
    1
    2
    3
    4
    5
    6
    <web-app xmlns="http://java.sun.com/xml/ns/javaee"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_3_0.xsd"
          version="3.0">
     
    </web-app>
    Voici un petit tutorial sur l'upload avec les Servlets 3.0 : ici

  3. #3
    Invité de passage
    Homme Profil pro
    Étudiant
    Inscrit en
    décembre 2012
    Messages
    27
    Détails du profil
    Informations personnelles :
    Sexe : Homme

    Informations professionnelles :
    Activité : Étudiant

    Informations forums :
    Inscription : décembre 2012
    Messages : 27
    Points : 2
    Points
    2

    Par défaut

    Merci ça marche maintenant ! J'étais en 2.5 :/

+ Répondre à la discussion
Cette discussion est résolue.

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •