Publicité
+ Répondre à la discussion
Affichage des résultats 1 à 20 sur 20
  1. #1

    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    10
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : janvier 2013
    Messages : 10
    Points : -2
    Points
    -2

    Par défaut configuration bind apache

    bonjour à tous.

    J'ai actuellement un serveur dédié chez ovh et tout fonctionne las bas ^^ ( apache, redirection de domaine .. )

    j'ai monter chez moi , un pc avec une distrib débian 6 afin de faire mes test sans risque.
    l'ip de ce pc est 192.168.1.142.

    j'ai fais toutes la configuration apache, mysql .. tout fonctionne.
    j'ai même mis en place un serveur samba, et j'ai créer et activer un fichier site dans /etc/apache2/sites-available .. tout fonctionne quand je tape le nom du pc dans l'explorateur.

    Le problème c'est bind :

    j’ai suivi scrupuleusement les tutoriels pour avoir un nom de domaine “ factice” sur mon réseau local personnel ( intranet )

    malheureusement, rien n’y fait : malgré les test avec la commande nslookup qui aboutissent bien , mon domaine ne marche pas ( je le tape dans l’explorateur mais j’arrive sur une page : Adresse introuvable ....

    j’ espère ne pas vous embêter, mais j’ai fais un récapitulatif de ma configuration :


    contenu de /etc/resolv.conf

    nameserver 192.168.1.142
    domain bureau.local

    contenu de /etc/bind/named.conf.local

    //
    // Do any local configuration here
    //

    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";

    zone "bureau.local" {
    type master;
    file "/etc/bind/db.bureau.local";
    };
    zone "1.168.192.in-addr.arpa" {
    type master;
    file "/etc/bind/db.1.168.192";
    };


    contenu de /etc/bind/db.bureau.local

    $ORIGIN bureau.local.
    $TTL 604800
    @ IN SOA wordpress.bureau.local. blots.free.fr. (
    4 ; Serial
    604800 ; Refresh
    86400 ; Retry
    2419200 ; Expire
    604800 ) ; Negative Cache TTL
    ;
    @ IN NS wordpress.bureau.local.
    ;
    @ IN MX 10 mail.bureau.local.
    ;
    dns IN A 192.168.1.142
    wordpress IN A 192.168.1.142
    index IN A 192.168.1.142
    mail IN A 192.168.1.142

    contenu de /etc/bind/db.1.168.192

    $ORIGIN 1.168.192.in-addr.arpa.
    $TTL 604800

    @ IN SOA wordpress.bureau.local. blots.free.fr. (
    3 ; Serial
    604800 ; Refresh
    86400 ; Retry
    2419200 ; Expire
    604800 ) ; Negative Cache TTL
    ;
    @ IN NS wordpress.bureau.local.
    ;
    @ IN MX 10 mail.bureau.local.
    ;
    142 IN PTR dns.bureau.local.
    142 IN PTR wordpress.bureau.local.
    142 IN PTR index.bureau.local.
    142 IN PTR mail.bureau.local.


    contenu de /etc/bind/named.conf.options

    ptions {
    directory "/var/cache/bind";

    // If there is a firewall between you and nameservers you want
    // to talk to, you may need to fix the firewall to allow multiple
    // ports to talk. See http://www.kb.cert.org/vuls/id/800113

    // If your ISP provided one or more IP addresses for stable
    // nameservers, you probably want to use them as forwarders.
    // Uncomment the following block, and insert the addresses replacing
    // the all-0's placeholder.

    // forwarders {
    // 0.0.0.0;
    // };

    auth-nxdomain no; # conform to RFC1035
    listen-on-v6 { any; };
    };

    tous mes services sont bien redémarrer avec :

    /etc/init.d/bind restart


    je devrai arriver sur ma page par défaut de apache non ?
    j'ai dû oublier de faire quelques chose mais je ne sais pas quoi .


    si vous pouviez m’éclairer car malgré la lecture de plusieurs tutoriel qui se ressemble tous, je n’arrive toujours pas à faire fonctionner ce bind.

  2. #2
    Expert Confirmé Sénior
    Homme Profil pro Laurent Willems
    MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!
    Inscrit en
    septembre 2002
    Messages
    3 176
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Willems
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 176
    Points : 5 815
    Points
    5 815

    Par défaut

    Salut,

    Où se trouve le navigateur depuis lequel tu fais tes tests? Sur le serveur même sur un autre poste? S'il s'agit d'un autre poste, as-tu également ajouté le serveur dns dans la configuration?

    Que renvoie la commande depuis le serveur dns?

    dig wordpress.bureau.local

    Quel nom de domaine as-tu testé?
    As-tu défini de virtual host pour le(s) hostname(s) que tu souhaites testé au niveau de ton serveur apache? quelle est la configuration de ce virtualhost?
    Alea Jacta Test!

  3. #3
    Modérateur
    Avatar de becket
    Profil pro Frédéric Brugmans
    Informaticien multitâches
    Inscrit en
    février 2005
    Messages
    1 184
    Détails du profil
    Informations personnelles :
    Nom : Frédéric Brugmans

    Informations professionnelles :
    Activité : Informaticien multitâches
    Secteur : Service public

    Informations forums :
    Inscription : février 2005
    Messages : 1 184
    Points : 2 453
    Points
    2 453

    Par défaut

    Que renvoie :

    Le pc sur lequel tu fais le test est bien configuré pour utiliser ton serveur dns fraichement crée ?

  4. #4

    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    10
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : janvier 2013
    Messages : 10
    Points : -2
    Points
    -2

    Par défaut

    bonsoir
    je suis content d'avoir des reponses ce soir

    tout d'abord je fais mes test depuis mon pc perso sous windows 7( 192.168.1.10 )

    en réponse à la commande dig wordpress.bureau.local :

    ; <<>> DiG 9.7.3 <<>> wordpress.bureau.local
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32689
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;wordpress.bureau.local. IN A

    ;; ANSWER SECTION:
    wordpress.bureau.local. 604800 IN A 192.168.1.142

    ;; AUTHORITY SECTION:
    bureau.local. 604800 IN NS wordpress.bureau.local.

    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.142#53(192.168.1.142)
    ;; WHEN: Wed Jan 9 20:20:06 2013
    ;; MSG SIZE rcvd: 70


    pour les virtual host sur le serveur j'ai bien fais ma configuration dans /etc/apache2/sites-available
    j'y ai créer un fichier wordpress.bureau.local et voici son contenu :

    <VirtualHost *:80>
    # Adresse email à contacter en cas de problemes
    ServerAdmin blots@free.fr
    # Nom de domaine avec les www
    ServerName www.wordpress.bureau.local
    # Les différents alias du site, généralement le NDD sans les www
    ServerAlias wordpress.bureau.local
    # La où sont stocké les données du site
    DocumentRoot /home/wordpress/www
    <Directory />
    # Des options : ici suivre les liens symboliques
    Options FollowSymLinks
    # Autoriser l'override, autrement dit les .htaccess
    AllowOverride All
    </Directory>
    <Directory /home/wordpress/www>
    # Encore des options : multiviews peut être pratique
    # Si on essaye d'accéder à site.com/index
    # Et que index n'existe pas, le serveur va rechercher index.*
    # Autrement dit : index.php, index.html etc...
    Options FollowSymLinks MultiViews
    # Autorise les htaccess
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>
    # Log pour les erreurs
    ErrorLog ${APACHE_LOG_DIR}/error.log
    LogLevel warn
    # Log des connexion au site
    CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>

    pour la commande netstat -atpn :

    Connexions Internet actives (serveurs et établies)
    Proto Recv-Q Send-Q Adresse locale Adresse distante Etat PID/Program name
    tcp 0 0 0.0.0.0:40555 0.0.0.0:* LISTEN 865/rpc.statd
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 852/portmap
    tcp 0 0 0.0.0.0:10000 0.0.0.0:* LISTEN 1418/perl
    tcp 0 0 0.0.0.0:4949 0.0.0.0:* LISTEN 1653/munin-node
    tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 1582/proftpd: (acce
    tcp 0 0 192.168.1.142:53 0.0.0.0:* LISTEN 1115/named
    tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 1115/named
    tcp 0 0 0.0.0.0:4598 0.0.0.0:* LISTEN 1030/monit
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 1165/sshd
    tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 1567/master
    tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 1115/named
    tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 1309/mysqld
    tcp 0 52 192.168.1.142:22 192.168.1.10:53416 ESTABLISHED 9819/0
    tcp6 0 0 :::139 :::* LISTEN 1062/smbd
    tcp6 0 0 :::110 :::* LISTEN 1125/couriertcpd
    tcp6 0 0 :::143 :::* LISTEN 1154/couriertcpd
    tcp6 0 0 :::80 :::* LISTEN 5363/apache2
    tcp6 0 0 :::53 :::* LISTEN 1115/named
    tcp6 0 0 :::22 :::* LISTEN 1165/sshd
    tcp6 0 0 ::1:953 :::* LISTEN 1115/named
    tcp6 0 0 :::445 :::* LISTEN 1062/smbd

    je n'ai pas fais plus sur mon pc de bureau . je ne vois pas pourquoi je devrai configurer le pc sur laquel je tente d'accéder à ce serveur . Le but étant de ne pas toucher au fichier hosts de mon pc .

  5. #5
    Expert Confirmé Sénior
    Homme Profil pro Laurent Willems
    MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!
    Inscrit en
    septembre 2002
    Messages
    3 176
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Willems
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 176
    Points : 5 815
    Points
    5 815

    Par défaut

    Salut,

    En niveau de ton pc windows, tu dois ajouter l'adresse ip de ton serveur dns pour que les noms d'hôtes *.bureau.local puissent être résolus. Est-ce le cas?

    Au niveau de l'apache,

    Il n'y a aucun hostname www.wordpress.bureau.local qui est spécifié dans ta config dns. Tu dois donc mettre wordpress.bureau.local dans la directive ServerName. et au niveau du navigateur tu dois taper l'url http://wordpress.bureau.local
    Alea Jacta Test!

  6. #6

    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    10
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : janvier 2013
    Messages : 10
    Points : -2
    Points
    -2

    Par défaut

    je suis embéter car je ne comprend pas ce que tu me demandes de faire.

  7. #7
    Expert Confirmé Sénior
    Homme Profil pro Laurent Willems
    MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!
    Inscrit en
    septembre 2002
    Messages
    3 176
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Willems
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 176
    Points : 5 815
    Points
    5 815

    Par défaut

    Qu'est ce que tu ne comprends pas exactement? l'ajout de l'ip du serveur dns?

    Si c'est ça, Tu as la manière de faire dans ce lien(point 6)

    http://windows.microsoft.com/en-US/w...CP-IP-settings
    Alea Jacta Test!

  8. #8

    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    10
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : janvier 2013
    Messages : 10
    Points : -2
    Points
    -2

    Par défaut

    ha ok
    ben non je vais pas changer les dns de mes pc sur mon reseau ^^
    ils sont tous configurer en ip fixe avec le dns primaire pour mon routeur en 192.168.1.1
    mes accès internet, réseau fonctionne
    le problème viens pas de là

  9. #9
    Modérateur
    Avatar de becket
    Profil pro Frédéric Brugmans
    Informaticien multitâches
    Inscrit en
    février 2005
    Messages
    1 184
    Détails du profil
    Informations personnelles :
    Nom : Frédéric Brugmans

    Informations professionnelles :
    Activité : Informaticien multitâches
    Secteur : Service public

    Informations forums :
    Inscription : février 2005
    Messages : 1 184
    Points : 2 453
    Points
    2 453

    Par défaut

    Ben justement si car lorsque ton pc demande une résolution, ton routeur est pas censé savoir qu'il existe un bureau.local quelque part

  10. #10

    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    10
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : janvier 2013
    Messages : 10
    Points : -2
    Points
    -2

    Par défaut

    donc je dois mettre quoi dans mes dns sur mes pc ?

  11. #11
    Modérateur
    Avatar de becket
    Profil pro Frédéric Brugmans
    Informaticien multitâches
    Inscrit en
    février 2005
    Messages
    1 184
    Détails du profil
    Informations personnelles :
    Nom : Frédéric Brugmans

    Informations professionnelles :
    Activité : Informaticien multitâches
    Secteur : Service public

    Informations forums :
    Inscription : février 2005
    Messages : 1 184
    Points : 2 453
    Points
    2 453

    Par défaut

    l'adresse ip du serveur sur lequel tu as configuré ce domaine.

  12. #12

    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    10
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : janvier 2013
    Messages : 10
    Points : -2
    Points
    -2

    Par défaut

    bon, j'y étais pas du tout sur cette configuration du fichier de zone
    je ne savais pas qu'il lui fallait indiquez tout mes pc de ma maison ...

    du genre en rajoutant un ligne :

    hallowman IN A 192.168.1.10 et en redémarrant le service bind, ca marche. j'arrive à taper sur mon pc "hallowman" l'adresse blog.maison.lan et j'ai mon site.

    y'a pas un moyen de faire en sorte que TOUT les pcs de chez moi ai accès au site sans pour celà qu'il soit tous indiqué un par un ?? du genre avec une astérisque ou autre ..

    apres il me reste le probleme de l'alias, j'y arrive pas .

    j'ai l'adresse http://blog.maison.lan qui fonctionne ( la zone c'est maison.lan et le serveur reste le meme : 192.168.1.142 )
    mais l'adresse avec les www ne marche pas.
    de quel forme je dois ajouter le CNAME ?
    et dois je le mettre aussi dans la zone inverse ?

    je reedit car en fait ca ne marche toujours pas après redémarrage de mon pc, en fait on es obliger de mettre le dns du serveur ou se trouve BIN dans ma config réseau de chaque pc de chez moi ?

  13. #13
    Modérateur
    Avatar de becket
    Profil pro Frédéric Brugmans
    Informaticien multitâches
    Inscrit en
    février 2005
    Messages
    1 184
    Détails du profil
    Informations personnelles :
    Nom : Frédéric Brugmans

    Informations professionnelles :
    Activité : Informaticien multitâches
    Secteur : Service public

    Informations forums :
    Inscription : février 2005
    Messages : 1 184
    Points : 2 453
    Points
    2 453

    Par défaut

    Je pense que tu as mal compris. Tu dois configurer tes pc pour utiliser ton serveur dns ( qui connait ton nom de domaine local ) et pas configurer ton dns pour renseigner tes pc.

    Pour www, tu peux le configurer en A ou en CNAME, c'est kif-kif.
    Pour le Reverse, cela n'a aucune espèce d'importance dans ton cas.

  14. #14

    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    10
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : janvier 2013
    Messages : 10
    Points : -2
    Points
    -2

    Par défaut

    je ne sais pas si quelqu'un suit toujours mon post mais j'ai trouver une solution.
    peut être c'est ce qu'il fallait faire mais je voudrais avoir confirmation ..

    sur TOUT les pc de ma maison, les téléphone ou autre il faut faire une configuration avec ip fixe et indiquer un dns primaire vers le serveur bind ( 192.168.1.142 dan smomn cas )
    la passerelle reste mon routeur qui lui est 192.168.1.1 ( un netgear )

    c'est ca ?

  15. #15
    Modérateur
    Avatar de becket
    Profil pro Frédéric Brugmans
    Informaticien multitâches
    Inscrit en
    février 2005
    Messages
    1 184
    Détails du profil
    Informations personnelles :
    Nom : Frédéric Brugmans

    Informations professionnelles :
    Activité : Informaticien multitâches
    Secteur : Service public

    Informations forums :
    Inscription : février 2005
    Messages : 1 184
    Points : 2 453
    Points
    2 453

    Par défaut

    C'est ce que j'expliquais dans ma réponse juste avant mais apparemment tu ne lis pas les réponses que l'on te fait.

  16. #16
    Expert Confirmé Sénior
    Homme Profil pro Laurent Willems
    MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!
    Inscrit en
    septembre 2002
    Messages
    3 176
    Détails du profil
    Informations personnelles :
    Nom : Homme Laurent Willems
    Âge : 35
    Localisation : Belgique

    Informations professionnelles :
    Activité : MOA? hahaha - MOE? euhh - Chapeau pointu? turlututu!

    Informations forums :
    Inscription : septembre 2002
    Messages : 3 176
    Points : 5 815
    Points
    5 815

    Par défaut

    Sans commentaire.
    Alea Jacta Test!

  17. #17

    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    10
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : janvier 2013
    Messages : 10
    Points : -2
    Points
    -2

    Par défaut

    sisi
    lu et relu
    mais pour que je comprenne bien . j'aime les confirmation avec des tournure de phrase différentes.

    je lis toujours tout, c'est la moindre des choses il me semble

  18. #18
    Modérateur
    Avatar de becket
    Profil pro Frédéric Brugmans
    Informaticien multitâches
    Inscrit en
    février 2005
    Messages
    1 184
    Détails du profil
    Informations personnelles :
    Nom : Frédéric Brugmans

    Informations professionnelles :
    Activité : Informaticien multitâches
    Secteur : Service public

    Informations forums :
    Inscription : février 2005
    Messages : 1 184
    Points : 2 453
    Points
    2 453

    Par défaut

    Lu et relu ?

    Citation Envoyé par hallowman le 10/01/2013, 18h32
    ...
    Citation Envoyé par becket Hier, 06h54
    ...
    Citation Envoyé par hallowman Aujourd'hui, 12h43
    je ne sais pas si quelqu'un suit toujours
    Lu et relu ?

    Citation Envoyé par becket Hier, 06h54
    Tu dois configurer tes pc pour utiliser ton serveur dns ( qui connait ton nom de domaine local ) et pas configurer ton dns pour renseigner tes pc.

    Citation Envoyé par hallowman Aujourd'hui, 12h43
    je ne sais pas si quelqu'un suit toujours mon post mais j'ai trouver une solution.

    sur TOUT les pc de ma maison, les téléphone ou autre il faut faire une configuration avec ip fixe et indiquer un dns primaire vers le serveur bind
    Je préciserais que tu peux utiliser un serveur dhcp pour obtenir une adresse dynamiquement et fixer un serveur dns "à la main"

  19. #19

    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    10
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : janvier 2013
    Messages : 10
    Points : -2
    Points
    -2

    Par défaut

    merci pour les compléments d'infos .

  20. #20

    Homme Profil pro
    Inscrit en
    janvier 2013
    Messages
    10
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Localisation : France

    Informations forums :
    Inscription : janvier 2013
    Messages : 10
    Points : -2
    Points
    -2

    Par défaut

    bonsoir

    tout fonctionne bien mais j'ai une question :

    Là je viens de refaire un test de boutique dans mon domaine perso .
    j'ai donc créer le virtual host pour apache, puis relancer apache;
    et j'ai rajouter une ligne dans mon fichier de configuration db... à savoir :
    stickers IN A 192.168.1.142 et redémarrer bind.

    normalement quand j'ouvre mon mozilla et que je tape l'adresse :
    stickers.maison.lan je devrai avoir la page mais il n'en ai rien.
    à chaque fois je suis obliger d'ouvrir mon IE9 , taper la même adresse qui plante aussi dans IE9 mais en cliquant sur diagnostiquer les problèmes de connexion tout remarche ( même dans Mozilla apres )

    quelqu'un aurai l'explication pour ca ?

Liens sociaux

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •