p
u
b
l
i
c
i
t
é
publicité

Discussion: FTINCL error RC=20

  1. #21
    Membre confirmé
    Inscrit en
    mars 2004
    Messages
    1 431
    Détails du profil
    Informations forums :
    Inscription : mars 2004
    Messages : 1 431
    Points : 294
    Points
    294

    Par défaut

    je te confirme que ça fonctionne avec un autre membre du pds.

  2. #22
    Expert Confirmé Sénior
    Homme Profil pro
    Ingénieur d'Etude Mainframe
    Inscrit en
    novembre 2012
    Messages
    914
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 34
    Localisation : France, Yvelines (Île de France)

    Informations professionnelles :
    Activité : Ingénieur d'Etude Mainframe
    Secteur : Finance

    Informations forums :
    Inscription : novembre 2012
    Messages : 914
    Points : 5 702
    Points
    5 702

    Par défaut

    Je me demande si cela ne vient pas de ça dans ton SKELETON :

    Code : Sélectionner tout - Visualiser dans une fenêtre à part
    1
    2
    3
    4
    5
    //ISPMLIB  DD DSN=&PREFISP..&VISPF..SISPMENU,DISP=SHR                   
    //ISPSLIB  DD DSN=&PREFISP..&VISPF..SISPSENU,DISP=SHR                   
    //ISPPLIB  DD DSN=&PREFISP..&VISPF..SISPPENU,DISP=SHR                   
    //ISPTLIB  DD DSN=&PREFISP..&VISPF..SISPTENU,DISP=SHR
    Quand le FTINCL se lance il se perd peut être car tu redéfinis d'autres ISP*LIB que celles de ton JCL appelant.

    Tu pourrais créer un nouveau SKELETTON en ajoutant STEP par STEP les éléments de ton SKELETTON d'origine pour voir quelle STEP pose problème pour le FTINCL.

  3. #23
    Membre Expert Avatar de bernard59139
    Profil pro
    Administrateur de base de données
    Inscrit en
    octobre 2006
    Messages
    785
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Administrateur de base de données

    Informations forums :
    Inscription : octobre 2006
    Messages : 785
    Points : 1 520
    Points
    1 520

    Par défaut

    en edit, vérifie que le skelette ne soit pas en NUM ON.

    Il peut arriver que ca déborde...

    edit: si ce n'est pas cela, qu'est-ce qu'il y a dans "NCUSTJCL" sur le record-10?

  4. #24
    Membre confirmé
    Inscrit en
    mars 2004
    Messages
    1 431
    Détails du profil
    Informations forums :
    Inscription : mars 2004
    Messages : 1 431
    Points : 294
    Points
    294

    Par défaut

    bizarre, en changeant le nom du membre ça fonctionne...

  5. #25
    Expert Confirmé Sénior
    Homme Profil pro
    Ingénieur d'Etude Mainframe
    Inscrit en
    novembre 2012
    Messages
    914
    Détails du profil
    Informations personnelles :
    Sexe : Homme
    Âge : 34
    Localisation : France, Yvelines (Île de France)

    Informations professionnelles :
    Activité : Ingénieur d'Etude Mainframe
    Secteur : Finance

    Informations forums :
    Inscription : novembre 2012
    Messages : 914
    Points : 5 702
    Points
    5 702

    Par défaut

    Citation Envoyé par sam01 Voir le message
    bizarre, en changeant le nom du membre ça fonctionne...
    C'était peut être un problème de MOT CLEF réservé par ISPF...

  6. #26
    Membre Expert Avatar de bernard59139
    Profil pro
    Administrateur de base de données
    Inscrit en
    octobre 2006
    Messages
    785
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Administrateur de base de données

    Informations forums :
    Inscription : octobre 2006
    Messages : 785
    Points : 1 520
    Points
    1 520

    Par défaut

    je viens de faire qques tests.

    Tous mes fichiers sont en FB80 (skeletons, rexx, sortie pour le jcl généré).

    je me plante sur ce message d'erreur quand une ligne du généré dépasse la longueur 80.

    Cela m'arrive avec des variables dont le contenu a une longeur trop grande. Cas typique: variable avec des blancs ou contenu mal maitrisé.

    Vérifie qu'il n'y ait pas un truc qui traine en colonne 71, ou avant.

    Qu'y a-t-il en ligne 10 de ton skeleton?

  7. #27
    Membre confirmé
    Inscrit en
    mars 2004
    Messages
    1 431
    Détails du profil
    Informations forums :
    Inscription : mars 2004
    Messages : 1 431
    Points : 294
    Points
    294

    Par défaut

    salut, je pense que les caractères que j'avais : § , > même en commentaire, faisait planter mon REXX.

  8. #28
    Membre Expert Avatar de bernard59139
    Profil pro
    Administrateur de base de données
    Inscrit en
    octobre 2006
    Messages
    785
    Détails du profil
    Informations personnelles :
    Localisation : France

    Informations professionnelles :
    Activité : Administrateur de base de données

    Informations forums :
    Inscription : octobre 2006
    Messages : 785
    Points : 1 520
    Points
    1 520

    Par défaut

    je pense avoir l'explication, même quasi certain.
    je subodore que ton émulateur est configuré en codepage 1147 (francais euro) ou approchant.

    § ,hex('5A') en ebcdic 1147 (francais euro) est équivalent au ! en ebcdic 037 (ebcdic us).

    Le ! (et le | )est pris comme "ou", opérateur de comparaison.

    et comme le systeme est en ebcdic 037 (ou 500, ca dépend des cas), ton § est interprété comme un ! (ou |).


    Bernard

+ Répondre à la discussion
Cette discussion est résolue.
Page 2 sur 2 PremièrePremière 12

Discussions similaires

  1. ERROR: pg_atoi: zero-length string
    Par steelspirit92 dans le forum PostgreSQL
    Réponses: 1
    Dernier message: 23/08/2003, 22h29
  2. [SQL Server] Error converting data type varchar...
    Par Sir Tengu dans le forum MS SQL-Server
    Réponses: 9
    Dernier message: 13/06/2003, 10h46
  3. [Kylix] Kylix c++ error
    Par pacpac dans le forum Kylix
    Réponses: 2
    Dernier message: 10/06/2003, 16h27
  4. [CR] Print Engine error text
    Par afaraji dans le forum SAP Crystal Reports
    Réponses: 1
    Dernier message: 03/09/2002, 15h44
  5. [Kylix] Runtime error 230 avec INDY
    Par Anonymous dans le forum Kylix
    Réponses: 2
    Dernier message: 23/03/2002, 11h51

Partager

Partager
  • Envoyer la discussion sur Viadeo
  • Envoyer la discussion sur Twitter
  • Envoyer la discussion sur Google
  • Envoyer la discussion sur Facebook
  • Envoyer la discussion sur Digg
  • Envoyer la discussion sur Delicious
  • Envoyer la discussion sur MySpace
  • Envoyer la discussion sur Yahoo